aboutsummaryrefslogtreecommitdiff
path: root/www/py-pylons
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-25 18:19:25 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-06-25 18:19:25 +0000
commit5c4d1ce4703554385cd3028a0724bba90431e6f5 (patch)
tree45ebc222739110b038c8a611db9c7e566fb9db4c /www/py-pylons
parent0cf48a6707cb33ee760cdf2efa1610948f63fccb (diff)
downloadports-5c4d1ce4703554385cd3028a0724bba90431e6f5.tar.gz
ports-5c4d1ce4703554385cd3028a0724bba90431e6f5.zip
Notes
Diffstat (limited to 'www/py-pylons')
-rw-r--r--www/py-pylons/Makefile56
-rw-r--r--www/py-pylons/distinfo3
-rw-r--r--www/py-pylons/pkg-descr25
-rw-r--r--www/py-pylons/pkg-plist292
4 files changed, 376 insertions, 0 deletions
diff --git a/www/py-pylons/Makefile b/www/py-pylons/Makefile
new file mode 100644
index 000000000000..8aba757c4f12
--- /dev/null
+++ b/www/py-pylons/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: py-pylons
+# Date created: Thu Jun 21 16:05:21 MSD 2007
+# Whom: Denis Shaposhnikov <dsh@vlink.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pylons
+PORTVERSION= 0.9.5
+CATEGORIES= www python
+MASTER_SITES= http://pylonshq.com/download/0.9.5/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Pylons-${PORTVERSION}
+
+MAINTAINER= dsh@vlink.ru
+COMMENT= Pylons Web Framework
+
+BUILD_DEPENDS= ${EASY_INSTALL_CMD}:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS= ${EASY_INSTALL_CMD}:${PORTSDIR}/devel/py-setuptools \
+ ${PYTHON_PKGNAMEPREFIX}Paste>=1.3:${PORTSDIR}/www/py-paste \
+ ${PYTHON_PKGNAMEPREFIX}PasteDeploy>=1.3:${PORTSDIR}/www/py-pastedeploy \
+ ${PYTHON_PKGNAMEPREFIX}PasteScript>=1.3.2:${PORTSDIR}/www/py-pastescript \
+ ${PYTHON_PKGNAMEPREFIX}beaker>=0.6.3:${PORTSDIR}/www/py-beaker \
+ ${PYTHON_PKGNAMEPREFIX}decorator>=2.0.1:${PORTSDIR}/devel/py-decorator \
+ ${PYTHON_PKGNAMEPREFIX}formencode>=0.7:${PORTSDIR}/www/py-formencode \
+ ${PYTHON_PKGNAMEPREFIX}mako>=0.1.5:${PORTSDIR}/textproc/py-mako \
+ ${PYTHON_PKGNAMEPREFIX}nose>=0.9.2:${PORTSDIR}/devel/py-nose \
+ ${PYTHON_PKGNAMEPREFIX}routes>=1.6.3:${PORTSDIR}/www/py-routes \
+ ${PYTHON_PKGNAMEPREFIX}simplejson>=1.7.1:${PORTSDIR}/devel/py-simplejson \
+ ${PYTHON_PKGNAMEPREFIX}webhelpers>=0.3:${PORTSDIR}/www/py-webhelpers \
+ myghty>=1.1:${PORTSDIR}/www/myghty
+
+USE_PYTHON= 2.4
+USE_PYDISTUTILS= yes
+
+PYPYLONS_EGG= Pylons-${PORTVERSION}-py${PYTHON_VER}.egg
+
+PLIST_SUB= EASY_INSTALL_CMD=${EASY_INSTALL_CMD} \
+ PYPYLONS_EGG=${PYPYLONS_EGG}
+
+EASY_INSTALL_CMD?= easy_install-${PYTHON_VER}
+
+DOCSDIR= ${TARGETDIR}/share/doc/py-${PORTNAME}
+
+post-install:
+ ${FIND} ${PYTHON_SITELIBDIR}/${PYPYLONS_EGG} \
+ -type d -exec ${CHMOD} 755 {} +
+ ${FIND} ${PYTHON_SITELIBDIR}/${PYPYLONS_EGG} \
+ -type f -exec ${CHMOD} ${SHAREMODE} {} +
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC}/docs/ && ${COPYTREE_SHARE} \* ${DOCSDIR})
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/py-pylons/distinfo b/www/py-pylons/distinfo
new file mode 100644
index 000000000000..6a5377880b3d
--- /dev/null
+++ b/www/py-pylons/distinfo
@@ -0,0 +1,3 @@
+MD5 (Pylons-0.9.5.tar.gz) = 929825ab20610f4ec15038c2a590d8cf
+SHA256 (Pylons-0.9.5.tar.gz) = 03f6a049cd2d2ddcedfdd54dcfca213bd0e394bd00528a0d9c114cb1ec1c45ff
+SIZE (Pylons-0.9.5.tar.gz) = 179468
diff --git a/www/py-pylons/pkg-descr b/www/py-pylons/pkg-descr
new file mode 100644
index 000000000000..0c842dd786ee
--- /dev/null
+++ b/www/py-pylons/pkg-descr
@@ -0,0 +1,25 @@
+The Pylons web framework is aimed at making webapps and large
+programmatic website development in Python easy. Several key points:
+
+* A framework to make writing web applications in Python easy
+
+* Inspired by Rails and TurboGears
+
+* Utilizes a minimalist, component-based philosophy that makes it easy
+ to expand on
+
+* Harness existing knowledge about Python
+
+Pylons makes it easy to expand on your knowledge of Python to master
+Pylons for web development. Using a MVC style dispath, Python
+knowledge is used at various levels:
+
+* The Controller is just a basic Python class, called for each
+ request. Customizing the response is as easy as overriding __call__
+ to make your webapp work how you want.
+
+* Myghty templating compiles directly to Python byte-code for speed
+ and utilizes Python for template control rather than creating its
+ own template syntax for "for, while, etc"
+
+WWW: http://www.pylonshq.com/
diff --git a/www/py-pylons/pkg-plist b/www/py-pylons/pkg-plist
new file mode 100644
index 000000000000..d1878cc1e1da
--- /dev/null
+++ b/www/py-pylons/pkg-plist
@@ -0,0 +1,292 @@
+@unexec %%EASY_INSTALL_CMD%% -N -m -q %D/%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/EGG-INFO/entry_points.txt
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/EGG-INFO/requires.txt
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/commands.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/commands.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/commands.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/config.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/config.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/config.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/controllers.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/controllers.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/controllers.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/database.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/database.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/database.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/decorator.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/decorator.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/decorator.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/decorators/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/decorators/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/decorators/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/decorators/_decorator.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/decorators/_decorator.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/decorators/_decorator.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/decorators/cache.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/decorators/cache.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/decorators/cache.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/decorators/rest.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/decorators/rest.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/decorators/rest.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/error.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/error.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/error.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/helpers.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/helpers.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/helpers.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/i18n/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/i18n/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/i18n/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/i18n/translation.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/i18n/translation.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/i18n/translation.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/legacy.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/legacy.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/legacy.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/media/img/bar-bg.png
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/media/img/bg.jpg
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/media/img/hatch-yellow.png
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/media/img/header.png
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/media/img/highlight.png
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/media/img/icon-16.png
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/media/img/logo.gif
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/media/img/main-nav-bg-on.png
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/media/img/main-nav-bg.png
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/media/img/plus.jpg
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/media/img/tab-brown.png
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/media/img/tab-white.png
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/media/img/tab-yellow-highlight.png
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/media/img/tab-yellow.png
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/media/img/warning.gif
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/media/style/orange.css
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/middleware.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/middleware.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/middleware.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/controller.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+egg+.egg-info/paste_deploy_config.ini_tmpl_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/__init__.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/config/__init__.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/config/environment.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/config/middleware.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/config/routing.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/controllers/__init__.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/controllers/error.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/controllers/template.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/docs/index.txt_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/i18n/__init__.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/lib/__init__.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/lib/app_globals.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/lib/base.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/lib/helpers.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/models/__init__.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/public/index.html_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/templates/autohandler
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/tests/__init__.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/tests/functional/__init__.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/tests/test_models.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/websetup.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/README.txt_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/development.ini_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/ez_setup/README.txt
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/ez_setup/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/ez_setup/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/ez_setup/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/setup.cfg_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/setup.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/test.ini_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/+egg+.egg-info/paste_deploy_config.ini_tmpl_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/+package+/__init__.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/+package+/controllers/__init__.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/+package+/helpers.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/+package+/public/index.html_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/+package+/routing.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/+package+/templates/autohandler
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/+package+/tests/__init__.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/+package+/wsgiapp.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/README.txt_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/development.ini_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/ez_setup/README.txt
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/ez_setup/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/ez_setup/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/ez_setup/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/setup.cfg_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/setup.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/test.ini_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/restcontroller.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/test_controller.py_tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templating.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templating.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templating.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/util.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/util.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/util.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/wsgiapp.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/wsgiapp.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/wsgiapp.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/conftest.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/conftest.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/conftest.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_units/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_units/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_units/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_units/test_controller.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_units/test_controller.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_units/test_controller.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_units/test_decorator_cache.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_units/test_decorator_cache.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_units/test_decorator_cache.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_units/test_deprecated.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_units/test_deprecated.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_units/test_deprecated.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_units/test_xmlrpc.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_units/test_xmlrpc.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_units/test_xmlrpc.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/app_globals.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/app_globals.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/app_globals.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/base_with_xmlrpc.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/base_with_xmlrpc.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/base_with_xmlrpc.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/cache_controller.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/cache_controller.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/cache_controller.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/controller_sample.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/controller_sample.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/controller_sample.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/controller_xmlrpc.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/controller_xmlrpc.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/controller_xmlrpc.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/development.ini
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_controller_cache_decorator.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_controller_cache_decorator.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_controller_cache_decorator.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_controller_xmlrpc.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_controller_xmlrpc.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_controller_xmlrpc.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_sample_controller_cheetah.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_sample_controller_cheetah.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_sample_controller_cheetah.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_sample_controller_i18n.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_sample_controller_i18n.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_sample_controller_i18n.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_sample_controller_sample1.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_sample_controller_sample1.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_sample_controller_sample1.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_sample_controller_sample2.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_sample_controller_sample2.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_sample_controller_sample2.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_sample_controller_sample3.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_sample_controller_sample3.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_sample_controller_sample3.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_sample_controller_sample4.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_sample_controller_sample4.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/functional_sample_controller_sample4.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/messages.ja.mo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/messages.ja.po
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/messages.pot
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/middleware_cheetah_engine.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/middleware_cheetah_engine.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/middleware_cheetah_engine.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/middleware_def_engine.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/middleware_def_engine.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/middleware_def_engine.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/middleware_two_engines.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/middleware_two_engines.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/middleware_two_engines.pyo
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/test_myghty.myt
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/testcheetah.tmpl
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest/testkid.kid
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/test_make_project.py
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/test_make_project.pyc
+%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/test_make_project.pyo
+%%DOCSDIR%%/adding_docs.txt
+%%DOCSDIR%%/application_configuration.txt
+%%DOCSDIR%%/application_setup.txt
+%%DOCSDIR%%/caching.txt
+%%DOCSDIR%%/deployment.txt
+%%DOCSDIR%%/error_documents.txt
+%%DOCSDIR%%/faq.txt
+%%DOCSDIR%%/flickrsearch.txt
+%%DOCSDIR%%/form_handling.txt
+%%DOCSDIR%%/getting_started.txt
+%%DOCSDIR%%/hosting.txt
+%%DOCSDIR%%/index.txt
+%%DOCSDIR%%/install.txt
+%%DOCSDIR%%/interactive_debugger.txt
+%%DOCSDIR%%/internationalization.txt
+%%DOCSDIR%%/logging.txt
+%%DOCSDIR%%/pudge_template/at.png
+%%DOCSDIR%%/pudge_template/class.html
+%%DOCSDIR%%/pudge_template/common.html
+%%DOCSDIR%%/pudge_template/document.html
+%%DOCSDIR%%/pudge_template/layout.css
+%%DOCSDIR%%/pudge_template/layout.html
+%%DOCSDIR%%/pudge_template/master-index.html
+%%DOCSDIR%%/pudge_template/member.html
+%%DOCSDIR%%/pudge_template/module-index.html
+%%DOCSDIR%%/pudge_template/module.html
+%%DOCSDIR%%/pudge_template/package-index.html
+%%DOCSDIR%%/pudge_template/pudge.css
+%%DOCSDIR%%/pudge_template/rst.css
+%%DOCSDIR%%/pudge_template/silvercity.css
+%%DOCSDIR%%/pudge_template/transitions.html
+%%DOCSDIR%%/pylonsdev.txt
+%%DOCSDIR%%/quick_wiki.txt
+%%DOCSDIR%%/security_policy.txt
+%%DOCSDIR%%/template_plugins.txt
+%%DOCSDIR%%/testing_web_application.txt
+%%DOCSDIR%%/webserver_config.txt
+%%DOCSDIR%%/windowsnotes.txt
+%%DOCSDIR%%/wsgi.txt
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/i18n
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/decorators
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+egg+.egg-info
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/config
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/controllers
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/docs
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/i18n
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/lib
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/models
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/public
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/templates
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/tests/functional
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+/tests
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/+package+
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project/ez_setup
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/default_project
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/+egg+.egg-info
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/+package+/controllers
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/+package+/public
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/+package+/templates
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/+package+/tests
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/+package+
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project/ez_setup
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates/minimal_project
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/templates
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/media/img
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/media/style
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons/media
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/pylons
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_units
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps/filestotest
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests/test_webapps
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/tests
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%/EGG-INFO
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%
+@dirrm %%DOCSDIR%%/pudge_template
+@dirrm %%DOCSDIR%%
+@exec %%EASY_INSTALL_CMD%% -N -q %D/%%PYTHON_SITELIBDIR%%/%%PYPYLONS_EGG%%