aboutsummaryrefslogtreecommitdiff
path: root/www/py-qp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-20 03:22:01 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-20 03:22:01 +0000
commit1da41445289c847446670aae2e462115bc456feb (patch)
treeff5bbdcc7ec41cd823f464dec6556a19903aa190 /www/py-qp
parentd318fafe0fe451e3a1a63e641653e730e0b645b0 (diff)
downloadports-1da41445289c847446670aae2e462115bc456feb.tar.gz
ports-1da41445289c847446670aae2e462115bc456feb.zip
Notes
Diffstat (limited to 'www/py-qp')
-rw-r--r--www/py-qp/Makefile14
-rw-r--r--www/py-qp/pkg-descr9
2 files changed, 10 insertions, 13 deletions
diff --git a/www/py-qp/Makefile b/www/py-qp/Makefile
index 39cebf00874f..23db8621333c 100644
--- a/www/py-qp/Makefile
+++ b/www/py-qp/Makefile
@@ -13,28 +13,26 @@ COMMENT= Python web framework to use qpy and durus together
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}durus>=0:${PORTSDIR}/devel/py-durus \
${PYTHON_PKGNAMEPREFIX}qpy>=1.7:${PORTSDIR}/www/py-qpy
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}durus>=0:${PORTSDIR}/devel/py-durus \
- ${PYTHON_PKGNAMEPREFIX}qpy>=1.7:${PORTSDIR}/www/py-qpy
+RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
MAKE_ENV= USE_DISTUTILS=yes
-USE_PYTHON= 2.5-2.7
USE_PYDISTUTILS=yes
+USE_PYTHON= -2.7
SUB_FILES= pkg-message
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/
- cd ${WRKSRC}/ && ${INSTALL_DATA} CHANGES.txt LICENSE.txt README.txt ${DOCSDIR}/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} CHANGES.txt LICENSE.txt README.txt ${STAGEDIR}${DOCSDIR}/
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
- cd ${WRKSRC}/ && ${PYTHON_CMD} ${PYSETUP} install_demo_sites ${EXAMPLESDIR}/
+ cd ${WRKSRC}/ && ${PYTHON_CMD} ${PYSETUP} install_demo_sites ${STAGEDIR}${EXAMPLESDIR}/
.endif
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/www/py-qp/pkg-descr b/www/py-qp/pkg-descr
index 8369fd0f5b44..13b3d0e59ccb 100644
--- a/www/py-qp/pkg-descr
+++ b/www/py-qp/pkg-descr
@@ -1,7 +1,6 @@
-This is QP, a package for defining and running multiple web
-applications based on Durus for persistence, standard persistent
-Session and User classes, easy interactive database sessions, qpy for
-assembling html, and Quixote2-style forms and path traversal. QP makes
-it easier than ever to use these tools together.
+This is QP, a package for defining and running multiple web applications based
+on Durus for persistence, standard persistent Session and User classes, easy
+interactive database sessions, qpy for assembling html, and Quixote2-style forms
+and path traversal. QP makes it easier than ever to use these tools together.
WWW: http://www.mems-exchange.org/software/qp/