aboutsummaryrefslogtreecommitdiff
path: root/www/py-rssdler
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-10-10 04:36:38 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-10-10 04:36:38 +0000
commitc14b231292c50c116818c43bcdfe9df49901c79e (patch)
treed91f1d2421359df5fdc1eacb6aadd2512a2ba6cc /www/py-rssdler
parent7b221796207d98d66770e00106c57046dd0e1010 (diff)
downloadports-c14b231292c50c116818c43bcdfe9df49901c79e.tar.gz
ports-c14b231292c50c116818c43bcdfe9df49901c79e.zip
Notes
Diffstat (limited to 'www/py-rssdler')
-rw-r--r--www/py-rssdler/Makefile2
-rw-r--r--www/py-rssdler/files/patch-rssdler.py10
2 files changed, 11 insertions, 1 deletions
diff --git a/www/py-rssdler/Makefile b/www/py-rssdler/Makefile
index 6fb0f39195e8..eff548290e60 100644
--- a/www/py-rssdler/Makefile
+++ b/www/py-rssdler/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rssdler
PORTVERSION= 0.4.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www python
MASTER_SITES= GOOGLE_CODE
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/www/py-rssdler/files/patch-rssdler.py b/www/py-rssdler/files/patch-rssdler.py
new file mode 100644
index 000000000000..aa94ab3cb40a
--- /dev/null
+++ b/www/py-rssdler/files/patch-rssdler.py
@@ -0,0 +1,10 @@
+--- ./rssdler.py.orig 2010-10-10 03:58:44.112133159 +0000
++++ ./rssdler.py 2010-10-10 03:59:10.937002223 +0000
+@@ -2180,6 +2180,7 @@
+ elif param == "--purge-saved": _action = 'purge-saved'
+ elif param == "--comment-config": _action = 'comment-config'
+ signal.signal(signal.SIGINT, signalHandler)
++ signal.signal(signal.SIGTERM, signalHandler)
+ sys.excepthook = setDebug #this is NOT supposed to be called!
+ if _action == 'comment-config':
+ print(commentConfig)