aboutsummaryrefslogtreecommitdiff
path: root/www/py-spyne
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-12-28 13:14:37 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-12-28 13:14:37 +0000
commite1334008cda41da93e04f2ca79d1e939a47522f6 (patch)
tree8c8386a0b4de5d5542337ee17497c4871bd2018b /www/py-spyne
parentd2f78922dabe99d41a5625ee9a591794b89e10bf (diff)
Notes
Diffstat (limited to 'www/py-spyne')
-rw-r--r--www/py-spyne/Makefile20
-rw-r--r--www/py-spyne/distinfo2
-rw-r--r--www/py-spyne/pkg-descr8
3 files changed, 30 insertions, 0 deletions
diff --git a/www/py-spyne/Makefile b/www/py-spyne/Makefile
new file mode 100644
index 000000000000..3f30b3a31939
--- /dev/null
+++ b/www/py-spyne/Makefile
@@ -0,0 +1,20 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= spyne
+PORTVERSION= 2.11.0
+CATEGORIES= www devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Transport and architecture agnostic RPC library
+
+LICENSE= LGPL21
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>=0:${PORTSDIR}/devel/py-pytz
+
+USE_PYTHON= autoplist distutils
+USES= python:2
+
+.include <bsd.port.mk>
diff --git a/www/py-spyne/distinfo b/www/py-spyne/distinfo
new file mode 100644
index 000000000000..20599e95d7d2
--- /dev/null
+++ b/www/py-spyne/distinfo
@@ -0,0 +1,2 @@
+SHA256 (spyne-2.11.0.tar.gz) = 37b9eb8f600655607d4adf5ad9ab93e6718d1fcefe8917d3d59321188fd2328d
+SIZE (spyne-2.11.0.tar.gz) = 265456
diff --git a/www/py-spyne/pkg-descr b/www/py-spyne/pkg-descr
new file mode 100644
index 000000000000..56c3fa649103
--- /dev/null
+++ b/www/py-spyne/pkg-descr
@@ -0,0 +1,8 @@
+Spyne is a Python RPC toolkit that makes it easy to expose online services that
+have a well-defined API using multiple protocols and transports.
+
+It integrates with popular Python web frameworks as well as libraries like
+SQLAlchemy to keep your code as DRY (Don't Repeat Yourself) as possible.
+
+WWW: https://pypi.python.org/pypi/spyne
+WWW: http://spyne.io/