aboutsummaryrefslogtreecommitdiff
path: root/www/py-tgwebservices/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2007-02-17 14:52:39 +0000
committerNicola Vitale <nivit@FreeBSD.org>2007-02-17 14:52:39 +0000
commit30d3a9c60ca3d01a87e636c99c97c97fc1bd3e8f (patch)
treebcbac26e56122b9e44057a18bd917c61bc303aed /www/py-tgwebservices/Makefile
parentcc6371ad2333edf4153301305a408813cfb5654f (diff)
downloadports-30d3a9c60ca3d01a87e636c99c97c97fc1bd3e8f.tar.gz
ports-30d3a9c60ca3d01a87e636c99c97c97fc1bd3e8f.zip
Notes
Diffstat (limited to 'www/py-tgwebservices/Makefile')
-rw-r--r--www/py-tgwebservices/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/www/py-tgwebservices/Makefile b/www/py-tgwebservices/Makefile
new file mode 100644
index 000000000000..45a5b7fc665c
--- /dev/null
+++ b/www/py-tgwebservices/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: py-tgwebservices
+# Date created: 2007-02-14
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tgwebservices
+PORTVERSION= 1.0.1
+CATEGORIES= www python
+MASTER_SITES= http://cheeseshop.python.org/packages/source/T/${PYTGWEBSERVICES}/ \
+ LOCAL/nivit/${PYTGWEBSERVICES}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PYTGWEBSERVICES}-${PORTVERSION}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= Multiprotocol Web Services for TurboGears
+
+BUILD_DEPENDS= ${EASY_INSTALL_CMD}:${PORTSDIR}/devel/py-setuptools \
+ ${PYTHON_PKGNAMEPREFIX}TurboGears>=1.0.1:${PORTSDIR}/www/py-turbogears \
+ ${PYTHON_PKGNAMEPREFIX}Genshi>=0.3.6:${PORTSDIR}/textproc/py-genshi
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= yes
+
+PLIST_SUB= EASY_INSTALL_CMD=${EASY_INSTALL_CMD} \
+ PORTNAME=${PORTNAME} PORTVERSION=${PORTVERSION} \
+ PYTGWEBSERVICES_EGG=${PYTGWEBSERVICES_EGG}
+
+EASY_INSTALL_CMD?= easy_install-${PYTHON_VER}
+
+PYTGWEBSERVICES= TGWebServices
+PYTGWEBSERVICES_EGG= ${PYTGWEBSERVICES}-${PORTVERSION}-py${PYTHON_VER}.egg
+
+.include <bsd.port.mk>