aboutsummaryrefslogtreecommitdiff
path: root/www/py-turbodjango
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2009-01-20 17:22:11 +0000
committerNicola Vitale <nivit@FreeBSD.org>2009-01-20 17:22:11 +0000
commite7e65734072bb77538c1a034b35e19e9cd78c933 (patch)
treeaff6f4621ec7ec28a99111e4a2bd36ac35953c20 /www/py-turbodjango
parentc1e95e4decc6f0fe3550eddb7a302b1f203c9ada (diff)
downloadports-e7e65734072bb77538c1a034b35e19e9cd78c933.tar.gz
ports-e7e65734072bb77538c1a034b35e19e9cd78c933.zip
Notes
Diffstat (limited to 'www/py-turbodjango')
-rw-r--r--www/py-turbodjango/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/www/py-turbodjango/Makefile b/www/py-turbodjango/Makefile
index dcb94aa7b360..4d8b111bd068 100644
--- a/www/py-turbodjango/Makefile
+++ b/www/py-turbodjango/Makefile
@@ -24,8 +24,7 @@ RUN_DEPENDS= ${EASY_INSTALL_CMD}:${PORTSDIR}/devel/py-setuptools \
NO_BUILD= yes
-# Use the same version of www/py-turbogears
-USE_PYTHON= 2.4
+USE_PYTHON= yes
PLIST_SUB= EASY_INSTALL_CMD=${EASY_INSTALL_CMD} \
PORTNAME=${PORTNAME} PORTVERSION=${PYTURBODJANGO_VER} \
@@ -45,4 +44,10 @@ do-extract:
do-install:
@${EASY_INSTALL_CMD} ${EASY_INSTALL_ARGS} ${DISTDIR}/${PYTURBODJANGO_EGG}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 240 || ${PYTHON_REL} >= 250
+IGNORE= the distribution file is available only for Python 2.4
+.endif
+
+.include <bsd.port.post.mk>