aboutsummaryrefslogtreecommitdiff
path: root/www/py-twistedWeb/Makefile
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-04-15 04:56:19 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-04-15 04:56:19 +0000
commita72fc28eda3631d06dd57faffc235fdc366a4a41 (patch)
tree70436f949fbef2d67fc6b95e78a082678e5f3d67 /www/py-twistedWeb/Makefile
parent116dcd0a33d89080f859520d752a7fb419a023b1 (diff)
Notes
Diffstat (limited to 'www/py-twistedWeb/Makefile')
-rw-r--r--www/py-twistedWeb/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/www/py-twistedWeb/Makefile b/www/py-twistedWeb/Makefile
new file mode 100644
index 000000000000..ba8657f60a1c
--- /dev/null
+++ b/www/py-twistedWeb/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: py-twistedWeb
+# Date created: 14 April 2005
+# Whom: Neal Nelson <neal@nelson.name>
+#
+# $FreeBSD$
+#
+
+PORTNAME= twistedWeb
+PORTVERSION= 0.5.0
+CATEGORIES= www devel python
+MASTER_SITES= http://twistedmatrix.com/downloads/Web/0.5/ \
+ http://tmrc.mit.edu/mirror/twisted/Web/0.5/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= TwistedWeb-${PORTVERSION}
+
+MAINTAINER= neal@nelson.name
+COMMENT= An HTTP protocol implementation together with clients and servers
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/twisted:${PORTSDIR}/devel/py-twistedCore
+
+WRKSRC= ${WRKDIR}/TwistedWeb-${PORTVERSION}
+
+USE_BZIP2= yes
+USE_PYTHON= 2.2+
+USE_PYDISTUTILS= yes
+
+PLIST_SUB+= S=${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;}
+
+.include <bsd.port.mk>