aboutsummaryrefslogtreecommitdiff
path: root/www/py-webware-component
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-04-11 19:32:41 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-04-11 19:32:41 +0000
commit585665a9b6acadc044fc0cb59f1fbd62c7795e0c (patch)
tree36a4d32ffb918b360b432eda565cd179d1bd85c2 /www/py-webware-component
parent494ceff9706c8662d7b04f06e383de09b3004195 (diff)
downloadports-585665a9b6acadc044fc0cb59f1fbd62c7795e0c.tar.gz
ports-585665a9b6acadc044fc0cb59f1fbd62c7795e0c.zip
Notes
Diffstat (limited to 'www/py-webware-component')
-rw-r--r--www/py-webware-component/Makefile33
-rw-r--r--www/py-webware-component/distinfo2
-rw-r--r--www/py-webware-component/pkg-descr9
-rw-r--r--www/py-webware-component/pkg-plist15
4 files changed, 59 insertions, 0 deletions
diff --git a/www/py-webware-component/Makefile b/www/py-webware-component/Makefile
new file mode 100644
index 000000000000..6571c0669c99
--- /dev/null
+++ b/www/py-webware-component/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: py-webware-component
+# Date created: 2005-03-25
+# Whom: Choe, Cheng-Dae
+#
+# $FreeBSD$
+#
+
+PORTNAME= Component
+PORTVERSION= 0.1
+CATEGORIES= www python
+MASTER_SITES= http://www.webwareforpython.org/downloads/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}webware-
+
+MAINTAINER= whitekid@gmail.com
+COMMENT= Webware servlet component extension
+
+RUN_DEPENDS= ${LOCALBASE}/share/webware/__init__.py:${PORTSDIR}/www/py-webware
+
+USE_PYTHON= yes
+
+do-build:
+ @${ECHO_MSG} -n ">> Compiling ..."
+ @${PYTHON_CMD} -c "import compileall; compileall.compile_dir('${WRKSRC}')"
+ @${ECHO_MSG} " [ DONE ]"
+
+do-install:
+ @${ECHO_CMD} -n ">> Installing ..."
+ @cd ${WRKSRC} && \
+ ${FIND} . -type d -exec ${MKDIR} "${PREFIX}/share/webware/${PORTNAME}/{}" \; && \
+ ${FIND} . -not -type d -exec ${INSTALL_DATA} "{}" "${PREFIX}/share/webware/${PORTNAME}/{}" \;
+ @${ECHO_MSG} " [ DONE ]"
+
+.include <bsd.port.mk>
diff --git a/www/py-webware-component/distinfo b/www/py-webware-component/distinfo
new file mode 100644
index 000000000000..a7cf0601e910
--- /dev/null
+++ b/www/py-webware-component/distinfo
@@ -0,0 +1,2 @@
+MD5 (Component-0.1.tar.gz) = 4511d6ff605994a739e0079902fa6cf8
+SIZE (Component-0.1.tar.gz) = 10392
diff --git a/www/py-webware-component/pkg-descr b/www/py-webware-component/pkg-descr
new file mode 100644
index 000000000000..b9ca9c3a5d37
--- /dev/null
+++ b/www/py-webware-component/pkg-descr
@@ -0,0 +1,9 @@
+From document:
+
+ Components are useful if you have code that should know about the
+request and response, and possible intercept it. If the code doesn't need to
+know about the request at all, you should just create a normal Python library,
+and call into it explicitly. Components can also be a convenient way to add new
+convenience methods to your servlet.
+
+WWW: http://wiki.w4py.org/component.html
diff --git a/www/py-webware-component/pkg-plist b/www/py-webware-component/pkg-plist
new file mode 100644
index 000000000000..686f0a79f0b5
--- /dev/null
+++ b/www/py-webware-component/pkg-plist
@@ -0,0 +1,15 @@
+share/webware/Component/Docs/default.css
+share/webware/Component/Docs/index.html
+share/webware/Component/Docs/index.txt
+share/webware/Component/Properties.py
+share/webware/Component/Properties.pyc
+share/webware/Component/__init__.py
+share/webware/Component/__init__.pyc
+share/webware/Component/component.py
+share/webware/Component/component.pyc
+share/webware/Component/cpage.py
+share/webware/Component/cpage.pyc
+share/webware/Component/notify.py
+share/webware/Component/notify.pyc
+@dirrm share/webware/Component/Docs
+@dirrm share/webware/Component