aboutsummaryrefslogtreecommitdiff
path: root/www/pyweblib
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-05-24 19:34:24 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-05-24 19:34:24 +0000
commit7d6a1437f4fa4179a7bd695dc350a22138bbe3f8 (patch)
tree8af96c90f49e26221a9850995a9125380d7d8594 /www/pyweblib
parent94196219462bff28769071051d85bae754531240 (diff)
downloadports-7d6a1437f4fa4179a7bd695dc350a22138bbe3f8.tar.gz
ports-7d6a1437f4fa4179a7bd695dc350a22138bbe3f8.zip
Notes
Diffstat (limited to 'www/pyweblib')
-rw-r--r--www/pyweblib/Makefile24
-rw-r--r--www/pyweblib/pkg-plist13
2 files changed, 18 insertions, 19 deletions
diff --git a/www/pyweblib/Makefile b/www/pyweblib/Makefile
index 72810e0ee105..cfade191c741 100644
--- a/www/pyweblib/Makefile
+++ b/www/pyweblib/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pyweblib
PORTVERSION= 1.3.10
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.stroeder.com/pylib/PyWebLib/download/
@@ -14,23 +15,22 @@ LICENSE= GPLv2
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-DOCS= pydoc/pyweblib.forms.html \
- pydoc/pyweblib.helper.html \
- pydoc/pyweblib.html \
- pydoc/pyweblib.httphelper.html \
- pydoc/pyweblib.session.html \
- pydoc/pyweblib.sslenv.html
+PORTDOCS= pyweblib.forms.html pyweblib.helper.html \
+ pyweblib.html pyweblib.httphelper.html \
+ pyweblib.session.html pyweblib.sslenv.html
EXAMPLES= *.py
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
post-install:
- ${MKDIR} ${EXAMPLESDIR} ${EXAMPLESDIR}/cgi-bin
+ @${MKDIR} ${EXAMPLESDIR} ${EXAMPLESDIR}/cgi-bin
${INSTALL_DATA} ${WRKSRC}/cgi-bin/${EXAMPLES} ${EXAMPLESDIR}/cgi-bin
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}/pydoc
-.for file in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/htdocs/${file} ${DOCSDIR}/${file}
-.endfor
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/htdocs/pydoc/,} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/www/pyweblib/pkg-plist b/www/pyweblib/pkg-plist
index bd550a622009..9d5015d4db29 100644
--- a/www/pyweblib/pkg-plist
+++ b/www/pyweblib/pkg-plist
@@ -19,13 +19,12 @@
@dirrm %%PYTHON_SITELIBDIR%%/pyweblib
@comment -
@comment --- HTML documentation ---
-%%PORTDOCS%%%%DOCSDIR%%/pydoc/pyweblib.forms.html
-%%PORTDOCS%%%%DOCSDIR%%/pydoc/pyweblib.helper.html
-%%PORTDOCS%%%%DOCSDIR%%/pydoc/pyweblib.html
-%%PORTDOCS%%%%DOCSDIR%%/pydoc/pyweblib.httphelper.html
-%%PORTDOCS%%%%DOCSDIR%%/pydoc/pyweblib.session.html
-%%PORTDOCS%%%%DOCSDIR%%/pydoc/pyweblib.sslenv.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/pydoc
+%%PORTDOCS%%%%DOCSDIR%%/pyweblib.forms.html
+%%PORTDOCS%%%%DOCSDIR%%/pyweblib.helper.html
+%%PORTDOCS%%%%DOCSDIR%%/pyweblib.html
+%%PORTDOCS%%%%DOCSDIR%%/pyweblib.httphelper.html
+%%PORTDOCS%%%%DOCSDIR%%/pyweblib.session.html
+%%PORTDOCS%%%%DOCSDIR%%/pyweblib.sslenv.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@comment -
@comment --- some examples here ---