aboutsummaryrefslogtreecommitdiff
path: root/www/qdecoder
diff options
context:
space:
mode:
authorCHOI Junho <cjh@FreeBSD.org>2008-11-28 11:16:47 +0000
committerCHOI Junho <cjh@FreeBSD.org>2008-11-28 11:16:47 +0000
commitec511d7330e2cedb2f22eefe2728569e3363d273 (patch)
treeafabc1a443e0305facd3eaf61369a691fc1e40ed /www/qdecoder
parent92f3b53fcdc5b855dc3d61851adae809ead5c52a (diff)
downloadports-ec511d7330e2cedb2f22eefe2728569e3363d273.tar.gz
ports-ec511d7330e2cedb2f22eefe2728569e3363d273.zip
Notes
Diffstat (limited to 'www/qdecoder')
-rw-r--r--www/qdecoder/Makefile83
-rw-r--r--www/qdecoder/distinfo6
-rw-r--r--www/qdecoder/files/patch-src::Makefile.in52
-rw-r--r--www/qdecoder/pkg-descr26
-rw-r--r--www/qdecoder/pkg-plist102
5 files changed, 160 insertions, 109 deletions
diff --git a/www/qdecoder/Makefile b/www/qdecoder/Makefile
index b66b870aecad..0f19efbc9297 100644
--- a/www/qdecoder/Makefile
+++ b/www/qdecoder/Makefile
@@ -5,30 +5,73 @@
# $FreeBSD$
#
-PORTNAME= qDecoder
-PORTVERSION= 7.0
+PORTNAME= qdecoder
+PORTVERSION= 9.0.1
CATEGORIES= www
-MASTER_SITES= ftp://ftp.qDecoder.org/pub/qDecoder/
-EXTRACT_SUFX= .tar.Z
+MASTER_SITES= ftp://ftp.qdecoder.org/pub/qDecoder/
+DISTNAME= qDecoder-${PORTVERSION}
MAINTAINER= cjh@FreeBSD.org
-COMMENT= CGI library for C/C++ language programming
+COMMENT= C/C++ language library including CGI supports
-GNU_CONFIGURE= yes
+CONFLICTS= qDecoder-[5-7]*
+
+HAS_CONFIGURE= yes
USE_LDCONFIG= yes
+OPTIONS= Q_DEBUG "Debug printout" off
+OPTIONS+= Q_64BIT "64bit support" off
+OPTIONS+= Q_SENDFILE "Use sendfile()" off
+OPTIONS+= Q_MYSQL "Use MySQL" off
+OPTIONS+= Q_CGISUPPORT "CGI API support" on
+OPTIONS+= Q_SOCKET "Socket API support" on
+OPTIONS+= Q_IPC "IPC API support" on
+OPTIONS+= Q_DATASTRUCTURE "Datastructure API support" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_Q_DEBUG)
+CONFIGURE_ARGS+="--enable-debug"
+.endif
+
+.if defined(WITH_Q_64BIT)
+CONFIGURE_ARGS+="--enable-64bit"
+.endif
+
+.if defined(WITH_Q_SENDFILE)
+CONFIGURE_ARGS+="--enable-sendfile"
+.endif
+
+.if defined(WITH_Q_MYSQL)
+CONFIGURE_ARGS+="--enable-mysql=${LOCALBASE}/include/mysql"
+USE_MYSQL=yes
+.endif
+
+.if defined(WITHOUT_Q_CGISUPPORT)
+CONFIGURE_ARGS+="--disable-cgisupport"
+.endif
+
+.if defined(WITHOUT_Q_SOCKET)
+CONFIGURE_ARGS+="--disable-socket"
+.endif
+
+.if defined(WITHOUT_Q_IPC)
+CONFIGURE_ARGS+="--disable-ipc"
+.endif
+
+.if defined(WITHOUT_Q_DATASTRUCTURE)
+CONFIGURE_ARGS+="--disable-datastructure"
+.endif
+
post-install:
- ${MKDIR} ${PREFIX}/share/doc/qDecoder
-.for doc in AUTHORS DISCLAIMER README REFERENCE qDecoder.jpg
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${PREFIX}/share/doc/qDecoder
-.endfor
- ${MKDIR} ${PREFIX}/share/examples/qDecoder
- -${RM} ${WRKSRC}/examples/*.o ${WRKSRC}/examples/*.cgi \
- ${WRKSRC}/examples/Makefile.in
- ${INSTALL_DATA} ${WRKSRC}/examples/Makefile ${PREFIX}/share/examples/qDecoder
- ${INSTALL_DATA} ${WRKSRC}/examples/*.c ${PREFIX}/share/examples/qDecoder
- ${INSTALL_DATA} ${WRKSRC}/examples/*.conf ${PREFIX}/share/examples/qDecoder
- ${INSTALL_DATA} ${WRKSRC}/examples/*.html ${PREFIX}/share/examples/qDecoder
- ${INSTALL_DATA} ${WRKSRC}/examples/*.in ${PREFIX}/share/examples/qDecoder
-
-.include <bsd.port.mk>
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "AUTHORS CHANGES COPYING INSTALL qDecoder.jpg" ${DOCSDIR})
+ (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} "html" ${DOCSDIR})
+.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} "Makefile *.c *.conf *.html* qDecoder-upload" ${EXAMPLESDIR})
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/qdecoder/distinfo b/www/qdecoder/distinfo
index 550db7199649..c8da670ccb86 100644
--- a/www/qdecoder/distinfo
+++ b/www/qdecoder/distinfo
@@ -1,3 +1,3 @@
-MD5 (qDecoder-7.0.tar.Z) = 0de9ab7432fb207575c1e4fb27cc6cb8
-SHA256 (qDecoder-7.0.tar.Z) = eae8158d8e49ecc2c7fd77d033950f38271295c9360916cfa6a5b0cdb81fbbf2
-SIZE (qDecoder-7.0.tar.Z) = 982210
+MD5 (qDecoder-9.0.1.tar.gz) = 8f99c97e029066a35020bb45ab33f545
+SHA256 (qDecoder-9.0.1.tar.gz) = b48e4c6e9a7ef26062fe79c5fcb81593059cb9d207c8e4c3cbfc41225c58e3fc
+SIZE (qDecoder-9.0.1.tar.gz) = 266821
diff --git a/www/qdecoder/files/patch-src::Makefile.in b/www/qdecoder/files/patch-src::Makefile.in
deleted file mode 100644
index 7dd1215598d4..000000000000
--- a/www/qdecoder/files/patch-src::Makefile.in
+++ /dev/null
@@ -1,52 +0,0 @@
---- src/Makefile.in.orig Mon Mar 15 03:30:00 2004
-+++ src/Makefile.in Mon Mar 15 03:31:47 2004
-@@ -90,11 +90,36 @@
- qInternalEntry.o \
- md5/md5c.o
-
-+# Shared objects List
-+SHOBJ = qDecoder.So \
-+ qSession.So \
-+ qfDecoder.So \
-+ qsDecoder.So \
-+ qHttpHeader.So \
-+ qError.So \
-+ qEnv.So \
-+ qEncode.So \
-+ qString.So \
-+ qFile.So \
-+ qValid.So \
-+ qArg.So \
-+ qAwk.So \
-+ qSed.So \
-+ qCount.So \
-+ qDownload.So \
-+ qTime.So \
-+ qMisc.So \
-+ qInternalCommon.So \
-+ qInternalEntry.So \
-+ md5/md5c.So
-+
-+.SUFFIXES: .o .So
-+
- ## Make Library
--all: ${OBJ}
-+all: ${OBJ} ${SHOBJ}
- ${AR} ${ARFLAGS} ${LIBNAME} ${OBJ}
- ${RANLIB} ${LIBNAME}
-- ${LD} ${LDFLAGS} -o ${SLIBREALNAME} ${OBJ}
-+ ${LD} ${LDFLAGS} -o ${SLIBREALNAME} ${SHOBJ}
- ${CHMOD} 0644 ${SLIBREALNAME}
- ${RM} -f ${SLIBNAME}
- ${LN_S} ${SLIBREALNAME} ${SLIBNAME}
-@@ -102,6 +127,10 @@
- ## Compile Module
- .c.o:
- ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -c -o $@ $<
-+
-+## Compile PIC Module
-+.c.So:
-+ ${CC} ${CFLAGS} -fPIC ${DEFS} ${INCLUDE} -c -o $@ $<
-
- ## Install Module
- install: all
diff --git a/www/qdecoder/pkg-descr b/www/qdecoder/pkg-descr
index 9cbfd4d96548..cc3485ffc8c4 100644
--- a/www/qdecoder/pkg-descr
+++ b/www/qdecoder/pkg-descr
@@ -1,14 +1,20 @@
-qDecoder
-========
+The qDecoder Project
+====================
-"qDecoder is a CGI library for C/C++ language programming and
- a solution product for developers. The Query Fetch algorithm
- of qDecoder which is based on linked-list gives developers
- more simple library interface without regard to a method of GET
- or POST. Also because it gives transperance with a subordinate
- layer, web-based softwares - CGI - is designed and embodied in
- reliability further. The source code for qDecoder is freely
- available to everyone."
+qDecoder is a C/C++ language library including CGI supports.
+Distributed under 2-clause BSD-like license since 9 release.
+
+ CGI Interfaces
+ o Request Parser, Response Generator, Session, Cookies
+ Network & IPC Interfaces
+ o Socket, Shared memory, Semaphore, Database wrapper
+ Data structures
+ o Linked-list, Hash tables, Queue, qDecoder implementation of Obstack
+ Useful APIs
+ o Configuration parser, Automated file logger, Server side includes
+ Common Utilities
+ o String libraries, File libraries, Hashes & En/decoders
+ And more...
--
Ports by CHOI Junho <cjh@FreeBSD.org>
diff --git a/www/qdecoder/pkg-plist b/www/qdecoder/pkg-plist
index 213c180a5bec..f4c3f996f92b 100644
--- a/www/qdecoder/pkg-plist
+++ b/www/qdecoder/pkg-plist
@@ -1,27 +1,81 @@
include/qDecoder.h
lib/libqDecoder.a
lib/libqDecoder.so
-lib/libqDecoder.so.2
-share/doc/qDecoder/AUTHORS
-share/doc/qDecoder/DISCLAIMER
-share/doc/qDecoder/README
-share/doc/qDecoder/REFERENCE
-share/doc/qDecoder/qDecoder.jpg
-@dirrm share/doc/qDecoder
-share/examples/qDecoder/Makefile
-share/examples/qDecoder/arglist.c
-share/examples/qDecoder/confparser.c
-share/examples/qDecoder/confparser.conf
-share/examples/qDecoder/cookie.c
-share/examples/qDecoder/download.c
-share/examples/qDecoder/examples.html
-share/examples/qDecoder/fetch.c
-share/examples/qDecoder/multivalue.c
-share/examples/qDecoder/session.c
-share/examples/qDecoder/streamedit-header.html.in
-share/examples/qDecoder/streamedit-tailer.html.in
-share/examples/qDecoder/streamedit.c
-share/examples/qDecoder/streamedit.html
-share/examples/qDecoder/streamedit.html.in
-share/examples/qDecoder/upload.c
-@dirrm share/examples/qDecoder
+lib/libqDecoder.so.6
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/qDecoder.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/annotated.html
+%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.css
+%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.png
+%%PORTDOCS%%%%DOCSDIR%%/html/files.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions.html
+%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars.html
+%%PORTDOCS%%%%DOCSDIR%%/html/globals.html
+%%PORTDOCS%%%%DOCSDIR%%/html/globals_func.html
+%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qCgiRequest_8c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qCgiResponse_8c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qConfig_8c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qCount_8c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qDatabase_8c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qDecoder_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qEncode_8c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qEntry_8c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qFile_8c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qHash_8c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qHasharr_8c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qHashtbl_8c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qHtml_8c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qLog_8c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qObstack_8c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qQueue_8c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qSed_8c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qSem_8c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qSession_8c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qShm_8c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qSocket_8c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qString_8c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qSystem_8c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/qTime_8c.html
+%%PORTDOCS%%%%DOCSDIR%%/html/structQ__DB.html
+%%PORTDOCS%%%%DOCSDIR%%/html/structQ__DBRESULT.html
+%%PORTDOCS%%%%DOCSDIR%%/html/structQ__ENTRY.html
+%%PORTDOCS%%%%DOCSDIR%%/html/structQ__HASHARR.html
+%%PORTDOCS%%%%DOCSDIR%%/html/structQ__HASHTBL.html
+%%PORTDOCS%%%%DOCSDIR%%/html/structQ__LOG.html
+%%PORTDOCS%%%%DOCSDIR%%/html/structQ__NLOBJ.html
+%%PORTDOCS%%%%DOCSDIR%%/html/structQ__OBJ.html
+%%PORTDOCS%%%%DOCSDIR%%/html/structQ__OBSTACK.html
+%%PORTDOCS%%%%DOCSDIR%%/html/structQ__QUEUE.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tab_b.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/tab_l.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/tab_r.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/tabs.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/arglist.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/config.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/download.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/multivalue.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/obstack.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/query.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/session.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/socket.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/streamedit.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upload.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/uploadfile.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/config.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/config_default.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/streamedit-header.html.in
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/streamedit-tailer.html.in
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/streamedit.html.in
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/qDecoder-upload/qDecoder-upload.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/qDecoder-upload/qDecoder-upload.js
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/qDecoder-upload
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%