aboutsummaryrefslogtreecommitdiff
path: root/www/quickie
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2006-06-20 12:54:52 +0000
committerShaun Amott <shaun@FreeBSD.org>2006-06-20 12:54:52 +0000
commit43819c31aed0679fecfa34cf4fa3cc15175402a2 (patch)
tree5c30ab6d06af903eafec2aa3059f4e0672a5eec8 /www/quickie
parent51c5eda23e398e3dcc7407bb3bab66ef66ed4303 (diff)
downloadports-43819c31aed0679fecfa34cf4fa3cc15175402a2.tar.gz
ports-43819c31aed0679fecfa34cf4fa3cc15175402a2.zip
Notes
Diffstat (limited to 'www/quickie')
-rw-r--r--www/quickie/Makefile1
-rw-r--r--www/quickie/files/patch-lib_file_regular.cc18
2 files changed, 13 insertions, 6 deletions
diff --git a/www/quickie/Makefile b/www/quickie/Makefile
index 279d6201e8be..959864ae963c 100644
--- a/www/quickie/Makefile
+++ b/www/quickie/Makefile
@@ -7,6 +7,7 @@
PORTNAME= quickie
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://${PORTNAME}.sourceforge.net/ \
http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
diff --git a/www/quickie/files/patch-lib_file_regular.cc b/www/quickie/files/patch-lib_file_regular.cc
index 53ed768dd175..74a5b4178ee5 100644
--- a/www/quickie/files/patch-lib_file_regular.cc
+++ b/www/quickie/files/patch-lib_file_regular.cc
@@ -12,12 +12,18 @@
#include <careful.h>
#include <cgi.h>
#include <configuration.h>
-@@ -386,7 +391,7 @@
+@@ -384,11 +389,8 @@
+ return;
+ }
output_stdout op;
- op << "Content-Type: text/html\n"
- "Content-Length: "
+- op << "Content-Type: text/html\n"
+- "Content-Length: "
- << st.st_size
-+ << (char)st.st_size
- << "\n"
- "\n";
+- << "\n"
+- "\n";
++ op << "Content-Type: text/html\n";
++ op.printf("Content-Length: %llu\n\n", st.st_size);
for (;;)
+ {
+ char buffer[1 << 14];
+