aboutsummaryrefslogtreecommitdiff
path: root/www/quixote/Makefile
diff options
context:
space:
mode:
authorJohann Visagie <wjv@FreeBSD.org>2002-10-20 20:11:50 +0000
committerJohann Visagie <wjv@FreeBSD.org>2002-10-20 20:11:50 +0000
commit1a5a3d0a0346df8932e567cf5c7e1f4223556a74 (patch)
tree1a010a3330d7bedbce22e03f262131681b9cdc73 /www/quixote/Makefile
parentfe7e30b662d302a2c532b47505d134e4bfbf03dc (diff)
downloadports-1a5a3d0a0346df8932e567cf5c7e1f4223556a74.tar.gz
ports-1a5a3d0a0346df8932e567cf5c7e1f4223556a74.zip
Notes
Diffstat (limited to 'www/quixote/Makefile')
-rw-r--r--www/quixote/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/www/quixote/Makefile b/www/quixote/Makefile
index ee3d04ceb3d4..3f34896078df 100644
--- a/www/quixote/Makefile
+++ b/www/quixote/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= quixote
-PORTVERSION= 0.5
+PORTVERSION= 0.5.1
CATEGORIES= www python
MASTER_SITES= http://www.mems-exchange.org/software/files/quixote/
DISTNAME= Quixote-${PORTVERSION}
@@ -30,13 +30,14 @@ pre-install:
post-install:
@ PYTHONPATH=${PREFIX}/lib/${PYTHON_VERSION}/site-packages \
${PYTHON_CMD} ${SCRIPTDIR}/compile_ptl.py \
- ${PREFIX}/lib/${PYTHON_VERSION}/site-packages/${PORTNAME}/demo/pages.ptl \
- ${PREFIX}/lib/${PYTHON_VERSION}/site-packages/${PORTNAME}/form/form_templates.ptl
+ ${PREFIX}/lib/${PYTHON_VERSION}/site-packages/${PORTNAME}/demo/*.ptl \
+ ${PREFIX}/lib/${PYTHON_VERSION}/site-packages/${PORTNAME}/form/*.ptl
@ ${MKDIR} ${EXAMPLESDIR}
- @ ${INSTALL_DATA} ${WRKSRC}/demo/demo.* ${EXAMPLESDIR}
+ @ ${INSTALL_DATA} ${WRKSRC}/demo/*.cgi ${WRKSRC}/demo/*.conf \
+ ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${DOCSDIR}
-.for docfile in ACKS CHANGES LICENSE README TODO doc/*.txt
+.for docfile in ACKS CHANGES LICENSE README TODO doc/*
@ ${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
.endfor
.endif