aboutsummaryrefslogtreecommitdiff
path: root/www/qupzilla-qt4/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /www/qupzilla-qt4/Makefile
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'www/qupzilla-qt4/Makefile')
-rw-r--r--www/qupzilla-qt4/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/www/qupzilla-qt4/Makefile b/www/qupzilla-qt4/Makefile
index c4548e4e5f38..9ccb387d4762 100644
--- a/www/qupzilla-qt4/Makefile
+++ b/www/qupzilla-qt4/Makefile
@@ -17,8 +17,8 @@ LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
CONFLICTS_INSTALL= ${PORTNAME}-qt5*
-USES= desktop-file-utils pkgconfig qmake ssl tar:xz
-USE_QT4= corelib gui network script sql webkit xml \
+USES= desktop-file-utils pkgconfig qmake qt:4 ssl tar:xz
+USE_QT= corelib gui network script sql webkit xml \
linguisttools_build moc_build rcc_build uic_build \
imageformats_run sql-sqlite3_run
USE_XORG= x11
@@ -31,7 +31,8 @@ OPTIONS_DEFINE= DBUS DEBUG GNOMEKEYRING KWALLET
OPTIONS_DEFAULT=DBUS
OPTIONS_SUB= yes
-DBUS_USE= QT4=dbus
+DBUS_USES= qt:4
+DBUS_USE= QT=dbus
DBUS_CONFIGURE_ENV_OFF= DISABLE_DBUS="true"
GNOMEKEYRING_LIB_DEPENDS= libgnome-keyring.so:security/libgnome-keyring