aboutsummaryrefslogtreecommitdiff
path: root/www/qupzilla
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-04-19 18:37:16 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-04-19 18:37:16 +0000
commitc900239036145bba5b5f1e0ee274c56c6bf2f764 (patch)
tree9fa1fdc557f53dceaa68831d4894f0ad0840a726 /www/qupzilla
parent64865487f1a38f473fc581eb5f9c9936aa0751d7 (diff)
downloadports-c900239036145bba5b5f1e0ee274c56c6bf2f764.tar.gz
ports-c900239036145bba5b5f1e0ee274c56c6bf2f764.zip
Notes
Diffstat (limited to 'www/qupzilla')
-rw-r--r--www/qupzilla/Makefile32
-rw-r--r--www/qupzilla/distinfo2
-rw-r--r--www/qupzilla/pkg-descr19
-rw-r--r--www/qupzilla/pkg-plist277
4 files changed, 330 insertions, 0 deletions
diff --git a/www/qupzilla/Makefile b/www/qupzilla/Makefile
new file mode 100644
index 000000000000..aa7b16bdd072
--- /dev/null
+++ b/www/qupzilla/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= qupzilla
+PORTVERSION= 1.4.0
+CATEGORIES= www
+MASTER_SITES= http://www.qupzilla.com/uploads/
+DISTNAME= QupZilla-${PORTVERSION}
+
+MAINTAINER= javad.kouhi@gmail.com
+COMMENT= Modern web browser based on WebKit core and Qt Framework
+
+LICENSE= GPLv3
+
+HAS_CONFIGURE= yes
+USE_QT4= gui moc_build qmake_build rcc_build uic_build webkit \
+ dbus xml script sql network imageformats linguist_build
+MAKE_ENV+= QUPZILLA_PREFIX=${PREFIX}/ USE_LIBPATH=${PREFIX}/lib/
+USE_LDCONFIG= yes
+INSTALLS_ICONS= yes
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${QMAKE} ${QMAKEFLAGS} QupZilla.pro
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/|${LOCALBASE}/|g' \
+ ${WRKSRC}/tests/autotests/qztoolstest.cpp \
+ ${WRKSRC}/src/lib/plugins/qtwebkit/spellcheck/speller.cpp
+ @${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|g' \
+ ${WRKSRC}/src/install.pri
+
+.include <bsd.port.mk>
diff --git a/www/qupzilla/distinfo b/www/qupzilla/distinfo
new file mode 100644
index 000000000000..dc28619b538f
--- /dev/null
+++ b/www/qupzilla/distinfo
@@ -0,0 +1,2 @@
+SHA256 (QupZilla-1.4.0.tar.gz) = c17a22ffda3d6d9794472207787808f0b318c19b78687dba670af35543af7a5f
+SIZE (QupZilla-1.4.0.tar.gz) = 3990320
diff --git a/www/qupzilla/pkg-descr b/www/qupzilla/pkg-descr
new file mode 100644
index 000000000000..030ffeb52932
--- /dev/null
+++ b/www/qupzilla/pkg-descr
@@ -0,0 +1,19 @@
+QupZilla is a new and very fast QtWebKit browser. It aims to be a lightweight
+web browser available through all major platforms. This project has been
+originally started only for educational purposes. But from its start, QupZilla
+has grown into a feature-rich browser.
+
+QupZilla has all standard functions you expect from a web browser. It includes
+bookmarks, history (both also in sidebar) and tabs. Above that, you can manage
+RSS feeds with an included RSS reader, block ads with a builtin AdBlock plugin,
+block Flash content with Click2Flash and edit the local CA Certificates
+database with an SSL Manager.
+
+QupZilla's main aim is to be a very fast and very stable QtWebKit browser
+available to everyone. There are already a lot of QtWebKit browsers available,
+but they are either bound to the KDE environment (rekonq), are not actively
+developed or very unstable and miss important features. But there is missing a
+multiplatform, modern and actively developed browser. QupZilla is trying to
+fill this gap by providing a very stable browsing experience.
+
+WWW: http://www.qupzilla.com
diff --git a/www/qupzilla/pkg-plist b/www/qupzilla/pkg-plist
new file mode 100644
index 000000000000..3e4190478208
--- /dev/null
+++ b/www/qupzilla/pkg-plist
@@ -0,0 +1,277 @@
+bin/qupzilla
+etc/bash_completion.d/bash_completion.sh
+lib/libQupZilla.so
+lib/libQupZilla.so.1
+lib/libQupZilla.so.1.4
+lib/libQupZilla.so.1.4.0
+lib/qupzilla/libAccessKeysNavigation.so
+lib/qupzilla/libGreaseMonkey.so
+lib/qupzilla/libMouseGestures.so
+lib/qupzilla/libPIM.so
+share/applications/qupzilla.desktop
+share/icons/hicolor/128x128/apps/qupzilla.png
+share/icons/hicolor/16x16/apps/qupzilla.png
+share/icons/hicolor/256x256/apps/qupzilla.png
+share/icons/hicolor/32x32/apps/qupzilla.png
+share/icons/hicolor/48x48/apps/qupzilla.png
+share/icons/hicolor/64x64/apps/qupzilla.png
+share/pixmaps/qupzilla.png
+share/qupzilla/locale/ca_ES.qm
+share/qupzilla/locale/cs_CZ.qm
+share/qupzilla/locale/de_DE.qm
+share/qupzilla/locale/el_GR.qm
+share/qupzilla/locale/es_ES.qm
+share/qupzilla/locale/es_VE.qm
+share/qupzilla/locale/fa_IR.qm
+share/qupzilla/locale/fr_FR.qm
+share/qupzilla/locale/hu_HU.qm
+share/qupzilla/locale/id_ID.qm
+share/qupzilla/locale/it_IT.qm
+share/qupzilla/locale/ja_JP.qm
+share/qupzilla/locale/ka_GE.qm
+share/qupzilla/locale/nl_NL.qm
+share/qupzilla/locale/pl_PL.qm
+share/qupzilla/locale/pt_BR.qm
+share/qupzilla/locale/pt_PT.qm
+share/qupzilla/locale/qt_ca.qm
+share/qupzilla/locale/qt_cs.qm
+share/qupzilla/locale/qt_de.qm
+share/qupzilla/locale/qt_el.qm
+share/qupzilla/locale/qt_es.qm
+share/qupzilla/locale/qt_fa.qm
+share/qupzilla/locale/qt_fr.qm
+share/qupzilla/locale/qt_hu.qm
+share/qupzilla/locale/qt_it.qm
+share/qupzilla/locale/qt_ja.qm
+share/qupzilla/locale/qt_nl.qm
+share/qupzilla/locale/qt_pl.qm
+share/qupzilla/locale/qt_pt.qm
+share/qupzilla/locale/qt_ru.qm
+share/qupzilla/locale/qt_sk.qm
+share/qupzilla/locale/qt_sr_BA.qm
+share/qupzilla/locale/qt_sr_BA@latin.qm
+share/qupzilla/locale/qt_sr_RS.qm
+share/qupzilla/locale/qt_sr_RS@latin.qm
+share/qupzilla/locale/qt_sv.qm
+share/qupzilla/locale/qt_uk.qm
+share/qupzilla/locale/qt_zh_CN.qm
+share/qupzilla/locale/qt_zh_TW.qm
+share/qupzilla/locale/ro_RO.qm
+share/qupzilla/locale/ru_RU.qm
+share/qupzilla/locale/sk_SK.qm
+share/qupzilla/locale/sr_BA.qm
+share/qupzilla/locale/sr_BA@latin.qm
+share/qupzilla/locale/sr_RS.qm
+share/qupzilla/locale/sr_RS@latin.qm
+share/qupzilla/locale/sv_SE.qm
+share/qupzilla/locale/uk_UA.qm
+share/qupzilla/locale/zh_CN.qm
+share/qupzilla/locale/zh_TW.qm
+share/qupzilla/themes/chrome/images/blankbutton-a.png
+share/qupzilla/themes/chrome/images/blankbutton-h.png
+share/qupzilla/themes/chrome/images/flash.png
+share/qupzilla/themes/chrome/images/flashstart.png
+share/qupzilla/themes/chrome/images/gotoaddress.png
+share/qupzilla/themes/chrome/images/key.png
+share/qupzilla/themes/chrome/images/library-bg-left.png
+share/qupzilla/themes/chrome/images/library-bg-top-right.png
+share/qupzilla/themes/chrome/images/library-bg-top.png
+share/qupzilla/themes/chrome/images/library-search-bg.png
+share/qupzilla/themes/chrome/images/lineedit-bg.png
+share/qupzilla/themes/chrome/images/navigation-addtab.png
+share/qupzilla/themes/chrome/images/navigation-back.png
+share/qupzilla/themes/chrome/images/navigation-dropdown.png
+share/qupzilla/themes/chrome/images/navigation-forward.png
+share/qupzilla/themes/chrome/images/navigation-home.png
+share/qupzilla/themes/chrome/images/navigation-reload.png
+share/qupzilla/themes/chrome/images/navigation-stop.png
+share/qupzilla/themes/chrome/images/navigation-supermenu.png
+share/qupzilla/themes/chrome/images/rss.png
+share/qupzilla/themes/chrome/images/search-icon.png
+share/qupzilla/themes/chrome/images/searchbar-provider-bg.png
+share/qupzilla/themes/chrome/images/semi-transp.png
+share/qupzilla/themes/chrome/images/siteicon-bg.png
+share/qupzilla/themes/chrome/images/siteicon-secure-bg.png
+share/qupzilla/themes/chrome/images/star-a.png
+share/qupzilla/themes/chrome/images/star.png
+share/qupzilla/themes/chrome/images/tabbar-addtab.png
+share/qupzilla/themes/chrome/images/tabs-bg.png
+share/qupzilla/themes/chrome/images/tabs-list-button.png
+share/qupzilla/themes/chrome/images/toolbar-bg.png
+share/qupzilla/themes/chrome/images/transp.png
+share/qupzilla/themes/chrome/linux.css
+share/qupzilla/themes/chrome/main.css
+share/qupzilla/themes/chrome/rtl.css
+share/qupzilla/themes/chrome/theme.info
+share/qupzilla/themes/chrome/theme.license
+share/qupzilla/themes/chrome/theme.png
+share/qupzilla/themes/chrome/windows.css
+share/qupzilla/themes/default/images/arrow-down.gif
+share/qupzilla/themes/default/images/background.png
+share/qupzilla/themes/default/images/flash.png
+share/qupzilla/themes/default/images/flashstart.png
+share/qupzilla/themes/default/images/gotoaddress.png
+share/qupzilla/themes/default/images/key.png
+share/qupzilla/themes/default/images/library-bg-left.png
+share/qupzilla/themes/default/images/library-bg-top-right.png
+share/qupzilla/themes/default/images/library-bg-top.png
+share/qupzilla/themes/default/images/lineedit-bg.png
+share/qupzilla/themes/default/images/navigation-addtab.png
+share/qupzilla/themes/default/images/navigation-back.png
+share/qupzilla/themes/default/images/navigation-forward.png
+share/qupzilla/themes/default/images/navigation-home.png
+share/qupzilla/themes/default/images/navigation-reload.png
+share/qupzilla/themes/default/images/navigation-stop.png
+share/qupzilla/themes/default/images/navigation-supmenu.png
+share/qupzilla/themes/default/images/rss.png
+share/qupzilla/themes/default/images/search.png
+share/qupzilla/themes/default/images/semi-transp.png
+share/qupzilla/themes/default/images/siteicon-bg-secure.png
+share/qupzilla/themes/default/images/siteicon-bg.png
+share/qupzilla/themes/default/images/star.png
+share/qupzilla/themes/default/images/starg.png
+share/qupzilla/themes/default/images/tabs-list-button.png
+share/qupzilla/themes/default/images/transp.png
+share/qupzilla/themes/default/main.css
+share/qupzilla/themes/default/rtl.css
+share/qupzilla/themes/default/theme.info
+share/qupzilla/themes/default/theme.png
+share/qupzilla/themes/default/windows.css
+share/qupzilla/themes/linux/images/flash.png
+share/qupzilla/themes/linux/images/flashstart.png
+share/qupzilla/themes/linux/images/go-home.png
+share/qupzilla/themes/linux/images/go-next.png
+share/qupzilla/themes/linux/images/go-previous.png
+share/qupzilla/themes/linux/images/gotoaddress.png
+share/qupzilla/themes/linux/images/key.png
+share/qupzilla/themes/linux/images/library-bg-left.png
+share/qupzilla/themes/linux/images/library-bg-top-right.png
+share/qupzilla/themes/linux/images/library-bg-top.png
+share/qupzilla/themes/linux/images/library-search-bg.png
+share/qupzilla/themes/linux/images/list-add.png
+share/qupzilla/themes/linux/images/navigation-dropdown.png
+share/qupzilla/themes/linux/images/preferences-desktop.png
+share/qupzilla/themes/linux/images/process-stop.png
+share/qupzilla/themes/linux/images/rss.png
+share/qupzilla/themes/linux/images/search-icon.png
+share/qupzilla/themes/linux/images/semi-transp.png
+share/qupzilla/themes/linux/images/star-a.png
+share/qupzilla/themes/linux/images/star.png
+share/qupzilla/themes/linux/images/tabs-list-button.png
+share/qupzilla/themes/linux/images/transp.png
+share/qupzilla/themes/linux/images/view-refresh.png
+share/qupzilla/themes/linux/images/websearch-bg.png
+share/qupzilla/themes/linux/main.css
+share/qupzilla/themes/linux/rtl.css
+share/qupzilla/themes/linux/theme.info
+share/qupzilla/themes/linux/theme.png
+share/qupzilla/themes/mac/images/feed-icon.png
+share/qupzilla/themes/mac/images/flash.png
+share/qupzilla/themes/mac/images/flashstart.png
+share/qupzilla/themes/mac/images/gotoaddress.png
+share/qupzilla/themes/mac/images/key.png
+share/qupzilla/themes/mac/images/library-bg-left.png
+share/qupzilla/themes/mac/images/library-bg-top-right.png
+share/qupzilla/themes/mac/images/library-bg-top.png
+share/qupzilla/themes/mac/images/library-search-bg.png
+share/qupzilla/themes/mac/images/lineedit-bg.png
+share/qupzilla/themes/mac/images/navigation-addtab.png
+share/qupzilla/themes/mac/images/navigation-back.png
+share/qupzilla/themes/mac/images/navigation-dropdown.png
+share/qupzilla/themes/mac/images/navigation-forward.png
+share/qupzilla/themes/mac/images/navigation-home.png
+share/qupzilla/themes/mac/images/navigation-reload.png
+share/qupzilla/themes/mac/images/navigation-stop.png
+share/qupzilla/themes/mac/images/navigation-supermenu.png
+share/qupzilla/themes/mac/images/search-icon.png
+share/qupzilla/themes/mac/images/searchbar-provider-bg.png
+share/qupzilla/themes/mac/images/semi-transp.png
+share/qupzilla/themes/mac/images/siteicon-bg.png
+share/qupzilla/themes/mac/images/siteicon-secure-bg.png
+share/qupzilla/themes/mac/images/splitter.png
+share/qupzilla/themes/mac/images/star-a.png
+share/qupzilla/themes/mac/images/star.png
+share/qupzilla/themes/mac/images/tabbar-addtab.png
+share/qupzilla/themes/mac/images/tabs-bg.png
+share/qupzilla/themes/mac/images/tabs-list-button.png
+share/qupzilla/themes/mac/images/tabs-list-button_rtl.png
+share/qupzilla/themes/mac/images/toolbar-bg.png
+share/qupzilla/themes/mac/images/transp.png
+share/qupzilla/themes/mac/linux.css
+share/qupzilla/themes/mac/main.css
+share/qupzilla/themes/mac/rtl.css
+share/qupzilla/themes/mac/theme.info
+share/qupzilla/themes/mac/theme.license
+share/qupzilla/themes/mac/theme.png
+share/qupzilla/themes/mac/windows.css
+share/qupzilla/themes/windows/images/flash.png
+share/qupzilla/themes/windows/images/flashstart.png
+share/qupzilla/themes/windows/images/gotoaddress.png
+share/qupzilla/themes/windows/images/key.png
+share/qupzilla/themes/windows/images/library-bg-left.png
+share/qupzilla/themes/windows/images/library-bg-top-right.png
+share/qupzilla/themes/windows/images/library-bg-top.png
+share/qupzilla/themes/windows/images/library-search-bg.png
+share/qupzilla/themes/windows/images/lineedit-bg.png
+share/qupzilla/themes/windows/images/navigation-addtab.png
+share/qupzilla/themes/windows/images/navigation-back.png
+share/qupzilla/themes/windows/images/navigation-dropdown.png
+share/qupzilla/themes/windows/images/navigation-forward.png
+share/qupzilla/themes/windows/images/navigation-home.png
+share/qupzilla/themes/windows/images/navigation-reload.png
+share/qupzilla/themes/windows/images/navigation-stop.png
+share/qupzilla/themes/windows/images/navigation-supermenu.png
+share/qupzilla/themes/windows/images/rss.png
+share/qupzilla/themes/windows/images/search-icon.png
+share/qupzilla/themes/windows/images/searchbar-provider-bg.png
+share/qupzilla/themes/windows/images/semi-transp.png
+share/qupzilla/themes/windows/images/siteicon-bg.png
+share/qupzilla/themes/windows/images/siteicon-secure-bg.png
+share/qupzilla/themes/windows/images/star-a.png
+share/qupzilla/themes/windows/images/star.png
+share/qupzilla/themes/windows/images/tab-active-bg.png
+share/qupzilla/themes/windows/images/tab-deactive-bg.png
+share/qupzilla/themes/windows/images/tab-deactive-hover-bg.png
+share/qupzilla/themes/windows/images/tabbar-addtab.png
+share/qupzilla/themes/windows/images/tabbar-addtab_rtl.png
+share/qupzilla/themes/windows/images/tabs-bg.png
+share/qupzilla/themes/windows/images/tabs-list-button.png
+share/qupzilla/themes/windows/images/toolbar-bg.png
+share/qupzilla/themes/windows/images/transp.png
+share/qupzilla/themes/windows/linux.css
+share/qupzilla/themes/windows/main.css
+share/qupzilla/themes/windows/rtl.css
+share/qupzilla/themes/windows/theme.info
+share/qupzilla/themes/windows/theme.license
+share/qupzilla/themes/windows/theme.png
+share/qupzilla/themes/windows/windows.css
+@dirrm lib/qupzilla
+@dirrm share/qupzilla/themes/windows/images
+@dirrm share/qupzilla/themes/windows
+@dirrm share/qupzilla/themes/mac/images
+@dirrm share/qupzilla/themes/mac
+@dirrm share/qupzilla/themes/linux/images
+@dirrm share/qupzilla/themes/linux
+@dirrm share/qupzilla/themes/default/images
+@dirrm share/qupzilla/themes/default
+@dirrm share/qupzilla/themes/chrome/images
+@dirrm share/qupzilla/themes/chrome
+@dirrm share/qupzilla/themes
+@dirrm share/qupzilla/locale
+@dirrm share/qupzilla
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/256x256/apps
+@dirrmtry share/icons/hicolor/256x256
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor/128x128/apps
+@dirrmtry share/icons/hicolor/128x128
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/applications
+@dirrmtry etc/bash_completion.d