aboutsummaryrefslogtreecommitdiff
path: root/www/raqdevil/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-18 21:55:43 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-18 21:55:43 +0000
commit62658da863462d41dc9f1178fe620dc8aa08b5da (patch)
treec88bdde5434713c462073a14a07a3c4751be2224 /www/raqdevil/Makefile
parent521f7d71055a1de35928d6832a9884bb31d71cc0 (diff)
downloadports-62658da863462d41dc9f1178fe620dc8aa08b5da.tar.gz
ports-62658da863462d41dc9f1178fe620dc8aa08b5da.zip
Notes
Diffstat (limited to 'www/raqdevil/Makefile')
-rw-r--r--www/raqdevil/Makefile34
1 files changed, 24 insertions, 10 deletions
diff --git a/www/raqdevil/Makefile b/www/raqdevil/Makefile
index 6495907239a7..1cc68443452e 100644
--- a/www/raqdevil/Makefile
+++ b/www/raqdevil/Makefile
@@ -1,27 +1,40 @@
# New ports collection makefile for: raqdevil
# Date created: 06 September 2005
-# Whom: Devon H. O'Dell <dodell@offmyserver.com>
+# Whom: Devon H. O'Dell <dodell@ixsystems.com>
#
# $FreeBSD$
#
PORTNAME= raqdevil
-PORTVERSION= 0.9.6
+PORTVERSION= 1.0
CATEGORIES= www sysutils
MASTER_SITES= http://www.raqdevil.com/
MAINTAINER= dodell@iXsystems.com
COMMENT= A port of the Sun Cobalt RaQ550 software to FreeBSD
+# The explicit dependencies on p5-Net, p5-Digest, p5-Authen-SASL,
+# p5-Test-Harness, p5-Test-Simple, p5-Authen-SASL and p5-MIME-Base64
+# are necessary due to ports/86310. This is a work-around: RAQdevil
+# does not depend on these ports itself.
+
RUN_DEPENDS= ${LOCALBASE}/sbin/sendmail:${PORTSDIR}/mail/${SENDMAIL_MILTER_PORT} \
- ${JCODE}:${PORTSDIR}/japanese/p5-Jcode \
- ${SITE_PERL}/mach/Quota.pm:${PORTSDIR}/sysutils/p5-Quota \
- ${SITE_PERL}/mach/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext \
+ ${SITE_PERL}/Authen/SASL.pm:${PORTSDIR}/security/p5-Authen-SASL \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/Digest.pm:${PORTSDIR}/security/p5-Digest \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/Net/Cmd.pm:${PORTSDIR}/net/p5-Net \
+ ${SITE_PERL}/Test/Harness.pm:${PORTSDIR}/devel/p5-Test-Harness \
+ ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${LOCALBASE}/libexec/imapd:${PORTSDIR}/mail/imap-uw \
+ ${SITE_PERL}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode \
+ ${SITE_PERL}/${PERL_ARCH}/Quota.pm:${PORTSDIR}/sysutils/p5-Quota \
+ ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext \
${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph \
${SITE_PERL}/Mail/SPF/Query.pm:${PORTSDIR}/mail/p5-Mail-SPF-Query \
+ ${JCODE}:${PORTSDIR}/japanese/p5-Jcode \
+ expect:${PORTSDIR}/lang/expect \
logrotate:${PORTSDIR}/sysutils/logrotate \
- perl:${PORTSDIR}/lang/perl5.8 \
- imapd:${PORTSDIR}/mail/imap-uw \
pcretest:${PORTSDIR}/devel/pcre \
snmpd:${PORTSDIR}/net-mgmt/net-snmp \
proftpd:${PORTSDIR}/ftp/proftpd \
@@ -33,7 +46,7 @@ RUN_DEPENDS= ${LOCALBASE}/sbin/sendmail:${PORTSDIR}/mail/${SENDMAIL_MILTER_PORT}
analog:${PORTSDIR}/www/analog
BUILD_DEPENDS= re2c:${PORTSDIR}/devel/re2c
-BROKEN= "Conflicting dependencies (apache 1.x vs 2.x)"
+NO_PACKAGE= Conflicting dependencies (apache 1.x vs 2.x)
USE_GNOME= glib20
USE_PHP= pcre session xml
@@ -42,6 +55,7 @@ USE_PERL5= yes
USE_REINPLACE= yes
USE_APACHE= yes
+WITHOUT_X11= yes
WITH_APACHE2= yes
REINPLACE_ARGS= -i""
INSTALLS_SHLIB= yes
@@ -68,12 +82,12 @@ pre-everything::
.endif
pre-extract:
-.if !defined(PACKAGE_BUILDING)
+.if !defined(BATCH)
@${SH} ${FILESDIR}/warning
.endif
post-extract:
-.if !defined(PACKAGE_BUILDING)
+.if !defined(BATCH)
${CC} -o ${WRKSRC}/rdqchk ${FILESDIR}/rdqchk.c
${WRKSRC}/rdqchk
.endif