aboutsummaryrefslogtreecommitdiff
path: root/www/raqdevil/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-02 02:11:52 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-02 02:11:52 +0000
commitead009d688ec8625a9ef0663134151f18efa2175 (patch)
tree9a359c41f93f0855df5e970dda8cd13e45f93c5b /www/raqdevil/Makefile
parentf9f58770d33cdc13eaa49644ffe5d73979cfdb4b (diff)
downloadports-ead009d688ec8625a9ef0663134151f18efa2175.tar.gz
ports-ead009d688ec8625a9ef0663134151f18efa2175.zip
Notes
Diffstat (limited to 'www/raqdevil/Makefile')
-rw-r--r--www/raqdevil/Makefile65
1 files changed, 34 insertions, 31 deletions
diff --git a/www/raqdevil/Makefile b/www/raqdevil/Makefile
index 23b75346af5c..bed9f1d10b39 100644
--- a/www/raqdevil/Makefile
+++ b/www/raqdevil/Makefile
@@ -6,55 +6,58 @@
#
PORTNAME= raqdevil
-PORTVERSION= 0.9.4
+PORTVERSION= 0.9.6
CATEGORIES= www sysutils
-MASTER_SITES= http://raqdevil.alkeninternet.com/ \
- http://www.sitetronics.com/
+MASTER_SITES= http://www.raqdevil.com/
MAINTAINER= dodell@offmyserver.com
COMMENT= A port of the Sun Cobalt RaQ550 software to FreeBSD
-RUN_DEPENDS= \
- ${LOCALBASE}/libexec/imapd:${PORTSDIR}/mail/imap-uw \
- ${LOCALBASE}/libexec/qpopper:${PORTSDIR}/mail/qpopper \
- ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext \
- ${SITE_PERL}/${PERL_ARCH}/Quota.pm:${PORTSDIR}/sysutils/p5-Quota \
- ${SITE_PERL}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode \
- analog:${PORTSDIR}/www/analog \
- clamscan:${PORTSDIR}/security/clamav \
- logrotate:${PORTSDIR}/sysutils/logrotate \
- pcretest:${PORTSDIR}/devel/pcre \
- procmail:${PORTSDIR}/mail/procmail \
- proftpd:${PORTSDIR}/ftp/proftpd \
- sendmail:${PORTSDIR}/mail/sendmail-sasl \
- snmpd:${PORTSDIR}/net-mgmt/net-snmp \
- spamc:${PORTSDIR}/mail/p5-Mail-SpamAssassin \
- xinetd:${PORTSDIR}/security/xinetd
-BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison \
- re2c:${PORTSDIR}/devel/re2c
+RUN_DEPENDS= ${LOCALBASE}/sbin/sendmail:${PORTSDIR}/mail/sendmail-sasl \
+ ${SITE_PERL}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode \
+ ${SITE_PERL}/mach/Quota.pm:${PORTSDIR}/sysutils/p5-Quota \
+ ${SITE_PERL}/mach/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext \
+ ${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph \
+ ${SITE_PERL}/Mail/SPF/Query.pm:${PORTSDIR}/mail/p5-Mail-SPF-Query \
+ logrotate:${PORTSDIR}/sysutils/logrotate \
+ httpd:${PORTSDIR}/www/apache20 \
+ perl:${PORTSDIR}/lang/perl5.8 \
+ imapd:${PORTSDIR}/mail/imap-uw \
+ pcretest:${PORTSDIR}/devel/pcre \
+ snmpd:${PORTSDIR}/net-mgmt/net-snmp \
+ proftpd:${PORTSDIR}/ftp/proftpd \
+ qpopauth:${PORTSDIR}/mail/qpopper \
+ xinetd:${PORTSDIR}/security/xinetd \
+ spamc:${PORTSDIR}/mail/p5-Mail-SpamAssassin \
+ procmail:${PORTSDIR}/mail/procmail \
+ clamscan:${PORTSDIR}/security/clamav \
+ analog:${PORTSDIR}/www/analog
+BUILD_DEPENDS= re2c:${PORTSDIR}/devel/re2c
USE_GNOME= glib20
-USE_PHP= xml pcre
+USE_PHP= pcre session xml
USE_GMAKE= yes
USE_PERL5= yes
USE_REINPLACE= yes
+USE_APACHE= yes
+
+WITH_APACHE2= yes
REINPLACE_ARGS= -i""
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= ${PREFIX}/raqdevil/lib
.include <bsd.port.pre.mk>
-.ifdef (WITH_APACHE)
-WITH_APACHE2= yes
-.endif
-
-.ifndef (WITH_APACHE2)
-BROKEN?= "This port requires Apache 2. Use make -DWITH_APACHE."
-.endif
-
pre-extract:
@${SH} ${FILESDIR}/warning
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^sendmail+tls+sasl*' 2> /dev/null`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: sendmail with sasl support is required for RAQdevil to properly function."; \
+ ${ECHO_CMD} "Please install mail/sendmail-sasl." \
+ ${FALSE}; \
+ fi
+
post-extract:
.if !defined(PACKAGE_BUILDING)
${CC} -o ${WRKSRC}/rdqchk ${FILESDIR}/rdqchk.c
@@ -67,7 +70,7 @@ post-patch:
@${FIND} ${WRKSRC} -type f -name \*-e | ${XARGS} ${RM} -f
post-install:
- @${SETENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @PKG_PREFIX=${PREFIX} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>