aboutsummaryrefslogtreecommitdiff
path: root/www/resin2
diff options
context:
space:
mode:
authorErnst de Haan <znerd@FreeBSD.org>2003-10-01 11:20:42 +0000
committerErnst de Haan <znerd@FreeBSD.org>2003-10-01 11:20:42 +0000
commitb719a5a0057e2eba43a29c0a0fdee4d45b949811 (patch)
tree39da0d36307f5e3da369247410c4aaa4987f0939 /www/resin2
parent3bb679a33f2a78af35b08bd0b890cc341d91af7d (diff)
downloadports-b719a5a0057e2eba43a29c0a0fdee4d45b949811.tar.gz
ports-b719a5a0057e2eba43a29c0a0fdee4d45b949811.zip
Notes
Diffstat (limited to 'www/resin2')
-rw-r--r--www/resin2/Makefile85
-rw-r--r--www/resin2/distinfo1
-rw-r--r--www/resin2/files/patch-Makefile.in11
-rw-r--r--www/resin2/files/patch-apache211
-rw-r--r--www/resin2/files/patch-httpd.sh34
-rw-r--r--www/resin2/files/patch-install-apache10
-rw-r--r--www/resin2/files/patch-install-apache211
-rw-r--r--www/resin2/files/patch-resin.conf11
-rw-r--r--www/resin2/pkg-deinstall43
-rw-r--r--www/resin2/pkg-descr9
-rw-r--r--www/resin2/pkg-install98
-rw-r--r--www/resin2/pkg-message6
-rw-r--r--www/resin2/pkg-plist468
13 files changed, 798 insertions, 0 deletions
diff --git a/www/resin2/Makefile b/www/resin2/Makefile
new file mode 100644
index 000000000000..3f3b9c3c9eeb
--- /dev/null
+++ b/www/resin2/Makefile
@@ -0,0 +1,85 @@
+# New ports collection makefile for: resin2
+# Whom: Jean-Baptiste Quenot <jb.quenot@caraldi.com>
+# Date Created: 2002-07-15 15:00:43
+#
+# $FreeBSD$
+#
+
+PORTNAME= resin
+PORTVERSION= 2.1.11
+CATEGORIES= www java
+MASTER_SITES= http://www.caucho.com/download/
+
+MAINTAINER= jb.quenot@caraldi.com
+COMMENT= Resin, a Java-based Application Server, 2.x branch
+
+USE_JAVA= 1.2+
+HAS_CONFIGURE= yes
+USE_PERL5= yes
+
+# Customizable settings
+RUNASUSER?= www
+RUNASUID?= 80
+GROUP?= ${RUNASUSER}
+GID?= ${RUNASUID}
+PORT?= 8080
+APP_HOME?= ${PREFIX}/${PKGNAMEPREFIX}${PORTNAME}
+WITH_APACHE?= NO
+WITH_APACHE2?= NO
+
+# Other settings
+APXS?= ${LOCALBASE}/sbin/apxs
+MOD_DIR?= `${APXS} -q LIBEXECDIR`
+
+# Pass JAVA_HOME as determined by bsd.java.mk
+CONFIGURE_ARGS+= --with-java-home=${JAVA_HOME}
+
+# Install the Apache plugin if needed
+.if defined(WITH_APACHE) && ($(WITH_APACHE) == yes || $(WITH_APACHE) == YES)
+#
+# Apache 1.3
+#
+BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/www/apache13
+CONFIGURE_ARGS+= --with-apxs=${APXS}
+PLIST_SUB+= MOD_DIR=libexec/apache
+.elif defined(WITH_APACHE2) && ($(WITH_APACHE2) == yes || $(WITH_APACHE2) == YES)
+#
+# Apache 2
+#
+BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/www/apache2
+CONFIGURE_ARGS+= --with-apxs=${APXS}
+PLIST_SUB+= MOD_DIR=libexec/apache2
+.else
+PLIST_SUB+= MOD_DIR="@comment "
+.endif
+
+.include <bsd.port.pre.mk>
+
+# Resin does not handle installation, so proceed now
+pre-install:
+ $(SED) -i -e "s|%%PREFIX%%|$(PREFIX)|g" $(WRKSRC)/src/c/plugin/apache/install.sh
+ $(SED) -i -e "s|%%PREFIX%%|$(PREFIX)|g" $(WRKSRC)/src/c/plugin/apache2/install.sh
+
+# Do not change the PID file location unless you also change it in pkg-deinstall script
+PID_FILE= /var/run/resin.pid
+
+post-install:
+ ${TOUCH} ${PID_FILE}
+ ${CHOWN} ${RUNASUID}:${GID} ${PID_FILE}
+ ${MKDIR} ${APP_HOME}
+ @PREFIX=${PREFIX} \
+ PKGNAMEPREFIX=${PKGNAMEPREFIX} \
+ PORTNAME=${PORTNAME} \
+ WRKSRC=${WRKSRC} \
+ RUNASUSER=${RUNASUSER} \
+ RUNASUID=${RUNASUID} \
+ GROUP=${GROUP} \
+ GID=${GID} \
+ PORT=${PORT} \
+ APP_HOME=${APP_HOME} \
+ JAVA_HOME=${JAVA_HOME} \
+ ${SH} pkg-install ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.post.mk>
+
+# ex:ts=18
diff --git a/www/resin2/distinfo b/www/resin2/distinfo
new file mode 100644
index 000000000000..331c69b26591
--- /dev/null
+++ b/www/resin2/distinfo
@@ -0,0 +1 @@
+MD5 (resin-2.1.11.tar.gz) = 97cd4be46138bf86ce582e437d747d1e
diff --git a/www/resin2/files/patch-Makefile.in b/www/resin2/files/patch-Makefile.in
new file mode 100644
index 000000000000..5754ce64ac6d
--- /dev/null
+++ b/www/resin2/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- src/c/plugin/resin/Makefile.in.orig Fri Feb 14 21:48:23 2003
++++ src/c/plugin/resin/Makefile.in Wed Mar 5 19:11:12 2003
+@@ -20,7 +20,7 @@
+ all : resin libresin.$(SO)
+
+ resin : resin.o $(OBJ)
+- $(CC) $(LDFLAGS) -o $@ resin.o $(OBJ) $(PROXY_LIBS) -ldl
++ $(CC) $(LDFLAGS) -o $@ resin.o $(OBJ) $(PROXY_LIBS)
+
+ resin_so : libresin.$(SO)
+
diff --git a/www/resin2/files/patch-apache2 b/www/resin2/files/patch-apache2
new file mode 100644
index 000000000000..2130da28e974
--- /dev/null
+++ b/www/resin2/files/patch-apache2
@@ -0,0 +1,11 @@
+--- src/c/plugin/apache2/mod_caucho.c.orig Tue Apr 15 23:28:46 2003
++++ src/c/plugin/apache2/mod_caucho.c Fri Jun 6 01:37:29 2003
+@@ -52,7 +52,7 @@
+ #include "cse.h"
+ #include "version.h"
+
+-#ifndef APR_HAS_THREADS
++#if !APR_HAS_THREADS
+ #define apr_thread_mutex_t int
+ #define apr_thread_mutex_create(a,b,c)
+ #define apr_thread_mutex_lock(a)
diff --git a/www/resin2/files/patch-httpd.sh b/www/resin2/files/patch-httpd.sh
new file mode 100644
index 000000000000..0eb3b58dd55b
--- /dev/null
+++ b/www/resin2/files/patch-httpd.sh
@@ -0,0 +1,34 @@
+--- bin/httpd.sh.orig Tue Apr 15 23:28:50 2003
++++ bin/httpd.sh Thu Jul 24 14:35:36 2003
+@@ -37,11 +37,8 @@
+ #
+ # You can predefine JAVA_HOME and RESIN_HOME
+ #
+-# JAVA_HOME=/usr/java
+-# export JAVA_HOME
+-#
+-# RESIN_HOME=/usr/local/resin
+-# export RESIN_HOME
++export JAVA_HOME=%%JAVA_HOME%%
++export RESIN_HOME=%%PREFIX%%/%%PKGNAMEPREFIX%%%%PORTNAME%%
+ #
+ # Extra arguments to Java. If you're passing arguments to the JVM, you'll
+ # need to use -Jxxx. For example, args="-J-ms48m". You can modify
+@@ -61,16 +58,4 @@
+ #
+ perl=perl
+
+-#
+-# trace script and simlinks to find thw wrapper
+-#
+-script=`/bin/ls -l $0 | awk '{ print $NF; }'`
+-
+-while test -h "$script"
+-do
+- script=`/bin/ls -l $script | awk '{ print $NF; }'`
+-done
+-
+-bin=`dirname $script`
+-
+-exec $perl $bin/wrapper.pl -chdir -name "$name" -class "$class" $args $*
++su -f -m www -c "exec $perl %%PREFIX%%/sbin/resinctl -conf %%PREFIX%%/etc/resin.xml -chdir -name "$name" -class "$class" $args $*" > /dev/null && echo -n '%%PKGNAMEPREFIX%%%%PORTNAME%% '
diff --git a/www/resin2/files/patch-install-apache b/www/resin2/files/patch-install-apache
new file mode 100644
index 000000000000..42482c94dc9a
--- /dev/null
+++ b/www/resin2/files/patch-install-apache
@@ -0,0 +1,10 @@
+--- src/c/plugin/apache/install.sh.orig Fri Jul 25 15:34:33 2003
++++ src/c/plugin/apache/install.sh Fri Jul 25 15:35:53 2003
+@@ -51,6 +51,6 @@
+
+ LoadModule caucho_module $LIBEXECDIR/mod_caucho.so
+
+-CauchoConfigFile $RESIN_HOME/conf/resin.conf
++CauchoConfigFile %%PREFIX%%/etc/resin.xml
+ EOF
+ fi
diff --git a/www/resin2/files/patch-install-apache2 b/www/resin2/files/patch-install-apache2
new file mode 100644
index 000000000000..98d826a6c83f
--- /dev/null
+++ b/www/resin2/files/patch-install-apache2
@@ -0,0 +1,11 @@
+--- src/c/plugin/apache2/install.sh.orig Fri Jul 25 15:34:39 2003
++++ src/c/plugin/apache2/install.sh Fri Jul 25 15:35:53 2003
+@@ -51,7 +51,7 @@
+
+ LoadModule caucho_module $LIBEXECDIR/mod_caucho.so
+
+-CauchoConfigFile $RESIN_HOME/conf/resin.conf
++CauchoConfigFile %%PREFIX%%/etc/resin.xml
+ EOF
+
+ fi
diff --git a/www/resin2/files/patch-resin.conf b/www/resin2/files/patch-resin.conf
new file mode 100644
index 000000000000..a90a144e6c7c
--- /dev/null
+++ b/www/resin2/files/patch-resin.conf
@@ -0,0 +1,11 @@
+--- conf/resin.conf.orig Thu Mar 6 10:19:07 2003
++++ conf/resin.conf Wed Mar 5 21:05:50 2003
+@@ -67,7 +67,7 @@
+ <doc-dir>doc</doc-dir>
+
+ <!-- the http port -->
+- <http port='8080'/>
++ <http port='%%PORT%%'/>
+
+ <!--
+ - The srun port, read by both JVM and plugin
diff --git a/www/resin2/pkg-deinstall b/www/resin2/pkg-deinstall
new file mode 100644
index 000000000000..f5ec53c59f44
--- /dev/null
+++ b/www/resin2/pkg-deinstall
@@ -0,0 +1,43 @@
+#!/bin/sh
+#
+# This script does the following.
+#
+# * Checks if the PID file exists. If it does, it kills the
+# process and removes the PID file.
+#
+# * Checks if the 'www' user exists. If it does, then it displays
+# a message.
+#
+
+# Make sure we're in the right stage of the process
+if [ "$2" = "DEINSTALL" ]; then
+
+ # Kill the process if it is still running
+ PID_FILE=/var/run/resin.pid
+ if [ -s ${PID_FILE} ]; then
+ PID=`cat ${PID_FILE}`
+ echo -n ">> Killing Resin process (${PID})..."
+ /bin/kill ${PID} > /dev/null 2> /dev/null
+ if [ $? -eq 0 ]; then
+ echo " [ DONE ]"
+ else
+ echo " [ FAILED ]"
+ fi
+ echo -n ">> Removing PID file (${PID_FILE})..."
+ rm ${PID_FILE} > /dev/null 2> /dev/null
+ if [ $? -eq 0 ]; then
+ echo " [ DONE ]"
+ else
+ echo " [ FAILED ]"
+ fi
+ fi
+fi
+
+if [ "$2" = "POST-DEINSTALL" ]; then
+ # If the user exists, then display a message
+ if pw usershow "www" 2>/dev/null 1>&2; then
+ echo "To delete the www user permanently, use 'pw userdel www'"
+ fi
+fi
+
+exit 0
diff --git a/www/resin2/pkg-descr b/www/resin2/pkg-descr
new file mode 100644
index 000000000000..20d0cc9d42e9
--- /dev/null
+++ b/www/resin2/pkg-descr
@@ -0,0 +1,9 @@
+Resin is a fast servlet and JSP engine supporting load balancing for increased
+reliability. Resin encourages separation of content from style with its XSL
+support. Servlets can generate simple XML and use an XSL filter to format
+results for each client's capability, from palm pilots to Mozilla. Resin
+includes a full-featured HTTP/1.1 web server, provides a fast servlet runner
+for Apache, and supports the latest Servlet 2.3 and JSP 1.2 specifications from
+Sun.
+
+WWW: http://www.caucho.com/
diff --git a/www/resin2/pkg-install b/www/resin2/pkg-install
new file mode 100644
index 000000000000..34288f2aff95
--- /dev/null
+++ b/www/resin2/pkg-install
@@ -0,0 +1,98 @@
+#!/bin/sh -e
+#
+# Checks if the 'www' user and group exist. If they don't, then
+# an attempt is made to create both.
+#
+# Borrowed to the jakarta-tomcat port
+
+# Make sure we're called during the 'make install' process
+if [ "$2" != "POST-INSTALL" ]; then
+ exit 0
+fi
+
+# See if the group already exists
+if ! pw groupshow "${GROUP}" 2>/dev/null 1>&2; then
+
+ # If not, try to create it
+ if pw groupadd ${GROUP} -g ${GID}; then
+ echo "Added group \"${GROUP}\"."
+ else
+ echo "Adding group \"${GROUP}\" failed..."
+ exit 1
+ fi
+fi
+
+# See if the user already exists
+if ! pw usershow "${RUNASUSER}" 2>/dev/null 1>&2; then
+
+ # If not, try to create it
+ if pw useradd ${RUNASUSER} -u ${RUNASUID} -g ${GROUP} -h - \
+ -s "/sbin/nologin" -d "/nonexistent" \
+ -c "World Wide Web Owner"; \
+ then
+ echo "Added user \"${RUNASUSER}\"."
+ else
+ echo "Adding user \"${RUNASUSER}\" failed..."
+ exit 1
+ fi
+fi
+
+
+################################################################################
+
+sed -i -e "s|%%PORT%%|$PORT|g" $WRKSRC/conf/resin.conf
+
+# Install config file only if none is already there
+if test -e $PREFIX/etc/resin.xml && \
+ ! cmp -s $WRKSRC/conf/resin.conf $PREFIX/etc/resin.xml ; then
+ cat <<EOF
+
+********************************************************************************
+Kept $PREFIX/etc/resin.xml intact from previous installation, please diff
+against resin.xml-dist
+********************************************************************************
+
+EOF
+else
+ install $WRKSRC/conf/resin.conf $PREFIX/etc/resin.xml
+ echo Installed $PREFIX/etc/resin.xml
+fi
+
+# Install new config file with '-dist' appended
+install $WRKSRC/conf/resin.conf $PREFIX/etc/resin.xml-dist
+echo Installed $PREFIX/etc/resin.xml-dist
+
+sed -i -e "s|%%PREFIX%%|$PREFIX|g" $WRKSRC/bin/httpd.sh
+sed -i -e "s|%%PKGNAMEPREFIX%%|$PKGNAMEPREFIX|g" $WRKSRC/bin/httpd.sh
+sed -i -e "s|%%PORTNAME%%|$PORTNAME|g" $WRKSRC/bin/httpd.sh
+sed -i -e "s|%%JAVA_HOME%%|$JAVA_HOME|g" $WRKSRC/bin/httpd.sh
+install $WRKSRC/bin/httpd.sh $PREFIX/etc/rc.d/resin.sh
+echo Installed $PREFIX/etc/rc.d/resin.sh
+
+install $WRKSRC/bin/wrapper.pl $PREFIX/sbin/resinctl
+echo Installed $PREFIX/sbin/resinctl
+
+list()
+{
+ for dir in doc lib webapps xsl ; do
+ ( cd $WRKSRC ; find $dir )
+ done
+}
+
+echo Installing in $PREFIX/resin
+list | xargs tar -C $WRKSRC -cf- | tar -C $APP_HOME -xpf-
+
+chown -R www:www $PREFIX/resin
+
+display_message()
+{
+ PORT_EXPR="s#%%PORT%%#:$PORT#g"
+ PREFIX_EXPR="s#%%PREFIX%%#$PREFIX#g"
+ sed -e $PORT_EXPR -e $PREFIX_EXPR
+}
+
+echo
+display_message < pkg-message
+echo
+
+exit 0
diff --git a/www/resin2/pkg-message b/www/resin2/pkg-message
new file mode 100644
index 000000000000..bc9b32a88224
--- /dev/null
+++ b/www/resin2/pkg-message
@@ -0,0 +1,6 @@
+********************************************************************************
+Resin is now installed. You may want to start it using the startup script
+installed as %%PREFIX%%/etc/rc.d/resin.sh, and then point your web browser to
+the default home page at http://localhost%%PORT%%/ to read the doc. Resin can
+be configured using %%PREFIX%%/etc/resin.xml.
+********************************************************************************
diff --git a/www/resin2/pkg-plist b/www/resin2/pkg-plist
new file mode 100644
index 000000000000..86d67ed4e9bb
--- /dev/null
+++ b/www/resin2/pkg-plist
@@ -0,0 +1,468 @@
+resin/doc/beta.xtp
+resin/doc/changes-1.xtp
+resin/doc/changes.xtp
+resin/doc/errata.xtp
+resin/doc/features.xtp
+resin/doc/future.xtp
+resin/doc/index.xtp
+resin/doc/toc.xml
+resin/doc/examples/basic/WEB-INF/classes/Env.java
+resin/doc/examples/basic/WEB-INF/classes/HelloServlet.java
+resin/doc/examples/basic/counter.jsp
+resin/doc/examples/basic/dir.jsp
+resin/doc/examples/basic/dummy.jsp
+resin/doc/examples/basic/env.jsp
+resin/doc/examples/basic/file.jsp
+resin/doc/examples/basic/form.html
+resin/doc/examples/basic/form.jsp
+resin/doc/examples/basic/hello.jsp
+resin/doc/examples/basic/quote.jsp
+resin/doc/examples/basic/quote_error.jsp
+resin/doc/examples/basic/session.jsp
+resin/doc/examples/basic/stats.jsp
+resin/doc/examples/basic/com/caucho/fortune/1.html
+resin/doc/examples/basic/com/caucho/fortune/2.html
+resin/doc/examples/basic/com/caucho/fortune/3.html
+resin/doc/examples/basic/com/caucho/fortune/4.html
+resin/doc/examples/basic/com/caucho/fortune/5.html
+resin/doc/examples/basic/data/fortune/1.html
+resin/doc/examples/basic/data/fortune/2.html
+resin/doc/examples/basic/data/fortune/3.html
+resin/doc/examples/basic/data/fortune/4.html
+resin/doc/examples/basic/data/fortune/5.html
+resin/doc/examples/index.xtp
+resin/doc/examples/toc.xml
+resin/doc/examples/view_source.jsp
+resin/doc/examples/login/WEB-INF/classes/test/TestAuthenticator.java
+resin/doc/examples/login/WEB-INF/web.xml
+resin/doc/examples/login/error.html
+resin/doc/examples/login/index.jsp
+resin/doc/examples/login/login.html
+resin/doc/examples/login/login.jsp
+resin/doc/examples/login/protected.jsp
+resin/doc/examples/navigation/WEB-INF/scripts/Navigation.js
+resin/doc/examples/navigation/WEB-INF/scripts/fancy_header.js
+resin/doc/examples/navigation/WEB-INF/scripts/header.js
+resin/doc/examples/navigation/article1.jsp
+resin/doc/examples/navigation/article2.jsp
+resin/doc/examples/navigation/child1.jsp
+resin/doc/examples/navigation/child2.jsp
+resin/doc/examples/navigation/conclusion.jsp
+resin/doc/examples/navigation/navigation.jsp
+resin/doc/examples/navigation/toc.xml
+resin/doc/examples/templates/admin.jsp
+resin/doc/examples/templates/add.jsp
+resin/doc/examples/templates/add.xtp
+resin/doc/examples/templates/WEB-INF/classes/jsp/Guest.java
+resin/doc/examples/templates/WEB-INF/classes/jsp/GuestBook.java
+resin/doc/examples/templates/WEB-INF/classes/jsp/GuestJsp.java
+resin/doc/examples/templates/WEB-INF/classes/jsp/GuestXtp.java
+resin/doc/examples/templates/WEB-INF/classes/jsp/RSS.java
+resin/doc/examples/templates/WEB-INF/xsl/caucho_form.xsl
+resin/doc/examples/templates/WEB-INF/xsl/default.xsl
+resin/doc/examples/templates/WEB-INF/xsl/defaultcopy.xsl
+resin/doc/examples/templates/WEB-INF/xsl/form.xsl
+resin/doc/examples/templates/WEB-INF/xsl/formatting.xsl
+resin/doc/examples/templates/WEB-INF/xsl/guestbook.xsl
+resin/doc/examples/templates/WEB-INF/xsl/header.xsl
+resin/doc/examples/templates/WEB-INF/xsl/rss.xsl
+resin/doc/examples/templates/admin.xtp
+resin/doc/examples/templates/guestbook.jsp
+resin/doc/examples/templates/guestbook.xtp
+resin/doc/examples/templates/guestbook_bean.jsp
+resin/doc/examples/templates/guestbook_inc.jsp
+resin/doc/examples/templates/list.jsp
+resin/doc/examples/templates/login.jsp
+resin/doc/examples/templates/login.xtp
+resin/doc/examples/templates/loginold.jsp
+resin/doc/examples/templates/rss.xtp
+resin/doc/examples/templates/simple-format.xsl
+resin/doc/examples/tictactoe/WEB-INF/scripts/score.js
+resin/doc/examples/tictactoe/error.jsp
+resin/doc/examples/tictactoe/tictactoe.jsp
+resin/doc/examples/tutorial/WEB-INF/classes/servlet/trivial/HelloServlet.java
+resin/doc/examples/tutorial/WEB-INF/web.xml
+resin/doc/examples/xsl/WEB-INF/classes/xsl/Dispatch.java
+resin/doc/examples/xsl/WEB-INF/web.xml
+resin/doc/examples/xsl/WEB-INF/scripts/Navigation.js
+resin/doc/examples/xsl/WEB-INF/xsl/basic.xsl
+resin/doc/examples/xsl/WEB-INF/xsl/content.xsl
+resin/doc/examples/xsl/WEB-INF/xsl/copy.xsl
+resin/doc/examples/xsl/WEB-INF/xsl/counter.xsl
+resin/doc/examples/xsl/WEB-INF/xsl/default.xsl
+resin/doc/examples/xsl/WEB-INF/xsl/header.xsl
+resin/doc/examples/xsl/WEB-INF/xsl/plain.xsl
+resin/doc/examples/xsl/WEB-INF/xsl/verify.xsl
+resin/doc/examples/xsl/basic.xtp
+resin/doc/examples/xsl/counter.xtp
+resin/doc/examples/xsl/good-doc.xtp
+resin/doc/examples/xsl/index.xml
+resin/doc/examples/xsl/navigation.xtp
+resin/doc/examples/xsl/toc.xml
+resin/doc/examples/xsl/vary.xml
+resin/doc/examples/xsl/vary.xtp
+resin/doc/examples/xsl/verify-bad.xtp
+resin/doc/examples/xsl/verify-ok.xtp
+resin/doc/examples/xsl/data/fortune/1.html
+resin/doc/examples/xsl/data/fortune/2.html
+resin/doc/examples/xsl/data/fortune/3.html
+resin/doc/examples/xsl/data/fortune/4.html
+resin/doc/examples/xsl/data/fortune/5.html
+resin/doc/images/apache_srun.gif
+resin/doc/images/appserver.gif
+resin/doc/images/background.gif
+resin/doc/images/backup.gif
+resin/doc/images/ball8.gif
+resin/doc/images/bean.gif
+resin/doc/images/bean1.gif
+resin/doc/images/caucho.gif
+resin/doc/images/compiler.gif
+resin/doc/images/file.gif
+resin/doc/images/folder.gif
+resin/doc/images/hbleed.gif
+resin/doc/images/httpd.gif
+resin/doc/images/iis_srun.gif
+resin/doc/images/jndi_tree.gif
+resin/doc/images/jsp.gif
+resin/doc/images/logo.gif
+resin/doc/images/pixel.gif
+resin/doc/images/resin_powered.gif
+resin/doc/images/same_srun.gif
+resin/doc/images/script.gif
+resin/doc/images/srunc.gif
+resin/doc/images/sticky-sessions.gif
+resin/doc/images/style.gif
+resin/doc/images/webserver.gif
+resin/doc/images/website_srun.gif
+resin/doc/images/caucho-blue.gif
+resin/doc/images/left_background.gif
+resin/doc/java_tut/WEB-INF/classes/example/servlet/basic/HelloServlet.java
+resin/doc/java_tut/WEB-INF/classes/example/servlet/basic/InitServlet.java
+resin/doc/java_tut/WEB-INF/classes/example/servlet/basic/MappingServlet.java
+resin/doc/java_tut/WEB-INF/classes/example/servlet/basic/URLServlet.java
+resin/doc/java_tut/WEB-INF/classes/example/servlet/database/InitDatabaseServlet.java
+resin/doc/java_tut/WEB-INF/classes/example/servlet/database/QueryServlet.java
+resin/doc/java_tut/WEB-INF/web.xml
+resin/doc/java_tut/WEB-INF/sql/default.sql
+resin/doc/java_tut/add_page.xtp
+resin/doc/java_tut/bean.xtp
+resin/doc/java_tut/cache.xtp
+resin/doc/java_tut/conf-basic.xtp
+resin/doc/java_tut/conf-dir.xtp
+resin/doc/java_tut/conf-servlet.xtp
+resin/doc/java_tut/conf.xtp
+resin/doc/java_tut/db-config.xtp
+resin/doc/java_tut/db_form.xtp
+resin/doc/java_tut/debug.xtp
+resin/doc/java_tut/filter-vary.xtp
+resin/doc/java_tut/form.xtp
+resin/doc/java_tut/hardcore.xtp
+resin/doc/java_tut/index.xtp
+resin/doc/java_tut/isp.xtp
+resin/doc/java_tut/linux-boot.xtp
+resin/doc/java_tut/linux-init.xtp
+resin/doc/java_tut/mail_form.xtp
+resin/doc/java_tut/multipart.xtp
+resin/doc/java_tut/parse_error.xtp
+resin/doc/java_tut/req_headers.xtp
+resin/doc/java_tut/plugin-dispatch.xtp
+resin/doc/java_tut/req_url.xtp
+resin/doc/java_tut/run-at.xtp
+resin/doc/java_tut/run_error.xtp
+resin/doc/java_tut/servlets.xtp
+resin/doc/java_tut/tag-attribute.xtp
+resin/doc/java_tut/tag-connection.xtp
+resin/doc/java_tut/tag-hello.xtp
+resin/doc/java_tut/tag-mail.xtp
+resin/doc/java_tut/tag-xsl.xtp
+resin/doc/java_tut/tcp-sessions.xtp
+resin/doc/java_tut/toc.xml
+resin/doc/java_tut/tuning.xtp
+resin/doc/java_tut/war-dir.xtp
+resin/doc/java_tut/xsl-filter.xtp
+resin/doc/java_tut/xtp-copy.xtp
+resin/doc/java_tut/xtp-format.xtp
+resin/doc/java_tut/xtp-jsp-stylescript.xtp
+resin/doc/java_tut/xtp-jsp.xtp
+resin/doc/java_tut/xtp-page.xtp
+resin/doc/java_tut/xtp-strict.xtp
+resin/doc/java_tut/javadoc/constant-values.html
+resin/doc/java_tut/javadoc/resources/inherit.gif
+resin/doc/java_tut/javadoc/overview-tree.html
+resin/doc/java_tut/javadoc/index-all.html
+resin/doc/java_tut/javadoc/deprecated-list.html
+resin/doc/java_tut/javadoc/allclasses-frame.html
+resin/doc/java_tut/javadoc/allclasses-noframe.html
+resin/doc/java_tut/javadoc/index.html
+resin/doc/java_tut/javadoc/packages.html
+resin/doc/java_tut/javadoc/overview-summary.html
+resin/doc/java_tut/javadoc/overview-frame.html
+resin/doc/java_tut/javadoc/example/servlet/basic/package-frame.html
+resin/doc/java_tut/javadoc/example/servlet/basic/package-summary.html
+resin/doc/java_tut/javadoc/example/servlet/basic/package-tree.html
+resin/doc/java_tut/javadoc/example/servlet/basic/HelloServlet.html
+resin/doc/java_tut/javadoc/example/servlet/basic/InitServlet.html
+resin/doc/java_tut/javadoc/example/servlet/basic/MappingServlet.html
+resin/doc/java_tut/javadoc/example/servlet/basic/URLServlet.html
+resin/doc/java_tut/javadoc/example/servlet/database/package-frame.html
+resin/doc/java_tut/javadoc/example/servlet/database/package-summary.html
+resin/doc/java_tut/javadoc/example/servlet/database/package-tree.html
+resin/doc/java_tut/javadoc/example/servlet/database/InitDatabaseServlet.html
+resin/doc/java_tut/javadoc/example/servlet/database/QueryServlet.html
+resin/doc/java_tut/javadoc/serialized-form.html
+resin/doc/java_tut/javadoc/package-list
+resin/doc/java_tut/javadoc/help-doc.html
+resin/doc/java_tut/javadoc/stylesheet.css
+resin/doc/java_tut/images/same_srun.gif
+resin/doc/java_tut/images/srunc.gif
+resin/doc/ref/jsp/jsp-el.xtp
+resin/doc/ref/admin.xtp
+resin/doc/ref/app-config.xtp
+resin/doc/ref/atp.xtp
+resin/doc/ref/auth-config.xtp
+resin/doc/ref/balance.xtp
+resin/doc/ref/basic-config.xtp
+resin/doc/ref/bnf.xtp
+resin/doc/ref/burlap.xtp
+resin/doc/ref/caching.xtp
+resin/doc/ref/changes.xtp
+resin/doc/ref/config-index.xtp
+resin/doc/ref/config-sum.xtp
+resin/doc/ref/config.xtp
+resin/doc/ref/contents.xtp
+resin/doc/ref/cse-apache-unix.xtp
+resin/doc/ref/cse-apache-win.xtp
+resin/doc/ref/cse-iis.xtp
+resin/doc/ref/cse-netscape.xtp
+resin/doc/ref/cse-oreilly-website.xtp
+resin/doc/ref/db-config.xtp
+resin/doc/ref/xml/attributes.xtp
+resin/doc/ref/xml/elements.xtp
+resin/doc/ref/xml/get_elements.xtp
+resin/doc/ref/xml/html.xtp
+resin/doc/ref/xml/index.xtp
+resin/doc/ref/xml/intro.xtp
+resin/doc/ref/xml/parsing.xtp
+resin/doc/ref/xml/sax.xtp
+resin/doc/ref/xml/text.xtp
+resin/doc/ref/xml/vfs.xtp
+resin/doc/ref/ejb-ias.xtp
+resin/doc/ref/ejb-jboss.xtp
+resin/doc/ref/ejb-jonas.xtp
+resin/doc/ref/ejb-orion.xtp
+resin/doc/ref/ejb-weblogic.xtp
+resin/doc/ref/ejb.xtp
+resin/doc/ref/errata.xtp
+resin/doc/ref/faq.xtp
+resin/doc/ref/file-config.xtp
+resin/doc/ref/filesystems.xtp
+resin/doc/ref/filter-config.xtp
+resin/doc/ref/filter-library.xtp
+resin/doc/ref/filter.xtp
+resin/doc/ref/glossary.xtp
+resin/doc/ref/hessian.xtp
+resin/doc/ref/http-config.xtp
+resin/doc/ref/httpd.xtp
+resin/doc/ref/ide-jbuilder.xtp
+resin/doc/ref/ide-kawa.xtp
+resin/doc/ref/ide.xtp
+resin/doc/ref/index.xtp
+resin/doc/ref/javascript.xtp
+resin/doc/ref/jms.xtp
+resin/doc/ref/jmx.xtp
+resin/doc/ref/jndi.xtp
+resin/doc/ref/jsp-actions.xtp
+resin/doc/ref/jsp-applications.xtp
+resin/doc/ref/jsp-directives.xtp
+resin/doc/ref/jsp-variables.xtp
+resin/doc/ref/jsp.xtp
+resin/doc/ref/jspapp.xtp
+resin/doc/ref/jtp.xtp
+resin/doc/ref/log-config.xtp
+resin/doc/ref/macos-x.xtp
+resin/doc/ref/page_context.xtp
+resin/doc/ref/port-config.xtp
+resin/doc/ref/raw-socket.xtp
+resin/doc/ref/resin-config.xtp
+resin/doc/ref/security.xtp
+resin/doc/ref/servlet-config.xtp
+resin/doc/ref/servlet-library.xtp
+resin/doc/ref/servlet.xtp
+resin/doc/ref/servletcontext.xtp
+resin/doc/ref/sessions.xtp
+resin/doc/ref/xsl/apply-templates.xtp
+resin/doc/ref/xsl/attribute.xtp
+resin/doc/ref/xsl/boxes.xtp
+resin/doc/ref/xsl/command-line.xtp
+resin/doc/ref/xsl/copy.xtp
+resin/doc/ref/xsl/filter-attribute.xtp
+resin/doc/ref/xsl/filter.xtp
+resin/doc/ref/xsl/hello.xtp
+resin/doc/ref/xsl/if-attribute.xtp
+resin/doc/ref/xsl/if-xpath-attribute.xtp
+resin/doc/ref/xsl/if.xtp
+resin/doc/ref/xsl/index.xtp
+resin/doc/ref/xsl/modes.xtp
+resin/doc/ref/xsl/ref.xtp
+resin/doc/ref/xsl/short-attribute.xtp
+resin/doc/ref/xsl/value-of.xtp
+resin/doc/ref/xsl/xpath-find.xtp
+resin/doc/ref/xsl/xpath-select.xtp
+resin/doc/ref/xsl/xpath.xtp
+resin/doc/ref/xsl/xsl-api.xtp
+resin/doc/ref/xsl/xsl.xtp
+resin/doc/ref/xsl/xsl-boxes.xtp
+resin/doc/ref/srun-other.xtp
+resin/doc/ref/ssl-quick.xml
+resin/doc/ref/ssl-quick.xtp
+resin/doc/ref/ssl.xml
+resin/doc/ref/ssl.xtp
+resin/doc/ref/starting.xtp
+resin/doc/ref/static.xtp
+resin/doc/ref/stylescript.xtp
+resin/doc/ref/taglib.xtp
+resin/doc/ref/toc.xml
+resin/doc/ref/topics.xtp
+resin/doc/ref/trouble.xtp
+resin/doc/ref/velocity.xtp
+resin/doc/ref/virtual-host.xtp
+resin/doc/ref/visual-age.xtp
+resin/doc/ref/war-dir.xtp
+resin/doc/ref/webdav.xtp
+resin/doc/ref/xml.xtp
+resin/doc/ref/xpath-fun.xtp
+resin/doc/ref/xpath.xtp
+resin/doc/ref/xsl.xtp
+resin/doc/ref/xslt-lite-eg.xtp
+resin/doc/ref/xslt-lite.xtp
+resin/doc/ref/xtp-jsp.xtp
+resin/doc/ref/xtp-index.xtp
+resin/doc/ref/xtp-intro.xtp
+resin/doc/ref/xtp.xtp
+resin/doc/faq/classloader.xtp
+resin/doc/faq/config.xtp
+resin/doc/faq/debug.xtp
+resin/doc/faq/index.xtp
+resin/doc/faq/install.xtp
+resin/doc/faq/misc.xtp
+resin/doc/faq/servlet.xtp
+resin/doc/faq/ssl.xtp
+resin/doc/faq/toc.xml
+resin/doc/css/default.css
+resin/lib/resin.jar
+resin/lib/jsdk23.jar
+resin/lib/jdbc2_0-stdext.jar
+resin/lib/jta_101.jar
+resin/lib/jndi.jar
+resin/lib/dom.jar
+resin/lib/sax.jar
+resin/lib/jaxp.jar
+resin/lib/jmx.jar
+resin/lib/webutil.jar
+resin/lib/jdbc-mysql.jar
+resin/xsl/caucho/comment.xsl
+resin/xsl/caucho/contents.xsl
+resin/xsl/caucho/control.xsl
+resin/xsl/caucho/debug.xsl
+resin/xsl/caucho/defaultcopy.xsl
+resin/xsl/caucho/format.xsl
+resin/xsl/caucho/newstyle.xsl
+resin/xsl/caucho/weblog.xsl
+resin/xsl/caucho_default.xsl
+resin/xsl/caucho_header.xsl
+resin/xsl/caucho_subpage.xsl
+resin/xsl/default.xsl
+resin/xsl/doc_header.xsl
+resin/xsl/header.xsl
+resin/xsl/js_header.xsl
+resin/xsl/new_doc_header.xsl
+resin/xsl/search.xsl
+resin/xsl/subpage.xsl
+resin/xsl/js/caucho/defaultcopy.xsl
+resin/xsl/js/caucho/format.xsl
+resin/xsl/js/caucho/weblog.xsl
+etc/rc.d/resin.sh
+sbin/resinctl
+%%MOD_DIR%%/mod_caucho.so
+@dirrm resin/doc/examples/basic/WEB-INF/classes
+@dirrm resin/doc/examples/basic/WEB-INF/tmp
+@dirrm resin/doc/examples/basic/WEB-INF
+@dirrm resin/doc/examples/basic/com/caucho/fortune
+@dirrm resin/doc/examples/basic/com/caucho
+@dirrm resin/doc/examples/basic/com
+@dirrm resin/doc/examples/basic/data/fortune
+@dirrm resin/doc/examples/basic/data
+@dirrm resin/doc/examples/basic
+@dirrm resin/doc/examples/login/WEB-INF/classes/test
+@dirrm resin/doc/examples/login/WEB-INF/classes
+@dirrm resin/doc/examples/login/WEB-INF/tmp
+@dirrm resin/doc/examples/login/WEB-INF
+@dirrm resin/doc/examples/login
+@dirrm resin/doc/examples/navigation/WEB-INF/scripts
+@dirrm resin/doc/examples/navigation/WEB-INF/tmp
+@dirrm resin/doc/examples/navigation/WEB-INF
+@dirrm resin/doc/examples/navigation
+@dirrm resin/doc/examples/templates/WEB-INF/classes/jsp
+@dirrm resin/doc/examples/templates/WEB-INF/classes
+@dirrm resin/doc/examples/templates/WEB-INF/xsl
+@dirrm resin/doc/examples/templates/WEB-INF/tmp
+@dirrm resin/doc/examples/templates/WEB-INF
+@dirrm resin/doc/examples/templates
+@dirrm resin/doc/examples/tictactoe/WEB-INF/scripts
+@dirrm resin/doc/examples/tictactoe/WEB-INF/tmp
+@dirrm resin/doc/examples/tictactoe/WEB-INF
+@dirrm resin/doc/examples/tictactoe
+@dirrm resin/doc/examples/tutorial/WEB-INF/classes/servlet/trivial
+@dirrm resin/doc/examples/tutorial/WEB-INF/classes/servlet
+@dirrm resin/doc/examples/tutorial/WEB-INF/classes
+@dirrm resin/doc/examples/tutorial/WEB-INF
+@dirrm resin/doc/examples/tutorial
+@dirrm resin/doc/examples/xsl/WEB-INF/classes/xsl
+@dirrm resin/doc/examples/xsl/WEB-INF/classes
+@dirrm resin/doc/examples/xsl/WEB-INF/scripts
+@dirrm resin/doc/examples/xsl/WEB-INF/xsl
+@dirrm resin/doc/examples/xsl/WEB-INF/tmp
+@dirrm resin/doc/examples/xsl/WEB-INF
+@dirrm resin/doc/examples/xsl/data/fortune
+@dirrm resin/doc/examples/xsl/data
+@dirrm resin/doc/examples/xsl
+@dirrm resin/doc/examples/tags/WEB-INF/tmp
+@dirrm resin/doc/examples/tags/WEB-INF
+@dirrm resin/doc/examples/tags
+@dirrm resin/doc/examples
+@dirrm resin/doc/images
+@dirrm resin/doc/java_tut/WEB-INF/classes/example/servlet/basic
+@dirrm resin/doc/java_tut/WEB-INF/classes/example/servlet/database
+@dirrm resin/doc/java_tut/WEB-INF/classes/example/servlet
+@dirrm resin/doc/java_tut/WEB-INF/classes/example
+@dirrm resin/doc/java_tut/WEB-INF/classes
+@dirrm resin/doc/java_tut/WEB-INF/sql
+@dirrm resin/doc/java_tut/WEB-INF/tmp
+@dirrm resin/doc/java_tut/WEB-INF
+@dirrm resin/doc/java_tut/javadoc/resources
+@dirrm resin/doc/java_tut/javadoc/example/servlet/basic
+@dirrm resin/doc/java_tut/javadoc/example/servlet/database
+@dirrm resin/doc/java_tut/javadoc/example/servlet
+@dirrm resin/doc/java_tut/javadoc/example
+@dirrm resin/doc/java_tut/javadoc
+@dirrm resin/doc/java_tut/images
+@dirrm resin/doc/java_tut
+@dirrm resin/doc/ref/jsp
+@dirrm resin/doc/ref/xml
+@dirrm resin/doc/ref/xsl
+@dirrm resin/doc/ref
+@dirrm resin/doc/faq
+@dirrm resin/doc/css
+@dirrm resin/doc/WEB-INF/classes
+@dirrm resin/doc/WEB-INF/lib
+@dirrm resin/doc/WEB-INF
+@dirrm resin/doc
+@dirrm resin/lib
+@dirrm resin/webapps
+@dirrm resin/xsl/caucho
+@dirrm resin/xsl/js/caucho
+@dirrm resin/xsl/js
+@dirrm resin/xsl
+@dirrm resin
+@unexec if cmp -s %D/etc/resin.xml %D/etc/resin.xml-dist; then rm -f %D/etc/resin.xml; else echo If permanently deleting this package, %%PREFIX%%/etc/resin.xml must be removed manually; fi
+etc/resin.xml-dist