aboutsummaryrefslogtreecommitdiff
path: root/www/resin3/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-12-16 22:03:16 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-12-16 22:03:16 +0000
commit3bebe87947687ad7466b5f11d03fea2cd0ea6b25 (patch)
tree7c6d2032c86c7900ccefa681fa6996e9d4aede64 /www/resin3/Makefile
parent435292f6ca293d26d6a6da5ba9a4e78c18f5c4bf (diff)
downloadports-3bebe87947687ad7466b5f11d03fea2cd0ea6b25.tar.gz
ports-3bebe87947687ad7466b5f11d03fea2cd0ea6b25.zip
Notes
Diffstat (limited to 'www/resin3/Makefile')
-rw-r--r--www/resin3/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/www/resin3/Makefile b/www/resin3/Makefile
index 11fb5008784e..923e28a74090 100644
--- a/www/resin3/Makefile
+++ b/www/resin3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= resin
PORTVERSION= 3.0.21
+PORTREVISION= 1
CATEGORIES= www java
MASTER_SITES= http://www.caucho.com/download/
@@ -114,6 +115,11 @@ SUBSTITUTIONS= -e "s|%%APP_HOME%%|${APP_HOME}|g" \
-e "s|%%WRKDIR%%|${WRKDIR}|g" \
-e "s|%%WRKSRC%%|${WRKSRC}|g"
+# Avoid build error on 64-bit architectures
+.if (${ARCH} == "amd64") || (${ARCH} == "ia64") || (${ARCH} == "sparc64")
+CFLAGS+= -fPIC
+.endif
+
post-patch:
@${REINPLACE_CMD} ${SUBSTITUTIONS} ${REINPLACE_FILES}
@for FILE in ${REPLACE_FILES} ; do \