aboutsummaryrefslogtreecommitdiff
path: root/www/resin3/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2004-03-29 16:40:23 +0000
committerGreg Lewis <glewis@FreeBSD.org>2004-03-29 16:40:23 +0000
commit7c5f2d9a14059567626004b92a7fa203cfffc1d7 (patch)
tree167504bb77d83df0c8c3e008b7def9e470bf8add /www/resin3/Makefile
parent3676196422f4b3161651876a37fc43f742a7d935 (diff)
downloadports-7c5f2d9a14059567626004b92a7fa203cfffc1d7.tar.gz
ports-7c5f2d9a14059567626004b92a7fa203cfffc1d7.zip
Notes
Diffstat (limited to 'www/resin3/Makefile')
-rw-r--r--www/resin3/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/www/resin3/Makefile b/www/resin3/Makefile
index 7ccdd083a947..3a5c2cffdb7e 100644
--- a/www/resin3/Makefile
+++ b/www/resin3/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= resin
-PORTVERSION= 3.0.6
+PORTVERSION= 3.0.7
CATEGORIES= www java
MASTER_SITES= http://www.caucho.com/download/
@@ -17,7 +17,9 @@ COMMENT= Resin, a Java-based Application Server, 3.x branch
USE_JAVA= 1.2+
HAS_CONFIGURE= yes
+USE_GMAKE= yes
USE_PERL5= yes
+USE_REINPLACE= yes
# Customizable settings
RUNASUSER?= www
@@ -53,7 +55,7 @@ REPLACE_FILES= ${FILESDIR}/pkg-install \
${WRKSRC}/conf/resin.conf \
${WRKSRC}/bin/wrapper.pl.in \
${FILESDIR}/resin.sh.in
-COPYDIRS= doc lib webapps xsl
+COPYDIRS= doc lib libexec webapps
# Pass JAVA_HOME as determined by bsd.java.mk
CONFIGURE_ARGS+= --with-java-home=${JAVA_HOME}
@@ -108,7 +110,7 @@ SUBSTITUTIONS= -e "s|%%APP_HOME%%|${APP_HOME}|g" \
post-patch:
.for FILE in ${REINPLACE_FILES}
- @${SED} -i bak ${SUBSTITUTIONS} ${FILE}
+ @${REINPLACE_CMD} ${SUBSTITUTIONS} ${FILE}
.endfor
.for FILE in ${REPLACE_FILES}
@${SED} ${SUBSTITUTIONS} ${FILE} > ${WRKDIR}/`basename ${FILE}`
@@ -121,7 +123,15 @@ defined(WITH_APACHE) && (${WITH_APACHE} == yes || ${WITH_APACHE} == YES))
in the Apache configuration file, where you should also \
add a line to specify the location of the Resin configuration \
server, for example: | fmt -w 80 >> ${PKGMESSAGE}
- @${ECHO_CMD} ResinConfigServer localhost 6802 >> ${PKGMESSAGE}
+ @${ECHO_CMD} >> ${PKGMESSAGE}
+ @${ECHO_CMD} "<IfModule mod_caucho.c>" >> ${PKGMESSAGE}
+.if (defined(WITH_APACHE2) && (${WITH_APACHE2} == yes || ${WITH_APACHE2} == YES))
+ @${ECHO_CMD} " ResinConfigServer localhost 6802" >> ${PKGMESSAGE}
+.endif
+.if (defined(WITH_APACHE) && (${WITH_APACHE} == yes || ${WITH_APACHE} == YES))
+ @${ECHO_CMD} " CauchoConfigFile ${PREFIX}/etc/${APP_NAME}/resin.xml" >> ${PKGMESSAGE}
+.endif
+ @${ECHO_CMD} "</IfModule>" >> ${PKGMESSAGE}
.endif
@${MV} ${WRKDIR}/wrapper.pl.in ${WRKSRC}/bin/wrapper.pl.in