aboutsummaryrefslogtreecommitdiff
path: root/www/resin3
diff options
context:
space:
mode:
authorMarc G. Fournier <scrappy@FreeBSD.org>2006-04-11 18:04:38 +0000
committerMarc G. Fournier <scrappy@FreeBSD.org>2006-04-11 18:04:38 +0000
commitb58430ef62fdeedc857cd0f11da170849208a590 (patch)
tree0fa2251f06e165794927d0bd8d8fb57cc46b7ce1 /www/resin3
parent5ef802661615ad65f468e71c5b1071af26b8bf68 (diff)
downloadports-b58430ef62fdeedc857cd0f11da170849208a590.tar.gz
ports-b58430ef62fdeedc857cd0f11da170849208a590.zip
Notes
Diffstat (limited to 'www/resin3')
-rw-r--r--www/resin3/Makefile5
-rw-r--r--www/resin3/files/patch-configure45
-rw-r--r--www/resin3/files/pkg-message.in3
3 files changed, 49 insertions, 4 deletions
diff --git a/www/resin3/Makefile b/www/resin3/Makefile
index 62afcd9e765b..a18eb3ee25ee 100644
--- a/www/resin3/Makefile
+++ b/www/resin3/Makefile
@@ -18,6 +18,7 @@ JAVA_VERSION= 1.2+
HAS_CONFIGURE= yes
USE_PYTHON= yes
USE_OPENSSL= yes
+USE_AUTOTOOLS= libtool:15
# Customizable settings
RUNASUSER?= www
@@ -61,7 +62,7 @@ CONFIGURE_ARGS+= --with-java-home=${JAVA_HOME} \
LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
# We need to link with cc instead of ld for the FreeBSD specific options used
# by threading libraries
-CONFIGURE_ENV= LD=${CC} PTHREAD_LIBS=${PTHREAD_LIBS} LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= LD=${CC} PTHREAD_LIBS=${PTHREAD_LIBS} LDFLAGS="${LDFLAGS}" LIBTOOL=${LIBTOOL}
# Install the Apache plugin if needed
.if defined(WITH_APACHE) && (${WITH_APACHE} == yes || ${WITH_APACHE} == YES)
@@ -131,7 +132,7 @@ defined(WITH_APACHE) && (${WITH_APACHE} == yes || ${WITH_APACHE} == YES))
.endif
post-build:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} install
+ cd ${WRKSRC}/modules/c/src/resin_os && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} install
# Resin does not handle installation, so proceed now
do-install:
diff --git a/www/resin3/files/patch-configure b/www/resin3/files/patch-configure
index 47c329bec2e0..ef4b3705d313 100644
--- a/www/resin3/files/patch-configure
+++ b/www/resin3/files/patch-configure
@@ -1,6 +1,47 @@
--- configure.orig Thu Feb 23 00:59:58 2006
-+++ configure Mon Apr 3 10:55:28 2006
-@@ -9026,33 +9026,8 @@
++++ configure Wed Apr 5 11:03:16 2006
+@@ -8193,37 +8193,12 @@
+
+
+
+-# This can be used to rebuild libtool when needed
+-LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+-
+-# Always use our own libtool.
+-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+-
+-# Prevent multiple expansion
+-
+-
+ #
+ # libtool stuff
+ #
+-if test -z "${LTFLAGS}"; then
+- LTFLAGS="--silent"
+-fi
+-
+-LIBTOOL_SCRIPT="`pwd`/libtool"
+-LIBTOOL="${LIBTOOL_SCRIPT} ${LTFLAGS}"
+-libtoolversion=`${SHELL} ${LIBTOOL_SCRIPT} --version`
+-case $libtoolversion in
+- *1.4*)
+- SH_LIBTOOL="${LIBTOOL_SCRIPT}"
+- SHLTCFLAGS="-prefer-pic"
+- LTCFLAGS="-prefer-non-pic -static"
+- ;;
+- *)
+- SH_LIBTOOL="${SHELL} ${LIBTOOL_SCRIPT} ${LTFLAGS}"
+- SHLTCFLAGS=""
+- LTCFLAGS=""
+- ;;
+-esac
++SH_LIBTOOL="${SHELL} ${LIBTOOL}"
++SHLTCFLAGS=""
++LTCFLAGS=""
+
+
+
+@@ -9026,33 +9001,8 @@
PROXY_LIBS='-lnsl -lsocket -lthread'
;;
diff --git a/www/resin3/files/pkg-message.in b/www/resin3/files/pkg-message.in
index 7d25594349cc..40dd6bcbbe0b 100644
--- a/www/resin3/files/pkg-message.in
+++ b/www/resin3/files/pkg-message.in
@@ -38,10 +38,13 @@ If you need to pass special options to Java, please set the
%%APP_NAME%%_flags option in /etc/rc.conf, see examples below:
# Prevent Java from opening an X11 display
+
%%APP_NAME%%_flags="-Djava.awt.headless=true"
# Increase memory limit of the Java virtual machine
+
%%APP_NAME%%_flags="-Xms32m -Xmx256m"
# Run Java with remote debugging turned on on port 8000
+
%%APP_NAME%%_flags="-Xdebug -Xnoagent -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=8000"