aboutsummaryrefslogtreecommitdiff
path: root/www/resin3
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-01-26 10:23:38 +0000
committerClement Laforet <clement@FreeBSD.org>2004-01-26 10:23:38 +0000
commit5e0219acda7d984479567588c5d6316a0f032dcf (patch)
treee2a18be36c7c537d59cd33a4bb743c8920afb019 /www/resin3
parentbfd9a1da9b93eaab8b8dbe9a54a8a7283987c947 (diff)
downloadports-5e0219acda7d984479567588c5d6316a0f032dcf.tar.gz
ports-5e0219acda7d984479567588c5d6316a0f032dcf.zip
Notes
Diffstat (limited to 'www/resin3')
-rw-r--r--www/resin3/Makefile11
-rw-r--r--www/resin3/distinfo2
-rw-r--r--www/resin3/files/install.sh4
-rw-r--r--www/resin3/files/patch-apache-Makefile.in2
-rw-r--r--www/resin3/files/patch-apache211
-rw-r--r--www/resin3/files/patch-resin.conf10
-rw-r--r--www/resin3/pkg-descr16
-rw-r--r--www/resin3/pkg-plist48
8 files changed, 54 insertions, 50 deletions
diff --git a/www/resin3/Makefile b/www/resin3/Makefile
index 74b028245d07..011a7b145c7b 100644
--- a/www/resin3/Makefile
+++ b/www/resin3/Makefile
@@ -8,8 +8,7 @@
#
PORTNAME= resin
-PORTVERSION= 3.0.3
-PORTREVISION= 1
+PORTVERSION= 3.0.6
CATEGORIES= www java
MASTER_SITES= http://www.caucho.com/download/
@@ -53,6 +52,7 @@ REPLACE_FILES= ${FILESDIR}/pkg-install \
${WRKSRC}/conf/resin.conf \
${WRKSRC}/bin/wrapper.pl.in \
${FILESDIR}/resin.sh.in
+COPYDIRS= doc lib webapps xsl
# Pass JAVA_HOME as determined by bsd.java.mk
CONFIGURE_ARGS+= --with-java-home=${JAVA_HOME}
@@ -88,6 +88,7 @@ PLIST_SUB+= APXS=${APXS}
SUBSTITUTIONS= -e "s|%%APP_HOME%%|${APP_HOME}|g" \
-e "s|%%APP_NAME%%|${APP_NAME}|g" \
-e "s|%%APXS%%|${APXS}|g" \
+ -e "s|%%COPYDIRS%%|${COPYDIRS}|g" \
-e "s|%%FILESDIR%%|${FILESDIR}|g" \
-e "s|%%GROUP%%|${GROUP}|g" \
-e "s|%%GID%%|${GID}|g" \
@@ -116,9 +117,9 @@ post-patch:
defined(WITH_APACHE) && (${WITH_APACHE} == yes || ${WITH_APACHE} == YES))
@${ECHO_CMD} >> ${PKGMESSAGE}
@${ECHO_CMD} The Resin Apache module mod_caucho has been activated \
- in the Apache configuration file, where you should also \
- add a line to specify the location of the Resin configuration \
- server, for example: | fmt -w 80 >> ${PKGMESSAGE}
+ in the Apache configuration file, where you should also \
+ add a line to specify the location of the Resin configuration \
+ server, for example: | fmt -w 80 >> ${PKGMESSAGE}
@${ECHO_CMD} ResinConfigServer localhost 6802 >> ${PKGMESSAGE}
.endif
@${MV} ${WRKDIR}/wrapper.pl.in ${WRKSRC}/bin/wrapper.pl.in
diff --git a/www/resin3/distinfo b/www/resin3/distinfo
index 3647fc3647f8..5941d9f40d8a 100644
--- a/www/resin3/distinfo
+++ b/www/resin3/distinfo
@@ -1 +1 @@
-MD5 (resin-3.0.3.tar.gz) = 3ac2280481f81a3ffd4b395498e32dc6
+MD5 (resin-3.0.6.tar.gz) = 032fc45db04945a95cb080fda1b8f216
diff --git a/www/resin3/files/install.sh b/www/resin3/files/install.sh
index 24794c4e9be9..2499baf9607d 100644
--- a/www/resin3/files/install.sh
+++ b/www/resin3/files/install.sh
@@ -39,13 +39,13 @@ echo Created installation directory %%APP_HOME%%
list()
{
- for dir in doc lib libexec xsl ; do
+ for dir in %%COPYDIRS%% libexec ; do
( cd %%WRKSRC%% ; find $dir )
done
}
# Remove all empty dirs
-( cd %%WRKSRC%% ; find doc -type d -empty -delete )
+( cd %%WRKSRC%% && find %%COPYDIRS%% libexec -type d -empty -delete )
echo Installing in %%APP_HOME%%
list | xargs tar -C %%WRKSRC%% -cf- | tar -C %%APP_HOME%% -xpf-
diff --git a/www/resin3/files/patch-apache-Makefile.in b/www/resin3/files/patch-apache-Makefile.in
index 4b10a88f34b5..161e6d7151d7 100644
--- a/www/resin3/files/patch-apache-Makefile.in
+++ b/www/resin3/files/patch-apache-Makefile.in
@@ -1,6 +1,6 @@
--- src/c/plugin/apache/Makefile.in.orig Thu Nov 13 09:27:52 2003
+++ src/c/plugin/apache/Makefile.in Thu Nov 13 09:28:36 2003
-@@ -28,8 +28,7 @@
+@@ -29,8 +29,7 @@
$(CC) -c $(INCLUDES) $(CFLAGS) $<
install :
diff --git a/www/resin3/files/patch-apache2 b/www/resin3/files/patch-apache2
deleted file mode 100644
index 2130da28e974..000000000000
--- a/www/resin3/files/patch-apache2
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/c/plugin/apache2/mod_caucho.c.orig Tue Apr 15 23:28:46 2003
-+++ src/c/plugin/apache2/mod_caucho.c Fri Jun 6 01:37:29 2003
-@@ -52,7 +52,7 @@
- #include "cse.h"
- #include "version.h"
-
--#ifndef APR_HAS_THREADS
-+#if !APR_HAS_THREADS
- #define apr_thread_mutex_t int
- #define apr_thread_mutex_create(a,b,c)
- #define apr_thread_mutex_lock(a)
diff --git a/www/resin3/files/patch-resin.conf b/www/resin3/files/patch-resin.conf
index f88ee07191c4..7d059801e11f 100644
--- a/www/resin3/files/patch-resin.conf
+++ b/www/resin3/files/patch-resin.conf
@@ -1,11 +1,11 @@
---- conf/resin.conf.orig Mon Sep 29 10:29:29 2003
-+++ conf/resin.conf Mon Sep 29 10:29:48 2003
-@@ -37,7 +37,7 @@
+--- conf/resin.conf.orig Wed Jan 21 01:46:58 2004
++++ conf/resin.conf Fri Jan 23 12:09:34 2004
+@@ -63,7 +63,7 @@
</class-loader>
<!-- The http port -->
-- <http id='' host='*' port='8080'/>
-+ <http id='' host='*' port='%%PORT%%'/>
+- <http id="" host="*" port="8080"/>
++ <http id="" host="*" port="%%PORT%%"/>
<!--
- SSL port configuration:
diff --git a/www/resin3/pkg-descr b/www/resin3/pkg-descr
index 20d0cc9d42e9..015d3d5586de 100644
--- a/www/resin3/pkg-descr
+++ b/www/resin3/pkg-descr
@@ -6,4 +6,20 @@ includes a full-featured HTTP/1.1 web server, provides a fast servlet runner
for Apache, and supports the latest Servlet 2.3 and JSP 1.2 specifications from
Sun.
+o You may use Resin for development, evaluation, and demos.
+o You must contact us to purchase a deployment license if either:
+
+ * You are paid to use Resin.
+ * You are paying someone else to use Resin.
+
+o If no one is paid to use Resin, you may use Resin for deployment:
+
+ * students
+ * private use
+ * tiny startups with neither funding nor income.
+
+o Anyone falling in between should contact us for a waiver.
+o Distributors must contact us.
+o If you are allowed to use Resin, you may modify the source for that use.
+
WWW: http://www.caucho.com/
diff --git a/www/resin3/pkg-plist b/www/resin3/pkg-plist
index 534d201f5e4b..3a6062ca32c8 100644
--- a/www/resin3/pkg-plist
+++ b/www/resin3/pkg-plist
@@ -1,13 +1,4 @@
-%%APP_NAME%%/doc/beta.xtp
-%%APP_NAME%%/doc/changes-1.xtp
-%%APP_NAME%%/doc/changes.xtp
-%%APP_NAME%%/doc/errata.xtp
-%%APP_NAME%%/doc/features.xtp
-%%APP_NAME%%/doc/future.xtp
-%%APP_NAME%%/doc/index.xtp
-%%APP_NAME%%/doc/href-map.xml
-%%APP_NAME%%/doc/toc.xml
-%%APP_NAME%%/doc/images/caucho-blue.gif
+%%APP_NAME%%/doc/css/default.css
%%APP_NAME%%/doc/images/apache_srun.gif
%%APP_NAME%%/doc/images/appserver.gif
%%APP_NAME%%/doc/images/background.gif
@@ -15,6 +6,7 @@
%%APP_NAME%%/doc/images/ball8.gif
%%APP_NAME%%/doc/images/bean.gif
%%APP_NAME%%/doc/images/bean1.gif
+%%APP_NAME%%/doc/images/caucho-white.jpg
%%APP_NAME%%/doc/images/caucho.gif
%%APP_NAME%%/doc/images/compiler.gif
%%APP_NAME%%/doc/images/file.gif
@@ -24,6 +16,7 @@
%%APP_NAME%%/doc/images/iis_srun.gif
%%APP_NAME%%/doc/images/jndi_tree.gif
%%APP_NAME%%/doc/images/jsp.gif
+%%APP_NAME%%/doc/images/left_background.gif
%%APP_NAME%%/doc/images/logo.gif
%%APP_NAME%%/doc/images/pixel.gif
%%APP_NAME%%/doc/images/resin_powered.gif
@@ -34,33 +27,39 @@
%%APP_NAME%%/doc/images/style.gif
%%APP_NAME%%/doc/images/webserver.gif
%%APP_NAME%%/doc/images/website_srun.gif
-%%APP_NAME%%/doc/images/caucho.jpg
-%%APP_NAME%%/doc/images/.xvpics/background.gif
-%%APP_NAME%%/doc/images/.xvpics/left_background.gif
-%%APP_NAME%%/doc/images/caucho-white.jpg
-%%APP_NAME%%/doc/images/left_background.gif
-%%APP_NAME%%/lib/resin.jar
-%%APP_NAME%%/lib/jsdk24.jar
-%%APP_NAME%%/lib/jta_101.jar
+%%APP_NAME%%/doc/changes-1.xtp
+%%APP_NAME%%/doc/changes.xtp
+%%APP_NAME%%/doc/index.xtp
+%%APP_NAME%%/doc/toc.xml
+%%APP_NAME%%/lib/dom.jar
%%APP_NAME%%/lib/isorelax.jar
-%%APP_NAME%%/lib/jmx.jar
%%APP_NAME%%/lib/jca-15.jar
+%%APP_NAME%%/lib/jmx-12.jar
+%%APP_NAME%%/lib/jsdk-24.jar
%%APP_NAME%%/lib/jstl-11.jar
+%%APP_NAME%%/lib/jta-101.jar
+%%APP_NAME%%/lib/license.jar
+%%APP_NAME%%/lib/resin.jar
%%APP_NAME%%/lib/webutil.jar
+%%APP_NAME%%/webapps/resin-doc.war
%%APP_NAME%%/xsl/caucho/comment.xsl
%%APP_NAME%%/xsl/caucho/contents.xsl
%%APP_NAME%%/xsl/caucho/control.xsl
%%APP_NAME%%/xsl/caucho/debug.xsl
%%APP_NAME%%/xsl/caucho/defaultcopy.xsl
%%APP_NAME%%/xsl/caucho/format.xsl
-%%APP_NAME%%/xsl/caucho/newstyle.xsl
-%%APP_NAME%%/xsl/caucho/weblog.xsl
%%APP_NAME%%/xsl/caucho/fun.xsl
%%APP_NAME%%/xsl/caucho/href.xsl
%%APP_NAME%%/xsl/caucho/include.xsl
+%%APP_NAME%%/xsl/caucho/newstyle.xsl
%%APP_NAME%%/xsl/caucho/nodeinfo.xsl
%%APP_NAME%%/xsl/caucho/toc.xsl
%%APP_NAME%%/xsl/caucho/viewfile.xsl
+%%APP_NAME%%/xsl/caucho/weblog.xsl
+%%APP_NAME%%/xsl/js/caucho/defaultcopy.xsl
+%%APP_NAME%%/xsl/js/caucho/format.xsl
+%%APP_NAME%%/xsl/js/caucho/weblog.xsl
+%%APP_NAME%%/xsl/tools/indexer.xsl
%%APP_NAME%%/xsl/caucho_default.xsl
%%APP_NAME%%/xsl/caucho_header.xsl
%%APP_NAME%%/xsl/caucho_subpage.xsl
@@ -71,9 +70,6 @@
%%APP_NAME%%/xsl/new_doc_header.xsl
%%APP_NAME%%/xsl/search.xsl
%%APP_NAME%%/xsl/subpage.xsl
-%%APP_NAME%%/xsl/js/caucho/defaultcopy.xsl
-%%APP_NAME%%/xsl/js/caucho/format.xsl
-%%APP_NAME%%/xsl/js/caucho/weblog.xsl
%%APP_NAME%%/libexec/libresin.so
%%APP_NAME%%/libexec/libresinssl.so
etc/app-default.xml
@@ -82,13 +78,15 @@ sbin/%%APP_NAME%%ctl
%%MOD_DIR%%/mod_caucho.so
%%APACHE%%@exec %%APXS%% -e -a -n caucho %f
%%APACHE%%@unexec %%APXS%% -e -A -n caucho %f
-@dirrm %%APP_NAME%%/doc/images/.xvpics
+@dirrm %%APP_NAME%%/doc/css
@dirrm %%APP_NAME%%/doc/images
@dirrm %%APP_NAME%%/doc
@dirrm %%APP_NAME%%/lib
+@dirrm %%APP_NAME%%/webapps
@dirrm %%APP_NAME%%/xsl/caucho
@dirrm %%APP_NAME%%/xsl/js/caucho
@dirrm %%APP_NAME%%/xsl/js
+@dirrm %%APP_NAME%%/xsl/tools
@dirrm %%APP_NAME%%/xsl
@dirrm %%APP_NAME%%/libexec
@dirrm %%APP_NAME%%