aboutsummaryrefslogtreecommitdiff
path: root/www/resin3
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-12-20 22:38:35 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-12-20 22:38:35 +0000
commit91935e798f847720931a5f3b2f631db46a2d4d4f (patch)
treed3ac0dc43c4c191c20851eae84400557307e126b /www/resin3
parenta53cf1c8644d148b9606f617884a01b75d0fcf19 (diff)
downloadports-91935e798f847720931a5f3b2f631db46a2d4d4f.tar.gz
ports-91935e798f847720931a5f3b2f631db46a2d4d4f.zip
Notes
Diffstat (limited to 'www/resin3')
-rw-r--r--www/resin3/Makefile2
-rw-r--r--www/resin3/distinfo5
-rw-r--r--www/resin3/files/pkg-message.in35
-rw-r--r--www/resin3/files/resinctl11
-rw-r--r--www/resin3/pkg-plist3
5 files changed, 46 insertions, 10 deletions
diff --git a/www/resin3/Makefile b/www/resin3/Makefile
index 573ba9075fe4..ca004456d420 100644
--- a/www/resin3/Makefile
+++ b/www/resin3/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= resin
-PORTVERSION= 3.0.14
+PORTVERSION= 3.0.16
CATEGORIES= www java
MASTER_SITES= http://www.caucho.com/download/
diff --git a/www/resin3/distinfo b/www/resin3/distinfo
index 5fe13ad97f49..1539abe3e076 100644
--- a/www/resin3/distinfo
+++ b/www/resin3/distinfo
@@ -1,2 +1,3 @@
-MD5 (resin-3.0.14.tar.gz) = 1348ca83d945a8905238989ba0eb7d23
-SIZE (resin-3.0.14.tar.gz) = 6275586
+MD5 (resin-3.0.16.tar.gz) = 8f5a88fa14190bc768b083c17f864ea3
+SHA256 (resin-3.0.16.tar.gz) = 17326fc79ec941cd18b9c25d251aa595a9b9bcaa5ff653cb44b9f129c7b948a2
+SIZE (resin-3.0.16.tar.gz) = 7667120
diff --git a/www/resin3/files/pkg-message.in b/www/resin3/files/pkg-message.in
index ce12375aa0b6..e69547c04df7 100644
--- a/www/resin3/files/pkg-message.in
+++ b/www/resin3/files/pkg-message.in
@@ -8,7 +8,40 @@ Then start it:
env - %%PREFIX%%/etc/rc.d/%%APP_NAME%%.sh start
-And point your web browser to the default home page at
+For this control script to run seamlessly, it is recommended to increase the
+maximum length of commands displayed by ps(1). Please append the following
+setting to /etc/sysctl.conf:
+
+ # Do not truncate command line arguments in ps(1) listing
+ kern.ps_arg_cache_limit=10000
+
+This setting will take effect at next reboot, however it is possible to have
+immediate effect with the following command as root:
+
+ # sysctl kern.ps_arg_cache_limit=10000
+
+If you wish to skip this setting, please note that the `stop', `restart' and
+`status' will not function properly with %%APP_NAME%%.sh.
+
+Once Resin is started, point your web browser to the default home page at
http://localhost:%%PORT%%/ to read the documentation and test the samples.
Resin configuration is located at %%PREFIX%%/etc/%%APP_NAME%%/resin.xml
+
+
+Enjoy!
+
+--------------------------------------------------------------------------------
+ADVANCED USAGE
+
+If you need to pass special options to Java, please set the
+%%APP_NAME%%_flags option in /etc/rc.conf, see examples below:
+
+ # Prevent Java from opening an X11 display
+ %%APP_NAME%%_flags="-Djava.awt.headless=true"
+
+ # Increase memory limit of the Java virtual machine
+ %%APP_NAME%%_flags="-Xms32mĀ -Xmx256m"
+
+ # Run Java with remote debugging turned on
+ %%APP_NAME%%_flags="-Xdebug -Xnoagent -Xrunjdwp:transport=dt_socket,server=y,suspend=n"
diff --git a/www/resin3/files/resinctl b/www/resin3/files/resinctl
index 809ad9cf5321..a175b132abde 100644
--- a/www/resin3/files/resinctl
+++ b/www/resin3/files/resinctl
@@ -157,8 +157,7 @@ if __name__ == '__main__':
COMMAND = "%%JAVA%%"
ARGS = [COMMAND]
- if os.environ.has_key('JAVA_OPTS'):
- ARGS += os.environ['JAVA_OPTS'].split(" ")
+ ARGS += sys.argv[1:-1]
ARGS += [
"-Dresin.home=%%APP_HOME%%",
@@ -170,17 +169,17 @@ if __name__ == '__main__':
os.environ['JAVA_HOME'] = "%%JAVA_HOME%%"
os.environ['CLASSPATH'] = classpath()
- if len(sys.argv) != 2:
+ if len(sys.argv) < 2:
usage()
sys.exit(1)
- if sys.argv[1] == "start":
+ if sys.argv[-1] == "start":
start()
- elif sys.argv[1] == "stop":
+ elif sys.argv[-1] == "stop":
stop()
- elif sys.argv[1] == "restart":
+ elif sys.argv[-1] == "restart":
stop()
start()
diff --git a/www/resin3/pkg-plist b/www/resin3/pkg-plist
index e9f0b8dbf4a4..59927bd05b11 100644
--- a/www/resin3/pkg-plist
+++ b/www/resin3/pkg-plist
@@ -1,5 +1,7 @@
@comment $FreeBSD$
%%APP_NAME%%/lib/aopalliance.jar
+%%APP_NAME%%/lib/default.xsl
+%%APP_NAME%%/lib/eclipse-compiler.jar
%%APP_NAME%%/lib/ejb-20.jar
%%APP_NAME%%/lib/ejb-30.jar
%%APP_NAME%%/lib/j2eedeploy.jar
@@ -10,6 +12,7 @@
%%APP_NAME%%/lib/jstl-11.jar
%%APP_NAME%%/lib/jta-101.jar
%%APP_NAME%%/lib/portlet-10.jar
+%%APP_NAME%%/lib/quercus.jar
%%APP_NAME%%/lib/resin-jdk15.jar
%%APP_NAME%%/lib/resin.jar
%%APP_NAME%%/lib/resinboot.jar