aboutsummaryrefslogtreecommitdiff
path: root/www/resin3
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2005-04-20 14:47:35 +0000
committerHerve Quiroz <hq@FreeBSD.org>2005-04-20 14:47:35 +0000
commitd4301ac6c08ad2d8cfd24b68d50d0a4975952216 (patch)
tree17b4bda28b3f9036e75e84261007a5d37d92b771 /www/resin3
parent5c73dc255bb971212e9a9f8443407b9618d84699 (diff)
downloadports-d4301ac6c08ad2d8cfd24b68d50d0a4975952216.tar.gz
ports-d4301ac6c08ad2d8cfd24b68d50d0a4975952216.zip
Notes
Diffstat (limited to 'www/resin3')
-rw-r--r--www/resin3/Makefile29
-rw-r--r--www/resin3/files/resinctl5
-rw-r--r--www/resin3/pkg-descr16
3 files changed, 14 insertions, 36 deletions
diff --git a/www/resin3/Makefile b/www/resin3/Makefile
index 0b18a9dc7a20..31f1e4470218 100644
--- a/www/resin3/Makefile
+++ b/www/resin3/Makefile
@@ -13,8 +13,6 @@ MASTER_SITES= http://www.caucho.com/download/
MAINTAINER= jb.quenot@caraldi.com
COMMENT= Resin, a Java-based Application Server, 3.x branch
-BROKEN= Does not build
-
USE_JAVA= yes
JAVA_VERSION= 1.2+
HAS_CONFIGURE= yes
@@ -43,8 +41,6 @@ APXS?= ${LOCALBASE}/sbin/apxs
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
PKGMESSAGE= ${WRKDIR}/pkg-message
-# We need WRKSRC and WRKDIR right now so define them "manually"
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
REINPLACE_FILES= ${WRKSRC}/src/c/apache1/Makefile.in \
${WRKSRC}/src/c/apache2/Makefile.in
REPLACE_FILES= ${FILESDIR}/pkg-install \
@@ -110,12 +106,10 @@ SUBSTITUTIONS= -e "s|%%APP_HOME%%|${APP_HOME}|g" \
-e "s|%%WRKSRC%%|${WRKSRC}|g"
post-patch:
-.for FILE in ${REINPLACE_FILES}
- @${REINPLACE_CMD} ${SUBSTITUTIONS} ${FILE}
-.endfor
-.for FILE in ${REPLACE_FILES}
- @${SED} ${SUBSTITUTIONS} ${FILE} > ${WRKDIR}/`basename ${FILE}`
-.endfor
+ @${REINPLACE_CMD} ${SUBSTITUTIONS} ${REINPLACE_FILES}
+ @for FILE in ${REPLACE_FILES} ; do \
+ ${SED} ${SUBSTITUTIONS} $${FILE} > ${WRKDIR}/`basename $${FILE}` ; \
+ done
@${FMT} -w 80 < ${WRKDIR}/pkg-message.in > ${PKGMESSAGE}
.if (defined(WITH_APACHE2) && (${WITH_APACHE2} == yes || ${WITH_APACHE2} == YES) || \
defined(WITH_APACHE) && (${WITH_APACHE} == yes || ${WITH_APACHE} == YES))
@@ -126,23 +120,18 @@ defined(WITH_APACHE) && (${WITH_APACHE} == yes || ${WITH_APACHE} == YES))
server, for example: | ${FMT} -w 80 >> ${PKGMESSAGE}
@${ECHO_CMD} >> ${PKGMESSAGE}
@${ECHO_CMD} "<IfModule mod_caucho.c>" >> ${PKGMESSAGE}
-.if (defined(WITH_APACHE2) && (${WITH_APACHE2} == yes || ${WITH_APACHE2} == YES))
@${ECHO_CMD} " ResinConfigServer localhost 6802" >> ${PKGMESSAGE}
-.endif
-.if (defined(WITH_APACHE) && (${WITH_APACHE} == yes || ${WITH_APACHE} == YES))
- @${ECHO_CMD} " CauchoConfigFile ${PREFIX}/etc/${APP_NAME}/resin.xml" >> ${PKGMESSAGE}
-.endif
- @${ECHO_CMD} "</IfModule>" >> ${PKGMESSAGE}
+ @${ECHO_CMD} "</IfModule>" >> ${PKGMESSAGE}
.endif
# Resin does not handle installation, so proceed now
post-install:
@${SETENV} RUNASUSER=${RUNASUSER} GROUP=${GROUP} ${SH} ${WRKDIR}/install.sh
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- @${ECHO_CMD}
- @${ECHO_CMD} "********************************************************************************"
+ @${ECHO_MSG}
+ @${ECHO_MSG} "********************************************************************************"
@${CAT} ${PKGMESSAGE}
- @${ECHO_CMD} "********************************************************************************"
- @${ECHO_CMD}
+ @${ECHO_MSG} "********************************************************************************"
+ @${ECHO_MSG}
.include <bsd.port.post.mk>
diff --git a/www/resin3/files/resinctl b/www/resin3/files/resinctl
index 764032cc9e93..809ad9cf5321 100644
--- a/www/resin3/files/resinctl
+++ b/www/resin3/files/resinctl
@@ -105,10 +105,10 @@ def start():
# Wait a little
time.sleep(.4)
- (unused_pid, status) = os.waitpid(pid, os.WNOHANG)
+ (status_pid, status) = os.waitpid(pid, os.WNOHANG)
# Check program exit status, if available
- if unused_pid != 0 and os.WIFEXITED(status):
+ if status_pid != 0 and os.WIFEXITED(status):
sys.stderr = os.fdopen(orig_stderr, 'w')
print >> sys.stderr, 'Could not start %s. Check %s for errors.' % (APP_NAME, LOG_FILE)
sys.exit(2)
@@ -153,7 +153,6 @@ if __name__ == '__main__':
LOG_FILE = "%%LOG_FILE%%"
APP_NAME = "%%APP_NAME%%"
APP_HOME = "%%APP_HOME%%"
- CONTROL_PROGRAM = "%%APP_NAME%%ctl"
PID_FILE = "%%PID_FILE%%"
COMMAND = "%%JAVA%%"
ARGS = [COMMAND]
diff --git a/www/resin3/pkg-descr b/www/resin3/pkg-descr
index 2cb2a45e22cd..d41e10551cd7 100644
--- a/www/resin3/pkg-descr
+++ b/www/resin3/pkg-descr
@@ -6,18 +6,8 @@ includes a full-featured HTTP/1.1 web server, provides a fast servlet runner
for Apache, and supports the latest Servlet 2.3 and JSP 1.2 specifications from
Sun.
-o You may use Resin for development, evaluation, and demos.
-o You must contact us to purchase a deployment license if either:
- * You are paid to use Resin.
- * You are paying someone else to use Resin.
-
-o If no one is paid to use Resin, you may use Resin for deployment:
- * students
- * private use
- * tiny startups with neither funding nor income.
-
-o Anyone falling in between should contact us for a waiver.
-o Distributors must contact us.
-o If you are allowed to use Resin, you may modify the source for that use.
+Resin 3.0 Open Source is available under the GNU Public License (GPL). It
+contains all functional components of Resin, including EJB, but excludes
+performance and clustering capabilities.
WWW: http://www.caucho.com/