aboutsummaryrefslogtreecommitdiff
path: root/www/rnews
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-27 13:50:26 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-27 13:50:26 +0000
commit9c4eb7ed5888e5745ef0d86caa0ee0442f3318a4 (patch)
tree21a1b953e709bb6de188e8dfa19dd670506a7a27 /www/rnews
parentfe7dcde478f115cf014860bef0b944c7ece422c3 (diff)
downloadports-9c4eb7ed5888e5745ef0d86caa0ee0442f3318a4.tar.gz
ports-9c4eb7ed5888e5745ef0d86caa0ee0442f3318a4.zip
Notes
Diffstat (limited to 'www/rnews')
-rw-r--r--www/rnews/Makefile64
-rw-r--r--www/rnews/distinfo1
-rw-r--r--www/rnews/pkg-descr3
-rw-r--r--www/rnews/pkg-message17
-rw-r--r--www/rnews/pkg-plist46
5 files changed, 131 insertions, 0 deletions
diff --git a/www/rnews/Makefile b/www/rnews/Makefile
new file mode 100644
index 000000000000..633f14c89358
--- /dev/null
+++ b/www/rnews/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: rnews
+# Date created: 22 December 2003
+# Whom: Vincent Tantardini <vinc@FreeBSD-fr.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rnews
+PORTVERSION= 0.63
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= vinc@FreeBSD-fr.org
+COMMENT= A server-side rss aggregator written in php with mysql
+
+.if defined(WITH_PHP3)
+RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp3.so:${PORTSDIR}/www/mod_php3
+.else
+RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
+.endif
+
+USE_MYSQL= yes
+
+NO_BUILD= yes
+MYPORTDOCS= CHANGELOG INSTALL LICENSE README magpierss/AUTHORS \
+ magpierss/CHANGES magpierss/ChangeLog magpierss/INSTALL \
+ magpierss/NEWS magpierss/README magpierss/TROUBLESHOOTING
+
+pre-everything::
+.if !defined(WITH_PHP3)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Press CTRL-C and define WITH_PHP3 if you want"
+ @${ECHO_MSG} "to use RNEWS with PHP3. PHP4 is used by default."
+ @${ECHO_MSG} ""
+.endif
+
+post-patch:
+ @${FIND} ${WRKSRC} -name CVS -type d | ${XARGS} ${RM} -fr
+
+do-install:
+ @${MKDIR} ${PREFIX}/www/rnews
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}/magpierss
+. for FILE in ${MYPORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}/${FILE}
+. endfor
+.endif
+ ${MKDIR} ${PREFIX}/www/rnews
+ ${MKDIR} ${PREFIX}/www/rnews/magpierss-0.5.2
+ cd ${PREFIX}/www/rnews && ${LN} -s magpierss-0.5.2 magpierss
+ ${MKDIR} ${PREFIX}/www/rnews/magpierss/cache
+ ${INSTALL_DATA} -v ${WRKSRC}/*.png ${PREFIX}/www/rnews
+ ${INSTALL_DATA} -v ${WRKSRC}/*.php ${PREFIX}/www/rnews
+ ${INSTALL_DATA} -v ${WRKSRC}/*.inc ${PREFIX}/www/rnews
+ ${INSTALL_DATA} -v ${WRKSRC}/magpierss/*.inc ${PREFIX}/www/rnews/magpierss
+ ${INSTALL_DATA} -v ${WRKSRC}/magpierss/cookbook ${PREFIX}/www/rnews/magpierss
+ ${CP} -Rv ${WRKSRC}/magpierss/extlib ${PREFIX}/www/rnews/magpierss
+ ${CP} -Rv ${WRKSRC}/magpierss/htdocs ${PREFIX}/www/rnews/magpierss
+ ${CP} -Rv ${WRKSRC}/magpierss/scripts ${PREFIX}/www/rnews/magpierss
+ @${CHOWN} ${WWWOWN}:${WWWGRP} ${PREFIX}/www/rnews/magpierss/cache
+ @${SED} "s,%%PREFIX%%,${PREFIX},g" ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/rnews/distinfo b/www/rnews/distinfo
new file mode 100644
index 000000000000..2a04e7a94920
--- /dev/null
+++ b/www/rnews/distinfo
@@ -0,0 +1 @@
+MD5 (rnews-0.63.tar.gz) = caf0bf807f7abc79b7ceb04b1e8c5d90
diff --git a/www/rnews/pkg-descr b/www/rnews/pkg-descr
new file mode 100644
index 000000000000..f395eb387e17
--- /dev/null
+++ b/www/rnews/pkg-descr
@@ -0,0 +1,3 @@
+Rnews is a server-side rss aggregator written in php with mysql.
+
+WWW: http://rnews.sourceforge.net/
diff --git a/www/rnews/pkg-message b/www/rnews/pkg-message
new file mode 100644
index 000000000000..8b96ebd626df
--- /dev/null
+++ b/www/rnews/pkg-message
@@ -0,0 +1,17 @@
+===============================================================
+Rnews is now installed. You may have to follow this steps to
+make it work correctly.
+
+1: edit rnews_config.php to suit your site's configuration
+2: create a database with the name you gave in rnews_config.inc
+ $ mysql -u root
+ mysql> CREATE DATABASE rnews_db;
+ mysql> quit
+3: go to http://your.site/some/dir/rnews/
+ by default, the DocumentRoot variable of your httpd.conf
+ must be "%%PREFIX%%/www/"
+
+If the configuration was done correctly, and php is able to
+connect to the mysql server, you should be able to create a new
+account and start adding rss sources!
+===============================================================
diff --git a/www/rnews/pkg-plist b/www/rnews/pkg-plist
new file mode 100644
index 000000000000..eb6f2f63b623
--- /dev/null
+++ b/www/rnews/pkg-plist
@@ -0,0 +1,46 @@
+%%DOCSDIR%%/CHANGELOG
+%%DOCSDIR%%/INSTALL
+%%DOCSDIR%%/LICENSE
+%%DOCSDIR%%/README
+%%DOCSDIR%%/magpierss/AUTHORS
+%%DOCSDIR%%/magpierss/CHANGES
+%%DOCSDIR%%/magpierss/ChangeLog
+%%DOCSDIR%%/magpierss/INSTALL
+%%DOCSDIR%%/magpierss/NEWS
+%%DOCSDIR%%/magpierss/README
+%%DOCSDIR%%/magpierss/TROUBLESHOOTING
+www/rnews/auth.php
+www/rnews/default_icon.png
+www/rnews/foot.php
+www/rnews/functions.inc
+www/rnews/head.php
+www/rnews/index.php
+www/rnews/magpierss
+www/rnews/magpierss-0.5.2/cookbook
+www/rnews/magpierss-0.5.2/extlib/Snoopy.class.inc
+www/rnews/magpierss-0.5.2/htdocs/cookbook.html
+www/rnews/magpierss-0.5.2/htdocs/index.html
+www/rnews/magpierss-0.5.2/rss_cache.inc
+www/rnews/magpierss-0.5.2/rss_fetch.inc
+www/rnews/magpierss-0.5.2/rss_parse.inc
+www/rnews/magpierss-0.5.2/rss_utils.inc
+www/rnews/magpierss-0.5.2/scripts/README
+www/rnews/magpierss-0.5.2/scripts/magpie_debug.php
+www/rnews/magpierss-0.5.2/scripts/magpie_simple.php
+www/rnews/magpierss-0.5.2/scripts/magpie_slashbox.php
+www/rnews/magpierss-0.5.2/scripts/simple_smarty.php
+www/rnews/magpierss-0.5.2/scripts/smarty_plugin/modifier.rss_date_parse.php
+www/rnews/magpierss-0.5.2/scripts/templates/simple.smarty
+www/rnews/prefs.php
+www/rnews/redirect.php
+www/rnews/rnews_config.php
+@dirrm www/rnews/magpierss-0.5.2/scripts/templates
+@dirrm www/rnews/magpierss-0.5.2/scripts/smarty_plugin
+@dirrm www/rnews/magpierss-0.5.2/scripts
+@dirrm www/rnews/magpierss-0.5.2/htdocs
+@dirrm www/rnews/magpierss-0.5.2/extlib
+@dirrm www/rnews/magpierss-0.5.2/cache
+@dirrm www/rnews/magpierss-0.5.2
+@dirrm www/rnews
+@dirrm %%DOCSDIR%%/magpierss
+@dirrm %%DOCSDIR%%