aboutsummaryrefslogtreecommitdiff
path: root/www/rsstool
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-06-11 18:58:44 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-06-11 18:58:44 +0000
commit49d95ca89297e144a5c920965eae369a193f0415 (patch)
tree881660ce648554aac427ab2b9156c01364afc342 /www/rsstool
parent4b98590421a8451a27e6c5d9b8430592f9a938ba (diff)
downloadports-49d95ca89297e144a5c920965eae369a193f0415.tar.gz
ports-49d95ca89297e144a5c920965eae369a193f0415.zip
Notes
Diffstat (limited to 'www/rsstool')
-rw-r--r--www/rsstool/Makefile30
-rw-r--r--www/rsstool/distinfo3
-rw-r--r--www/rsstool/pkg-descr8
3 files changed, 41 insertions, 0 deletions
diff --git a/www/rsstool/Makefile b/www/rsstool/Makefile
new file mode 100644
index 000000000000..0a61b1593b4d
--- /dev/null
+++ b/www/rsstool/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: rsstool
+# Date created: 11 June 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rsstool
+DISTVERSION= 1.0.0rc1
+DISTVERSIONSUFFIX= -src
+CATEGORIES= www
+MASTER_SITES= BERLIOS CENKES
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Read, parse, merge and write RSS and Atom feeds
+
+USE_ICONV= yes
+USE_GNOME= libxml2
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+HAS_CONFIGURE= yes
+PLIST_FILES= bin/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^CC=/d;/^CFLAGS=/s|-O3||;/^CFLAGS=/s|=|+=|' ${WRKSRC}/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/www/rsstool/distinfo b/www/rsstool/distinfo
new file mode 100644
index 000000000000..dc49238b4a7c
--- /dev/null
+++ b/www/rsstool/distinfo
@@ -0,0 +1,3 @@
+MD5 (rsstool-1.0.0rc1-src.tar.gz) = 703a2edde3e6ec0fad635d1703feb55c
+SHA256 (rsstool-1.0.0rc1-src.tar.gz) = 0acd077479568c3d0517ca78538fca8a0840a70063270cff90f06f973b2d4274
+SIZE (rsstool-1.0.0rc1-src.tar.gz) = 111610
diff --git a/www/rsstool/pkg-descr b/www/rsstool/pkg-descr
new file mode 100644
index 000000000000..b36f9ce8077b
--- /dev/null
+++ b/www/rsstool/pkg-descr
@@ -0,0 +1,8 @@
+rsstool is a tool to read, parse, merge, and write RSS (and Atom)
+feeds. It has some other functions built-in like text, HTML, or
+property file output, or templates with custom tags to insert RSS
+feeds into pages that could be uploaded to a server that supports
+only static HTML.
+
+WWW: http://rsstool.y7.ath.cx/
+Author: Dirk <noisyb at users.berlios.de>