aboutsummaryrefslogtreecommitdiff
path: root/www/rt32
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2003-11-10 14:11:01 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2003-11-10 14:11:01 +0000
commit3a88783192ab7a9cbe975137748313f2a85bacbd (patch)
tree43bcff4f9042ecc4db1a84daf0c1020787b2d4da /www/rt32
parent4fa2e87af8fdbea79906ffd12a57f0f759a90d66 (diff)
downloadports-3a88783192ab7a9cbe975137748313f2a85bacbd.tar.gz
ports-3a88783192ab7a9cbe975137748313f2a85bacbd.zip
Notes
Diffstat (limited to 'www/rt32')
-rw-r--r--www/rt32/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/www/rt32/Makefile b/www/rt32/Makefile
index d3ca06a87436..7fbfd5d2671f 100644
--- a/www/rt32/Makefile
+++ b/www/rt32/Makefile
@@ -89,13 +89,19 @@ BUILD_DEPENDS+= ${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl
DB_TYPE?= mysql
+.if ${DB_TYPE} == "Oracle"
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Oracle.pm:${PORTSDIR}/databases/p5-DBD-Oracle
+.else
.if ${DB_TYPE} == "Pg"
-BUILD_DEPENDS+= ${LOCALBASE}/bin/psql:${PORTSDIR}/databases/postgresql7 \
- ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+.else
+.if ${DB_TYPE} == "SQLite"
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite
.else
DB_TYPE= mysql
-BUILD_DEPENDS+= ${LOCALBASE}/bin/mysql_config:${PORTSDIR}/databases/mysql40-server \
- ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+.endif
+.endif
.endif
USE_PERL5= yes
@@ -114,7 +120,7 @@ pre-fetch:
@${ECHO} ""
@${ECHO} "You may use the following build options:"
@${ECHO} ""
- @${ECHO} " DB_TYPE=type Pg for postgresql, mysql for MySQL (mysql)"
+ @${ECHO} " DB_TYPE=type mysql, Oracle, Pg or SQLite (mysql)"
@${ECHO} " DB_HOST=hostname The database host (localhost)"
@${ECHO} " DB_PORT=port The database port"
@${ECHO} " DB_DBA_USER=password Name of database administrator (root)"