aboutsummaryrefslogtreecommitdiff
path: root/www/rt36
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2006-12-22 17:07:38 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2006-12-22 17:07:38 +0000
commitc9e35e5fb9e44b3a107b9836a272d259ec3e3a77 (patch)
treea3c450c35b0868c5bbb663f8954f49377348dd55 /www/rt36
parent26cbccf95515600ad4b611a258d22a36b5c51733 (diff)
downloadports-c9e35e5fb9e44b3a107b9836a272d259ec3e3a77.tar.gz
ports-c9e35e5fb9e44b3a107b9836a272d259ec3e3a77.zip
Notes
Diffstat (limited to 'www/rt36')
-rw-r--r--www/rt36/Makefile13
-rw-r--r--www/rt36/distinfo12
-rw-r--r--www/rt36/files/patch-Makefile_in25
-rw-r--r--www/rt36/pkg-message3
-rw-r--r--www/rt36/pkg-plist11
5 files changed, 44 insertions, 20 deletions
diff --git a/www/rt36/Makefile b/www/rt36/Makefile
index df645fcd396d..2fad53fe8f08 100644
--- a/www/rt36/Makefile
+++ b/www/rt36/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= rt
-PORTVERSION?= 3.6.1
-PORTREVISION= 1
+PORTVERSION?= 3.6.3
+PORTREVISION= 0
CATEGORIES= www
MASTER_SITES?= http://download.bestpractical.com/pub/rt/release/ \
http://download.bestpractical.com/pub/rt/devel/ \
@@ -19,7 +19,7 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= vivek@khera.org
COMMENT?= RT is an industrial-grade ticketing system written in Perl
-BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT} \
+PERL_MODULES = ${APXS}:${PORTSDIR}/${APACHE_PORT} \
${SITE_PERL}/Apache/Mason.pm:${PORTSDIR}/www/p5-HTML-Mason \
${SITE_PERL}/Apache/Session.pm:${PORTSDIR}/www/p5-Apache-Session \
${SITE_PERL}/CGI/Cookie.pm:${PORTSDIR}/www/p5-CGI.pm \
@@ -59,9 +59,11 @@ BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT} \
${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph \
${SITE_PERL}/GD/Text.pm:${PORTSDIR}/graphics/p5-GD-TextUtil \
${SITE_PERL}/Calendar/Simple.pm:${PORTSDIR}/devel/p5-Calendar-Simple \
+ ${SITE_PERL}/Date/Format.pm:${PORTSDIR}/devel/p5-TimeDate \
${SITE_PERL}/UNIVERSAL/require.pm:${PORTSDIR}/devel/p5-UNIVERSAL-require
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS+= ${PERL_MODULES}
+RUN_DEPENDS+= ${PERL_MODULES}
LATEST_LINK= rt36
HAS_CONFIGURE= yes
@@ -146,11 +148,10 @@ UPGRADES= 3.1.0 3.1.15 3.1.17
.if defined(UPGRADE_RT30) || defined(UPGRADE_RT32)
UPGRADES+= 3.3.0 3.3.11
.endif
-.if defined(UPGRADE_RT34)
+.if defined(UPGRADE_RT30) || defined(UPGRADE_RT32) || defined(UPGRADE_RT34)
UPGRADES+= 3.5.1
.endif
-
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500803
diff --git a/www/rt36/distinfo b/www/rt36/distinfo
index 51a5412e7295..0c4bef34f539 100644
--- a/www/rt36/distinfo
+++ b/www/rt36/distinfo
@@ -1,6 +1,6 @@
-MD5 (rt-3.6.1.tar.gz) = 40c5a828fadaeef9e150255a517d0b17
-SHA256 (rt-3.6.1.tar.gz) = 0925018dc29d2fa1a6d91480c0ea4d1a517ddfd4e3094db3525a30fb2a04b467
-SIZE (rt-3.6.1.tar.gz) = 1545708
-MD5 (rt-3.6.1.tar.gz.sig) = 07e4eaa15a4b814ac95c923e12e297dd
-SHA256 (rt-3.6.1.tar.gz.sig) = 1542ffc9d86d5d446db4462a0d5a253ccb1b42a502cf535a307bb1b2ee8ef2df
-SIZE (rt-3.6.1.tar.gz.sig) = 65
+MD5 (rt-3.6.3.tar.gz) = d6b2fa930441f16b6530aa00665eb8c7
+SHA256 (rt-3.6.3.tar.gz) = fc29f1fd95b3cd4813e3fbdef1882e8cd6c4516c66b3e78237272bdd200a1a67
+SIZE (rt-3.6.3.tar.gz) = 1602818
+MD5 (rt-3.6.3.tar.gz.sig) = 63bc8bd88d3edf384c6d42558ae79b87
+SHA256 (rt-3.6.3.tar.gz.sig) = a30b40b7e4939b7eee9503144a062d97a019da5cd8730c90e5e4b7711c009bf1
+SIZE (rt-3.6.3.tar.gz.sig) = 64
diff --git a/www/rt36/files/patch-Makefile_in b/www/rt36/files/patch-Makefile_in
index a689b003e405..70b5b72f0237 100644
--- a/www/rt36/files/patch-Makefile_in
+++ b/www/rt36/files/patch-Makefile_in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Fri Apr 1 11:18:10 2005
-+++ Makefile.in Wed May 4 17:00:58 2005
+--- Makefile.in.orig Mon Jun 19 18:44:04 2006
++++ Makefile.in Tue Dec 19 15:42:41 2006
@@ -224,9 +224,6 @@
@echo "very dangerous. Note that you do not have to manually add a "
@echo "database user or set up a database for RT. These actions will be "
@@ -10,16 +10,29 @@
# @echo " or by executing "
# @echo " '$(RT_SBIN_PATH)/rt-setup-database --action init \ "
-@@ -284,7 +281,7 @@
+@@ -276,15 +273,18 @@
+ chmod $(RT_READABLE_DIR_MODE) $(DESTDIR)/$(RT_BIN_PATH)
+
+ chmod 0755 $(DESTDIR)/$(RT_ETC_PATH)
+- chmod 0500 $(DESTDIR)/$(RT_ETC_PATH)/*
++ chmod 0400 $(DESTDIR)/$(RT_ETC_PATH)/*
+
+ #TODO: the config file should probably be able to have its
+ # owner set separately from the binaries.
+ chown -R $(BIN_OWNER) $(DESTDIR)/$(RT_ETC_PATH)
chgrp -R $(RTGROUP) $(DESTDIR)/$(RT_ETC_PATH)
- chmod 0550 $(DESTDIR)/$(CONFIG_FILE)
+- chmod 0550 $(DESTDIR)/$(CONFIG_FILE)
- chmod 0550 $(DESTDIR)/$(SITE_CONFIG_FILE)
-+ chmod 0550 $(DESTDIR)/$(SITE_CONFIG_FILE)-dist
++ chmod 0440 $(DESTDIR)/$(CONFIG_FILE)
++ chmod 0440 $(DESTDIR)/$(SITE_CONFIG_FILE)-dist
++ -chmod 0640 $(DESTDIR)/$(SITE_CONFIG_FILE)
++ chgrp $(WEB_GROUP) $(DESTDIR)/$(CONFIG_FILE)
++ -chgrp $(WEB_GROUP) $(DESTDIR)/$(SITE_CONFIG_FILE)
# Make the interfaces executable
chown $(BIN_OWNER) $(BINARIES)
-@@ -331,13 +328,13 @@
+@@ -331,13 +331,13 @@
config-install:
mkdir -p $(DESTDIR)/$(CONFIG_FILE_PATH)
-cp etc/RT_Config.pm $(DESTDIR)/$(CONFIG_FILE)
diff --git a/www/rt36/pkg-message b/www/rt36/pkg-message
index 414f02c0b294..842b2210eb2a 100644
--- a/www/rt36/pkg-message
+++ b/www/rt36/pkg-message
@@ -9,6 +9,7 @@ To complete the installation of this port, please follow these steps:
3. Restart Apache.
4. Do remember to *CHANGE* the root's password for the web interface.
The default is "password" (without the quotes.)
-5. Configure RT per the instructions at http://www.fsck.com/rtfm/.
+5. Configure RT per the instructions at
+ http://www.bestpractical.com/rt/docs.html
=====================================================================
diff --git a/www/rt36/pkg-plist b/www/rt36/pkg-plist
index 7b38b56488a2..bd97a4edc7a4 100644
--- a/www/rt36/pkg-plist
+++ b/www/rt36/pkg-plist
@@ -197,6 +197,7 @@
%%RTPLIST%%/lib/t/data/8859-15-message-series/msg6
%%RTPLIST%%/lib/t/data/8859-15-message-series/msg7
%%RTPLIST%%/lib/t/data/crashes-file-based-parser
+%%RTPLIST%%/lib/t/data/lorem-ipsum
%%RTPLIST%%/lib/t/data/multipart-alternative-with-umlaut
%%RTPLIST%%/lib/t/data/multipart-report
%%RTPLIST%%/lib/t/data/nested-mime-sample
@@ -206,14 +207,18 @@
%%RTPLIST%%/lib/t/data/notes-uuencoded
%%RTPLIST%%/lib/t/data/rt-send-cc
%%RTPLIST%%/lib/t/data/russian-subject-no-content-type
+%%RTPLIST%%/lib/t/data/subject-with-folding-ws
%%RTPLIST%%/lib/t/data/text-html-in-russian
%%RTPLIST%%/lib/t/data/text-html-with-umlaut
+%%RTPLIST%%/lib/t/data/very-long-subject
+%%RTPLIST%%/lib/t/regression/00-mason-syntax.t
%%RTPLIST%%/lib/t/regression/01ticket_link_searching.t
%%RTPLIST%%/lib/t/regression/02basic_web.t
%%RTPLIST%%/lib/t/regression/03web_compiliation_errors.t
%%RTPLIST%%/lib/t/regression/04send_email.t
%%RTPLIST%%/lib/t/regression/05cronsupport.t
%%RTPLIST%%/lib/t/regression/06mailgateway.t
+%%RTPLIST%%/lib/t/regression/06-mime_decoding.t
%%RTPLIST%%/lib/t/regression/07acl.t
%%RTPLIST%%/lib/t/regression/07rights.t
%%RTPLIST%%/lib/t/regression/08web_cf_access.t
@@ -259,6 +264,7 @@
%%RTPLIST%%/share/html/Admin/CustomFields/index.html
%%RTPLIST%%/share/html/Admin/Elements/AddCustomFieldValue
%%RTPLIST%%/share/html/Admin/Elements/CreateUserCalled
+%%RTPLIST%%/share/html/Admin/Elements/ConfigureMyRT
%%RTPLIST%%/share/html/Admin/Elements/CustomFieldTabs
%%RTPLIST%%/share/html/Admin/Elements/EditCustomField
%%RTPLIST%%/share/html/Admin/Elements/EditCustomFieldValues
@@ -304,6 +310,7 @@
%%RTPLIST%%/share/html/Admin/Global/CustomFields/Users.html
%%RTPLIST%%/share/html/Admin/Global/CustomFields/index.html
%%RTPLIST%%/share/html/Admin/Global/GroupRights.html
+%%RTPLIST%%/share/html/Admin/Global/MyRT.html
%%RTPLIST%%/share/html/Admin/Global/Scrip.html
%%RTPLIST%%/share/html/Admin/Global/Scrips.html
%%RTPLIST%%/share/html/Admin/Global/Template.html
@@ -334,6 +341,7 @@
%%RTPLIST%%/share/html/Admin/Users/History.html
%%RTPLIST%%/share/html/Admin/Users/Memberships.html
%%RTPLIST%%/share/html/Admin/Users/Modify.html
+%%RTPLIST%%/share/html/Admin/Users/MyRT.html
%%RTPLIST%%/share/html/Admin/Users/index.html
%%RTPLIST%%/share/html/Admin/autohandler
%%RTPLIST%%/share/html/Admin/index.html
@@ -617,6 +625,7 @@
%%RTPLIST%%/share/html/User/Groups/index.html
%%RTPLIST%%/share/html/User/Prefs.html
%%RTPLIST%%/share/html/Widgets/ComboBox
+%%RTPLIST%%/share/html/Widgets/SavedSearch
%%RTPLIST%%/share/html/Widgets/SelectionBox
%%RTPLIST%%/share/html/Widgets/TitleBox
%%RTPLIST%%/share/html/Widgets/TitleBoxEnd
@@ -707,6 +716,6 @@
@dirrm %%RTPLIST%%/lib/RT/Action
@dirrm %%RTPLIST%%/lib/RT
@dirrm %%RTPLIST%%/lib
-@unexec rmdir %%RT_PATH%%/etc 2> /dev/null || true
+@dirrmtry %%RTPLIST%%/etc
@dirrm %%RTPLIST%%/bin
@dirrm %%RTPLIST%%