aboutsummaryrefslogtreecommitdiff
path: root/www/rt40
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2013-07-25 21:33:36 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2013-07-25 21:33:36 +0000
commit46854fdc26c41a621882cb734c9b20f8f43705a4 (patch)
tree8370faad0a00d21b8977b5ab01f885142711258b /www/rt40
parentfdebe69aed186c4696a6b388738280326bfde90d (diff)
downloadports-46854fdc26c41a621882cb734c9b20f8f43705a4.tar.gz
ports-46854fdc26c41a621882cb734c9b20f8f43705a4.zip
Notes
Diffstat (limited to 'www/rt40')
-rw-r--r--www/rt40/Makefile10
-rw-r--r--www/rt40/Makefile.cpan12
-rw-r--r--www/rt40/distinfo4
-rw-r--r--www/rt40/pkg-plist1
4 files changed, 17 insertions, 10 deletions
diff --git a/www/rt40/Makefile b/www/rt40/Makefile
index 87f87796f28b..9f00a26df132 100644
--- a/www/rt40/Makefile
+++ b/www/rt40/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= rt
-PORTVERSION= 4.0.13
-PORTREVISION= 2
+PORTVERSION= 4.0.14
CATEGORIES= www
MASTER_SITES= http://download.bestpractical.com/pub/rt/release/ \
SF/requesttracker/
@@ -62,7 +61,8 @@ BUILD_DEPENDS+= ${CORE_DEPS} \
${ICAL_DEPS} \
${SMTP_DEPS} \
${DASHBOARDS_DEPS} \
- ${USERLOGO_DEPS}
+ ${USERLOGO_DEPS} \
+ ${HTML_DOC_DEPS}
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -78,6 +78,7 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-noportdocs-Makefile.in
.if ${PORT_OPTIONS:MAP_MODPERL}
BUILD_DEPENDS+= ${MODPERL2_DEPS}
RUN_DEPENDS+= ${MODPERL2_DEPS}
+CONFIGURE_ARGS+= --with-apachectl=${LOCALBASE}/sbin/apachectl
.endif
.if ${PORT_OPTIONS:MAP_MODFASTCGI}
@@ -85,6 +86,7 @@ USE_APACHE_RUN= 22+
BUILD_DEPENDS+= ${LOCALBASE}/${APACHEMODDIR}/mod_fastcgi.so:${PORTSDIR}/www/mod_fastcgi
RUN_DEPENDS+= ${LOCALBASE}/${APACHEMODDIR}/mod_fastcgi.so:${PORTSDIR}/www/mod_fastcgi \
${FASTCGI_DEPS}
+CONFIGURE_ARGS+= --with-apachectl=${LOCALBASE}/sbin/apachectl
.endif
.if ${PORT_OPTIONS:MLIGHTTPD}
@@ -156,7 +158,7 @@ CONFIGURE_ARGS+= --enable-gpg
.if ${PORT_OPTIONS:MGD}
BUILD_DEPENDS+= ${GD_DEPS}
RUN_DEPENDS+= ${GD_DEPS}
-configure_args+= --enable-gd
+CONFIGURE_ARGS+= --enable-gd
.endif
RT_ETC_PATH?= ${PREFIX}/etc/${PORTNAME}40
diff --git a/www/rt40/Makefile.cpan b/www/rt40/Makefile.cpan
index 15ab5d31b8fc..7bc7327980b2 100644
--- a/www/rt40/Makefile.cpan
+++ b/www/rt40/Makefile.cpan
@@ -35,9 +35,11 @@ CORE_DEPS= p5-CSS-Squish>=0.06:${PORTSDIR}/textproc/p5-CSS-Squish \
p5-Email-Address>=1.89.5:${PORTSDIR}/mail/p5-Email-Address \
p5-Encode>=2.39:${PORTSDIR}/converters/p5-Encode \
p5-File-ShareDir>0:${PORTSDIR}/devel/p5-File-ShareDir \
+ p5-HTML-Format>0:${PORTSDIR}/textproc/p5-HTML-Format \
p5-HTML-Parser>0:${PORTSDIR}/www/p5-HTML-Parser \
p5-HTML-Quoted>0:${PORTSDIR}/textproc/p5-HTML-Quoted \
p5-HTML-Scrubber>=0.08:${PORTSDIR}/www/p5-HTML-Scrubber \
+ p5-HTML-Tree>0:${PORTSDIR}/www/p5-HTML-Tree \
p5-List-MoreUtils>0:${PORTSDIR}/lang/p5-List-MoreUtils \
p5-Locale-Maketext-Fuzzy>0:${PORTSDIR}/devel/p5-Locale-Maketext-Fuzzy \
p5-Locale-Maketext-Lexicon>=0.32:${PORTSDIR}/devel/p5-Locale-Maketext-Lexicon \
@@ -71,9 +73,7 @@ PSGI_DEPS= p5-CGI-Emulate-PSGI>0:${PORTSDIR}/www/p5-CGI-Emulate-PSGI \
p5-Plack>=0.9971:${PORTSDIR}/www/p5-Plack \
p5-Starlet>0:${PORTSDIR}/www/p5-Starlet
-MAILGATE_DEPS= p5-HTML-Format>0:${PORTSDIR}/textproc/p5-HTML-Format \
- p5-HTML-Tree>0:${PORTSDIR}/www/p5-HTML-Tree \
- p5-libwww>6.0:${PORTSDIR}/www/p5-libwww
+MAILGATE_DEPS= p5-libwww>6.0:${PORTSDIR}/www/p5-libwww
SSL_MAILGATE_DEPS= p5-Crypt-SSLeay>0:${PORTSDIR}/security/p5-Crypt-SSLeay \
p5-LWP-Protocol-https>0:${PORTSDIR}/www/p5-LWP-Protocol-https \
@@ -125,7 +125,8 @@ ICAL_DEPS= p5-Data-ICal>0:${PORTSDIR}/deskutils/p5-Data-ICal
SMTP_DEPS= ## -- only needs perl core modules
DASHBOARDS_DEPS= p5-HTML-RewriteAttributes>=0.05:${PORTSDIR}/textproc/p5-HTML-RewriteAttributes \
- p5-MIME-Types>0:${PORTSDIR}/mail/p5-MIME-Types
+ p5-MIME-Types>0:${PORTSDIR}/mail/p5-MIME-Types \
+ p5-URI>=1.59:${PORTSDIR}/net/p5-URI
GRAPHVIZ_DEPS= p5-GraphViz>0:${PORTSDIR}/graphics/p5-GraphViz \
p5-IPC-Run>=0.90:${PORTSDIR}/devel/p5-IPC-Run
@@ -135,3 +136,6 @@ GD_DEPS= p5-GD>0:${PORTSDIR}/graphics/p5-GD \
p5-GD-TextUtil>0:${PORTSDIR}/graphics/p5-GD-TextUtil
USERLOGO_DEPS= p5-Convert-Color>0:${PORTSDIR}/graphics/p5-Convert-Color
+
+HTML_DOC_DEPS= p5-HTML-Parser>0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-Pod-Simple>=3.24:${PORTSDIR}/textproc/p5-Pod-Simple
diff --git a/www/rt40/distinfo b/www/rt40/distinfo
index cb373020f923..4aa370a1e3b2 100644
--- a/www/rt40/distinfo
+++ b/www/rt40/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rt-4.0.13.tar.gz) = b8c516e6b99a38476eb0e0d6336d11056e322a2143e01c96e42f4586a68bf999
-SIZE (rt-4.0.13.tar.gz) = 6895248
+SHA256 (rt-4.0.14.tar.gz) = 44fda97d12661d1448db82211d3734486de90d25ad6c0cf4c774e9634ebe4e0e
+SIZE (rt-4.0.14.tar.gz) = 6827713
diff --git a/www/rt40/pkg-plist b/www/rt40/pkg-plist
index 13748c9766c1..081eef42e9a1 100644
--- a/www/rt40/pkg-plist
+++ b/www/rt40/pkg-plist
@@ -1266,6 +1266,7 @@ share/rt40/html/Search/Elements/NewListActions
share/rt40/html/Search/Elements/PickBasics
share/rt40/html/Search/Elements/PickCFs
share/rt40/html/Search/Elements/PickCriteria
+share/rt40/html/Search/Elements/PickTicketCFs
share/rt40/html/Search/Elements/ResultsRSSView
share/rt40/html/Search/Elements/SearchPrivacy
share/rt40/html/Search/Elements/SearchesForObject