aboutsummaryrefslogtreecommitdiff
path: root/www/ruby-aws
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-22 10:36:27 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-22 10:36:27 +0000
commitf225902e8ec1f070df765c165a6e759bdd026b2f (patch)
tree87140ee24698f88bec1d790d8d73fa92d22bb98a /www/ruby-aws
parent75ff928b09a5ae6f0fc71e7d31d2c41fd0510119 (diff)
downloadports-f225902e8ec1f070df765c165a6e759bdd026b2f.tar.gz
ports-f225902e8ec1f070df765c165a6e759bdd026b2f.zip
Notes
Diffstat (limited to 'www/ruby-aws')
-rw-r--r--www/ruby-aws/Makefile23
1 files changed, 5 insertions, 18 deletions
diff --git a/www/ruby-aws/Makefile b/www/ruby-aws/Makefile
index b15656967505..e8252c13318b 100644
--- a/www/ruby-aws/Makefile
+++ b/www/ruby-aws/Makefile
@@ -20,27 +20,14 @@ USE_RUBY_SETUP= yes
DOCS= COPYING INSTALL NEWS README
EXAMPLES= example/*
-RUBY_REQUIRE= Ruby > 180
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if !defined(RUBY_PROVIDED)
-IGNORE= depends on Ruby 1.8.0 or later
-.endif
-
post-install:
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}/
+ ${MKDIR} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}/
.for f in ${EXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODEXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}/
.endfor
-.endif
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODDOCDIR}/
+ ${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}/
.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_MODDOCDIR}/
.endfor
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>