aboutsummaryrefslogtreecommitdiff
path: root/www/ruby-gtkmozembed
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2006-07-03 00:39:30 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2006-07-03 00:39:30 +0000
commitd9fa7e5a744e603502c90ed7e17c330916398013 (patch)
tree1602da6d53dcc2c6ee2fc83f64eda0e0b1660381 /www/ruby-gtkmozembed
parented21386c5e3f72a5c9caade01b0ac74988ce724b (diff)
downloadports-d9fa7e5a744e603502c90ed7e17c330916398013.tar.gz
ports-d9fa7e5a744e603502c90ed7e17c330916398013.zip
Notes
Diffstat (limited to 'www/ruby-gtkmozembed')
-rw-r--r--www/ruby-gtkmozembed/Makefile7
-rw-r--r--www/ruby-gtkmozembed/files/patch-extconf.rb12
2 files changed, 16 insertions, 3 deletions
diff --git a/www/ruby-gtkmozembed/Makefile b/www/ruby-gtkmozembed/Makefile
index ba9ffcfdffb7..b9ee5b4c4e4d 100644
--- a/www/ruby-gtkmozembed/Makefile
+++ b/www/ruby-gtkmozembed/Makefile
@@ -21,7 +21,7 @@ COMMENT= Ruby binding for GtkMozEmbed a widget embedding a Gecko renderer
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/gtk2.so:${PORTSDIR}/x11-toolkits/ruby-gtk2
USE_RUBY= yes
-USE_GECKO= mozilla
+USE_GECKO= firefox mozilla xulrunner
USE_RUBY_EXTCONF= yes
.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
@@ -35,8 +35,9 @@ DOCS= COPYING.LIB ChangeLog README
.include "${.CURDIR}/../../www/mozilla/bsd.gecko.mk"
post-patch:
- @${REINPLACE_CMD} -e 's|mozilla-|${GECKO}-|g' \
- ${WRKSRC}/extconf.rb
+ @${REINPLACE_CMD} -e 's|xulrunner-|${GECKO}-|g ; \
+ s|%%GECKO_PATH%%|${X11BASE}/lib/${GECKO}|g' \
+ ${WRKSRC}/extconf.rb
post-install:
.if !defined(NOPORTDOCS)
diff --git a/www/ruby-gtkmozembed/files/patch-extconf.rb b/www/ruby-gtkmozembed/files/patch-extconf.rb
new file mode 100644
index 000000000000..c08018c84c24
--- /dev/null
+++ b/www/ruby-gtkmozembed/files/patch-extconf.rb
@@ -0,0 +1,12 @@
+--- extconf.rb.orig Sun Jul 2 19:15:05 2006
++++ extconf.rb Sun Jul 2 19:19:25 2006
+@@ -23,8 +23,7 @@
+ PKGConfig.have_package(PACKAGE_ID)
+ setup_win32(PACKAGE_NAME)
+
+-mozpath = PKGConfig.libs_only_L(PACKAGE_ID)
+-mozpath.strip!.sub!(/^-L/, "")
++mozpath = "%%GECKO_PATH%%"
+
+ if mozpath
+ # please comment the CFLAGS line if you don't want a default comp_path