aboutsummaryrefslogtreecommitdiff
path: root/www/rubygem-actionpack4
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2013-10-24 18:32:24 +0000
committerSteve Wills <swills@FreeBSD.org>2013-10-24 18:32:24 +0000
commit7f70d47e70a33e8c29885045ce29fc376d1db969 (patch)
tree39da466f5587d6612880cba1c54a3a87b1378aef /www/rubygem-actionpack4
parent529fe210f12bd71a5ff923317e92e4ba2e5d0a1a (diff)
downloadports-7f70d47e70a33e8c29885045ce29fc376d1db969.tar.gz
ports-7f70d47e70a33e8c29885045ce29fc376d1db969.zip
Notes
Diffstat (limited to 'www/rubygem-actionpack4')
-rw-r--r--www/rubygem-actionpack4/Makefile26
-rw-r--r--www/rubygem-actionpack4/distinfo2
-rw-r--r--www/rubygem-actionpack4/pkg-descr12
3 files changed, 40 insertions, 0 deletions
diff --git a/www/rubygem-actionpack4/Makefile b/www/rubygem-actionpack4/Makefile
new file mode 100644
index 000000000000..f8b15cc6ae3e
--- /dev/null
+++ b/www/rubygem-actionpack4/Makefile
@@ -0,0 +1,26 @@
+# Created by: Jonathan Weiss (<jw@innerewut.de>)
+# $FreeBSD$
+
+PORTNAME= actionpack
+PORTVERSION= 4.0.0
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Action Controller and Action View of Rails MVC Framework
+
+RUN_DEPENDS= rubygem-activesupport4>=${PORTVERSION}:${PORTSDIR}/devel/rubygem-activesupport4 \
+ rubygem-builder31>=3.1.0:${PORTSDIR}/devel/rubygem-builder31 \
+ rubygem-erubis>=2.7.0:${PORTSDIR}/www/rubygem-erubis \
+ rubygem-rack15>=1.5.2:${PORTSDIR}/www/rubygem-rack15 \
+ rubygem-rack-test>=0.6.1:${PORTSDIR}/www/rubygem-rack-test
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+PKGNAMESUFFIX= 4
+
+NO_STAGE= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-actionpack4/distinfo b/www/rubygem-actionpack4/distinfo
new file mode 100644
index 000000000000..0e6e24f36e6b
--- /dev/null
+++ b/www/rubygem-actionpack4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/actionpack-4.0.0.gem) = 8dc8e2849e0524edb34f1c7a12481a070531db07a2e47203a2e3548c5783a943
+SIZE (rubygem/actionpack-4.0.0.gem) = 332288
diff --git a/www/rubygem-actionpack4/pkg-descr b/www/rubygem-actionpack4/pkg-descr
new file mode 100644
index 000000000000..86de86d0baca
--- /dev/null
+++ b/www/rubygem-actionpack4/pkg-descr
@@ -0,0 +1,12 @@
+Action Pack
+
+The controller and view of the RubyOnRails MVC-Framework is handled
+by the Action Pack, which handles both layers by its two parts:
+Action View and Action Controller. These two layers are bundled
+in a single package due to their heavy interdependence. This is unlike
+the relationship between the Active Record and Action Pack that is
+much more separate.
+
+Each of these packages can be used independently outside of Rails.
+
+WWW: http://www.rubyonrails.org