aboutsummaryrefslogtreecommitdiff
path: root/www/rubygem-amazon-ecs
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2010-11-10 15:24:43 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2010-11-10 15:24:43 +0000
commit07677d00018a88df67d589b0e8189e6c7e41cee2 (patch)
tree4c3adce0a6a7d923c3d9e21f61d6c3a14122274e /www/rubygem-amazon-ecs
parentcbc441f9799d64d2cfee33f1b1093a0baaaf2925 (diff)
downloadports-07677d00018a88df67d589b0e8189e6c7e41cee2.tar.gz
ports-07677d00018a88df67d589b0e8189e6c7e41cee2.zip
Notes
Diffstat (limited to 'www/rubygem-amazon-ecs')
-rw-r--r--www/rubygem-amazon-ecs/Makefile4
-rw-r--r--www/rubygem-amazon-ecs/distinfo5
-rw-r--r--www/rubygem-amazon-ecs/pkg-descr17
3 files changed, 19 insertions, 7 deletions
diff --git a/www/rubygem-amazon-ecs/Makefile b/www/rubygem-amazon-ecs/Makefile
index ec5fcba481d0..02850b197202 100644
--- a/www/rubygem-amazon-ecs/Makefile
+++ b/www/rubygem-amazon-ecs/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= amazon-ecs
-PORTVERSION= 0.5.7
+PORTVERSION= 1.0.0
CATEGORIES= www rubygems
MASTER_SITES= RG
@@ -16,6 +16,8 @@ COMMENT= A generic Amazon E-commerce REST API written in Ruby
RUN_DEPENDS= rubygem-hpricot>=0.4:${PORTSDIR}/www/rubygem-hpricot \
${RUBY_PKGNAMEPREFIX}hmac>=0.3.2:${PORTSDIR}/security/ruby-hmac
+LICENSE= MIT
+
USE_RUBY= yes
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
diff --git a/www/rubygem-amazon-ecs/distinfo b/www/rubygem-amazon-ecs/distinfo
index 48a610cbda0b..0fb7a182fb22 100644
--- a/www/rubygem-amazon-ecs/distinfo
+++ b/www/rubygem-amazon-ecs/distinfo
@@ -1,3 +1,2 @@
-MD5 (rubygem/amazon-ecs-0.5.7.gem) = 6483ab8e61b731da07dd2b2522a6b91f
-SHA256 (rubygem/amazon-ecs-0.5.7.gem) = f388e7bead1f82f3c306f8cfd39f369d64445c73f033deece8c8f93550604a67
-SIZE (rubygem/amazon-ecs-0.5.7.gem) = 9728
+SHA256 (rubygem/amazon-ecs-1.0.0.gem) = 3a884160049513ced7b81d8fa41876ec2a99b5c95931a8a969bf0efd937e24c0
+SIZE (rubygem/amazon-ecs-1.0.0.gem) = 9728
diff --git a/www/rubygem-amazon-ecs/pkg-descr b/www/rubygem-amazon-ecs/pkg-descr
index 6acf8046d6e1..43e8149d92a2 100644
--- a/www/rubygem-amazon-ecs/pkg-descr
+++ b/www/rubygem-amazon-ecs/pkg-descr
@@ -1,4 +1,15 @@
-A generic Amazon E-commerce REST API
-with configurable default options and method call options.
+A generic Amazon E-commerce REST API with configurable default options and
+method call options. It uses Hpricot to parse the XML output. Use Response and
+Element wrapper classes for easy access to the XML elements, and it supports
+ECS 4.0.
-WWW: http://amazon-ecs.rubyforge.net/
+It is generic, so you can extend Amazon::Ecs to support the other not-
+implemented operations easily; and the response object just wraps around
+Hpricot element object, instead of providing one-to-one object/attributes to
+XML elements map.
+
+With that, if in the future, there is a change in REST XML output structure,
+no changes will be required on amazon-ecs, instead you just need to change
+your element path.
+
+WWW: http://www.pluitsolutions.com/projects/amazon-ecs