aboutsummaryrefslogtreecommitdiff
path: root/www/rubygem-bluecloth
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-05-08 13:22:09 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-05-08 13:22:09 +0000
commita1ea4f35e8e0fc39c714f8c96dfa8b0e703a72a1 (patch)
treeaa44a6328d42b8c5c9de378e0ea11d9428a5b77d /www/rubygem-bluecloth
parent0e8c34c0e927a25aa8474802d5dbd8bead7b2bf7 (diff)
downloadports-a1ea4f35e8e0fc39c714f8c96dfa8b0e703a72a1.tar.gz
ports-a1ea4f35e8e0fc39c714f8c96dfa8b0e703a72a1.zip
Notes
Diffstat (limited to 'www/rubygem-bluecloth')
-rw-r--r--www/rubygem-bluecloth/Makefile18
-rw-r--r--www/rubygem-bluecloth/distinfo3
-rw-r--r--www/rubygem-bluecloth/pkg-descr8
-rw-r--r--www/rubygem-bluecloth/pkg-plist71
4 files changed, 100 insertions, 0 deletions
diff --git a/www/rubygem-bluecloth/Makefile b/www/rubygem-bluecloth/Makefile
new file mode 100644
index 000000000000..a691d6c589f6
--- /dev/null
+++ b/www/rubygem-bluecloth/Makefile
@@ -0,0 +1,18 @@
+# Ports collection makefile for: rubygem-bluecloth
+#
+# $FreeBSD$
+
+PORTNAME= bluecloth
+PORTVERSION= 1.0.0
+CATEGORIES= www rubygems
+MASTER_SITES= http://www.deveiate.org/code/
+DISTNAME= BlueCloth-${PORTVERSION}
+
+MAINTAINER= arsptr@optusnet.com.au
+COMMENT= Ruby implementation of Markdown, a text-to-HTML conversion tool
+
+PLIST_SUB+= DISTNAME="${DISTNAME}"
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/www/rubygem-bluecloth/distinfo b/www/rubygem-bluecloth/distinfo
new file mode 100644
index 000000000000..64b5b9f7b679
--- /dev/null
+++ b/www/rubygem-bluecloth/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/BlueCloth-1.0.0.gem) = 280cb5e30ae432724b52455e62de011a
+SHA256 (rubygem/BlueCloth-1.0.0.gem) = 40d34cc8c87654fdf10da4a23d31f2c7e4855175a5f8625f8229f3c842d85486
+SIZE (rubygem/BlueCloth-1.0.0.gem) = 66199
diff --git a/www/rubygem-bluecloth/pkg-descr b/www/rubygem-bluecloth/pkg-descr
new file mode 100644
index 000000000000..baee2ba2771d
--- /dev/null
+++ b/www/rubygem-bluecloth/pkg-descr
@@ -0,0 +1,8 @@
+BlueCloth is a Ruby implementation of Markdown, a text-to-HTML
+conversion tool for web writers.
+
+Markdown allows you to write using an easy-to-read, easy-to-write
+plain text format, then convert it to structurally valid XHTML (or
+HTML).
+
+WWW: http://www.deveiate.org/projects/BlueCloth
diff --git a/www/rubygem-bluecloth/pkg-plist b/www/rubygem-bluecloth/pkg-plist
new file mode 100644
index 000000000000..ecc595511daf
--- /dev/null
+++ b/www/rubygem-bluecloth/pkg-plist
@@ -0,0 +1,71 @@
+%%CACHE_DIR%%/%%DISTNAME%%.gem
+%%GEMS_DIR%%/%%DISTNAME%%/bin/bluecloth
+%%GEMS_DIR%%/%%DISTNAME%%/lib/bluecloth.rb
+%%GEMS_DIR%%/%%DISTNAME%%/CHANGES
+%%GEMS_DIR%%/%%DISTNAME%%/LICENSE
+%%GEMS_DIR%%/%%DISTNAME%%/README
+%%GEMS_DIR%%/%%DISTNAME%%/install.rb
+%%GEMS_DIR%%/%%DISTNAME%%/test.rb
+%%GEMS_DIR%%/%%DISTNAME%%/utils.rb
+%%GEMS_DIR%%/%%DISTNAME%%/tests/00_Class.tests.rb
+%%GEMS_DIR%%/%%DISTNAME%%/tests/05_Markdown.tests.rb
+%%GEMS_DIR%%/%%DISTNAME%%/tests/10_Bug.tests.rb
+%%GEMS_DIR%%/%%DISTNAME%%/tests/15_Contrib.tests.rb
+%%GEMS_DIR%%/%%DISTNAME%%/tests/bctestcase.rb
+%%GEMS_DIR%%/%%DISTNAME%%/tests/data/antsugar.txt
+%%GEMS_DIR%%/%%DISTNAME%%/tests/data/ml-announce.txt
+%%GEMS_DIR%%/%%DISTNAME%%/tests/data/re-overflow.txt
+%%GEMS_DIR%%/%%DISTNAME%%/tests/data/re-overflow2.txt
+%%SPEC_DIR%%/%%DISTNAME%%.gemspec
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/created.rid
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/fr_class_index.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/fr_file_index.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/fr_method_index.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/index.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/rdoc-style.css
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth/FormatError.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth/FormatError.src/M000030.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000001.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000002.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000003.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000004.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000005.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000006.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000007.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000008.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000009.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000010.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000011.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000012.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000013.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000014.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000015.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000016.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000017.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000018.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000019.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000020.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000021.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000022.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000023.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000024.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000025.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000026.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000027.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000028.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src/M000029.html
+%%DOC_DIR%%/%%DISTNAME%%/rdoc/files/lib/bluecloth_rb.html
+@dirrm %%GEMS_DIR%%/%%DISTNAME%%/tests/data
+@dirrm %%GEMS_DIR%%/%%DISTNAME%%/tests
+@dirrm %%GEMS_DIR%%/%%DISTNAME%%/lib
+@dirrm %%GEMS_DIR%%/%%DISTNAME%%/bin
+@dirrm %%GEMS_DIR%%/%%DISTNAME%%
+@dirrm %%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth/FormatError.src
+@dirrm %%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth.src
+@dirrm %%DOC_DIR%%/%%DISTNAME%%/rdoc/classes/BlueCloth
+@dirrm %%DOC_DIR%%/%%DISTNAME%%/rdoc/classes
+@dirrm %%DOC_DIR%%/%%DISTNAME%%/rdoc/files/lib
+@dirrm %%DOC_DIR%%/%%DISTNAME%%/rdoc/files
+@dirrm %%DOC_DIR%%/%%DISTNAME%%/rdoc
+@dirrm %%DOC_DIR%%/%%DISTNAME%%