aboutsummaryrefslogtreecommitdiff
path: root/www/rubygem-httpclient
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-04-08 20:29:17 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-04-08 20:29:17 +0000
commit65b84030ea9f9636d5a95229201fb28868169cd6 (patch)
tree41ebe7e120c0b95ea786c08570b81ad64bab81d5 /www/rubygem-httpclient
parent468ac7320b45a2cde9d227f64e67e41ef043e4fd (diff)
Notes
Diffstat (limited to 'www/rubygem-httpclient')
-rw-r--r--www/rubygem-httpclient/Makefile21
-rw-r--r--www/rubygem-httpclient/distinfo3
-rw-r--r--www/rubygem-httpclient/pkg-descr23
3 files changed, 47 insertions, 0 deletions
diff --git a/www/rubygem-httpclient/Makefile b/www/rubygem-httpclient/Makefile
new file mode 100644
index 000000000000..4f75b539ced3
--- /dev/null
+++ b/www/rubygem-httpclient/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: rubygem-httpclient
+# Date created: 7 April 2009
+# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= httpclient
+PORTVERSION= 2.1.4
+CATEGORIES= www rubygems
+MASTER_SITES= RF
+MASTER_SITE_SUBDIR= soap4r
+
+MAINTAINER= pgollucci@FreeBSD.org
+COMMENT= Yet another HTTP client implementation by NaHi
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-httpclient/distinfo b/www/rubygem-httpclient/distinfo
new file mode 100644
index 000000000000..e0f7e009ba72
--- /dev/null
+++ b/www/rubygem-httpclient/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/httpclient-2.1.4.gem) = e94974f785e667cfb533bb579a15fe34
+SHA256 (rubygem/httpclient-2.1.4.gem) = 7741222b6714723d5d1335d7ba79aa1f82a952d662fb8e95a5409d9573e8ed73
+SIZE (rubygem/httpclient-2.1.4.gem) = 71680
diff --git a/www/rubygem-httpclient/pkg-descr b/www/rubygem-httpclient/pkg-descr
new file mode 100644
index 000000000000..d8e4bb2d2322
--- /dev/null
+++ b/www/rubygem-httpclient/pkg-descr
@@ -0,0 +1,23 @@
+httpclient gives something like the functionality of libwww-perl (LWP) in Ruby. httpclient formerly known as http-access2.
+
+Features:
+
+ * methods like GET/HEAD/POST/* via HTTP/1.1.
+ * HTTPS(SSL), Cookies, proxy, authentication(Digest, NTLM, Basic), etc.
+ * asynchronous HTTP request, streaming HTTP request.
+ * by contrast with net/http in standard distribution;
+ o Cookies support
+ o MT-safe
+ o streaming POST (POST with File/IO)
+ o Digest auth
+ o Negotiate/NTLM auth for WWW-Authenticate (requires net/htlm module)
+ o NTLM auth for Proxy-Authenticate (requires win32/sspi module)
+ o extensible with filter interface
+ o you dont have to care HTTP/1.1 persistent connection (httpclient cares instead of you)
+ * Not supported now
+ o Cache
+ o Rather advanced HTTP/1.1 usage such as Range, deflate, etc. (of course you can set it in header by yourself)
+
+For more detail, see API document at dev.ctor.org/doc/httpclient/
+
+WWW: http://raa.ruby-lang.org/project/httpclient/