aboutsummaryrefslogtreecommitdiff
path: root/www/rubygem-mongrel/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-06-05 14:30:10 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-06-05 14:30:10 +0000
commitb25dfdb1fc46e1cbb89fbe1d78ac873b87fe3888 (patch)
tree2ce302a89bcaa7fe81d4ed85a2f0e6506ba907be /www/rubygem-mongrel/Makefile
parentd7ea4e4c41c102a4ff58459a24db573f595b4d96 (diff)
Notes
Diffstat (limited to 'www/rubygem-mongrel/Makefile')
-rw-r--r--www/rubygem-mongrel/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/www/rubygem-mongrel/Makefile b/www/rubygem-mongrel/Makefile
new file mode 100644
index 000000000000..2f15ced288b6
--- /dev/null
+++ b/www/rubygem-mongrel/Makefile
@@ -0,0 +1,34 @@
+# Ports collection makefile for: mongrel
+# Date created: 20 May 2006
+# Whom: Rui Lopes (<rgl ruilopes com>)
+#
+# $FreeBSD$
+
+PORTNAME= mongrel
+PORTVERSION= 0.3.12.4
+CATEGORIES= www rubygems
+MASTER_SITES= http://rubyforge.org/frs/download.php/9700/
+
+MAINTAINER= rgl@ruilopes.com
+COMMENT= Fast HTTP 1.1 library and server for Ruby web applications
+
+BUILD_DEPENDS= gpgen:${PORTSDIR}/devel/rubygem-gem_plugin \
+ rubygem-daemons>=0.4.4:${PORTSDIR}/devel/rubygem-daemons
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+# This target is only meant to be used by the port maintainer.
+x-generate-plist:
+ (${PORTSDIR}/Tools/scripts/plist -d -m ${MTREE_FILE} ${PREFIX} \
+ | ${SED} -E \
+ 's,.*share/nls/.+$$,,g \
+ ;s,^${CACHE_DIR}(/.+)$$,%%CACHE_DIR%%\1,g \
+ ;s,${GEM_DOC_DIR}(/.+)?$$,%%GEM_DOC_DIR%%\1,g \
+ ;s,${GEM_LIB_DIR}(/.+)?$$,%%GEM_LIB_DIR%%\1,g \
+ ;s,^${SPEC_DIR}(/.+)$$,%%SPEC_DIR%%\1,g \
+ ;s,^${GEMS_BASE_DIR}/(.+)$$,\1,g \
+ ;s,^@dirrm (${SPEC_DIR}|${GEMS_DIR}|lib/ruby).*$$,,g \
+ ' | ${TR} -s '\n') > temp-pkg-plist
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
+.include <bsd.port.post.mk>