aboutsummaryrefslogtreecommitdiff
path: root/www/rubygem-rails
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-10-28 14:55:12 +0000
committerSteve Wills <swills@FreeBSD.org>2011-10-28 14:55:12 +0000
commit2563c6d6decb7574ce7bc523f40a32bc9bdbd0c8 (patch)
tree143a9408302864d333c9f9c4bdd43ecbec999bff /www/rubygem-rails
parent35e6be4c398f32ab858030155fe1e3cfc45b39b9 (diff)
downloadports-2563c6d6decb7574ce7bc523f40a32bc9bdbd0c8.tar.gz
ports-2563c6d6decb7574ce7bc523f40a32bc9bdbd0c8.zip
Notes
Diffstat (limited to 'www/rubygem-rails')
-rw-r--r--www/rubygem-rails/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/www/rubygem-rails/Makefile b/www/rubygem-rails/Makefile
index abf6c7212124..f854043062d2 100644
--- a/www/rubygem-rails/Makefile
+++ b/www/rubygem-rails/Makefile
@@ -42,9 +42,9 @@ PLIST_FILES= bin/rails
OPTIONS= \
FCGI "FastCGI backend" Off \
MONGREL "Mongrel backend" Off \
- MONGRELCLUSTER "Mongrel Cluster backend" Off \
+ MONGRELCLUSTER "Mongrel Cluster backend" Off \
PASSENGER "Passenger backend" Off \
- MEMCACHE_CLIENT "MemCache-Client support" Off
+ MEMCACHE_CLIENT "MemCache-Client support" Off
OPTIONSFILE= ${PORT_DBDIR}/rubygem-${PORTNAME}/options
.include <bsd.port.options.mk>
@@ -69,4 +69,10 @@ RUN_DEPENDS+= rubygem-mongrel_cluster>=1.0.5:${PORTSDIR}/www/rubygem-mongrel_clu
RUN_DEPENDS+= rubygem-passenger>=2.2.15:${PORTSDIR}/www/rubygem-passenger
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${RUBY_VER} == 1.9
+RUN_DEPENDS+= rubygem-turn>=0.8.3:${PORTSDIR}/devel/rubygem-turn
+.endif
+
+.include <bsd.port.post.mk>