aboutsummaryrefslogtreecommitdiff
path: root/www/rubygem-ramaze
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-06-23 18:24:15 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-06-23 18:24:15 +0000
commita5613a7aa976bf9e092cc86100aee82cb2d8cae8 (patch)
treebb99b5157970b1624a298610692d5e844a2bbe1d /www/rubygem-ramaze
parent990a779a543458757df7e5c0e5fb18c096d64363 (diff)
- Update to 2010.04.04
PR: ports/148073 Submitted by: Jyun-Yan You <jyyou@cs.nctu.edu.tw> (maintainer) Feature safe: yes
Notes
Notes: svn path=/head/; revision=256879
Diffstat (limited to 'www/rubygem-ramaze')
-rw-r--r--www/rubygem-ramaze/Makefile12
-rw-r--r--www/rubygem-ramaze/distinfo6
-rw-r--r--www/rubygem-ramaze/files/xhtml.rb.patch20
3 files changed, 6 insertions, 32 deletions
diff --git a/www/rubygem-ramaze/Makefile b/www/rubygem-ramaze/Makefile
index 9e85f4c5d552..90fa86d024ac 100644
--- a/www/rubygem-ramaze/Makefile
+++ b/www/rubygem-ramaze/Makefile
@@ -4,28 +4,22 @@
#
# $FreeBSD$
#
+# note, innate version is typically an exact requirement
PORTNAME= ramaze
-PORTVERSION= 2009.10
+PORTVERSION= 2010.04.04
CATEGORIES= www rubygems
MASTER_SITES= RG
MAINTAINER= jyyou@cs.nctu.edu.tw
COMMENT= Ramaze is a simple and modular web framework
-RUN_DEPENDS= rubygem-innate=2009.10:${PORTSDIR}/www/rubygem-innate
-
-BROKEN= requires exact version of www/rubygem-innate
+RUN_DEPENDS= rubygem-innate>=2010.04:${PORTSDIR}/www/rubygem-innate
PLIST_FILES= bin/ramaze
USE_RUBY= yes
-
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
-post-install:
- @${PATCH} -p0 -d ${PREFIX}/${GEM_LIB_DIR} < ${PATCHDIR}/xhtml.rb.patch
- @${FIND} ${PREFIX}/${GEM_LIB_DIR} -name "*.orig" -delete
-
.include <bsd.port.mk>
diff --git a/www/rubygem-ramaze/distinfo b/www/rubygem-ramaze/distinfo
index dc58c55f4a10..1a2331ebf109 100644
--- a/www/rubygem-ramaze/distinfo
+++ b/www/rubygem-ramaze/distinfo
@@ -1,3 +1,3 @@
-MD5 (rubygem/ramaze-2009.10.gem) = e97055aa3b8ce4e744dc71fba36368d4
-SHA256 (rubygem/ramaze-2009.10.gem) = 49140e3ad5c39ead1ef25bdf333eade4bb067fdccd3c4cc6754b5bfc69ce87a7
-SIZE (rubygem/ramaze-2009.10.gem) = 626688
+MD5 (rubygem/ramaze-2010.04.04.gem) = 71736f531dce220597b4be517bf6bb28
+SHA256 (rubygem/ramaze-2010.04.04.gem) = f1b4a07a0371d8a164587bc13db03562d34852a3ab98da59e7bdccd32632d760
+SIZE (rubygem/ramaze-2010.04.04.gem) = 644096
diff --git a/www/rubygem-ramaze/files/xhtml.rb.patch b/www/rubygem-ramaze/files/xhtml.rb.patch
deleted file mode 100644
index 94f19c6009a5..000000000000
--- a/www/rubygem-ramaze/files/xhtml.rb.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- lib/ramaze/helper/xhtml.rb.orig 2009-11-04 20:13:31.180694249 +0800
-+++ lib/ramaze/helper/xhtml.rb 2009-11-04 20:18:00.000000000 +0800
-@@ -8,7 +8,7 @@
-
- def css(name, media = 'screen', options = {})
- if options.empty?
-- LINK_TAG % ["/css/#{name}.css", media]
-+ LINK_TAG % ["#{Ramaze.options.prefix}/css/#{name}.css", media]
- elsif options[:only].to_s.downcase == 'ie'
- "<!--[if IE]>#{css(name, media)}<![endif]-->"
- end
-@@ -22,7 +22,7 @@
- if name =~ /^http/ # consider it external full url
- SCRIPT_TAG % name
- else
-- SCRIPT_TAG % "/js/#{name}.js"
-+ SCRIPT_TAG % "#{Ramaze.options.prefix}/js/#{name}.js"
- end
- end
-