aboutsummaryrefslogtreecommitdiff
path: root/www/rubygem-rubyfulsoup/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2007-02-18 12:45:26 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2007-02-18 12:45:26 +0000
commit1fd2da0000fbe92f74aa70e8b294682261c6736f (patch)
treed73fd7f85ab1543dcc7405d682de7774de992cf8 /www/rubygem-rubyfulsoup/Makefile
parentd8eaa6454af4abc6c16cd4dc1ad86d9bc2f045ea (diff)
downloadports-1fd2da0000fbe92f74aa70e8b294682261c6736f.tar.gz
ports-1fd2da0000fbe92f74aa70e8b294682261c6736f.zip
Notes
Diffstat (limited to 'www/rubygem-rubyfulsoup/Makefile')
-rw-r--r--www/rubygem-rubyfulsoup/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/www/rubygem-rubyfulsoup/Makefile b/www/rubygem-rubyfulsoup/Makefile
new file mode 100644
index 000000000000..303aff8a998a
--- /dev/null
+++ b/www/rubygem-rubyfulsoup/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: rubyfulsoup
+# Date created: 16 feb 2007
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+
+PORTNAME= rubyfulsoup
+PORTVERSION= 1.0.4
+CATEGORIES= www textproc rubygems
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= rubyfulsoup
+DISTNAME= rubyful_soup-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Ruby port of the HTML/XML parser Beautiful Soup
+
+BUILD_DEPENDS= ${LOCALBASE}/${SPEC_DIR}/htmltools-1.10.gemspec:${PORTSDIR}/textproc/rubygem-htmltools
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_RUBY= yes
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
+.include <bsd.port.post.mk>