aboutsummaryrefslogtreecommitdiff
path: root/www/sarg
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2012-01-23 22:48:19 +0000
committerRenato Botelho <garga@FreeBSD.org>2012-01-23 22:48:19 +0000
commit1143a5408629be4521014fcb2445e02b6ffc1878 (patch)
treeef603ba2f4b19c07fba26a1b1a16550aa920ac04 /www/sarg
parent1c43d9e4b5d975719b81bc4cc7e41efee489fe58 (diff)
downloadports-1143a5408629be4521014fcb2445e02b6ffc1878.tar.gz
ports-1143a5408629be4521014fcb2445e02b6ffc1878.zip
Notes
Diffstat (limited to 'www/sarg')
-rw-r--r--www/sarg/Makefile10
-rw-r--r--www/sarg/files/patch-configure.in12
2 files changed, 17 insertions, 5 deletions
diff --git a/www/sarg/Makefile b/www/sarg/Makefile
index 9d632427839d..34131d795a59 100644
--- a/www/sarg/Makefile
+++ b/www/sarg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sarg
PORTVERSION= 2.3.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -19,6 +19,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
OPTIONS= GD "Enable GD support" on
+USE_AUTOTOOLS= autoconf aclocal
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
@@ -32,10 +33,6 @@ MAN1= sarg.1
.include <bsd.port.pre.mk>
-.if ${CC} == "cc"
-CC= gcc
-.endif
-
.if defined(WITHOUT_NLS)
PLIST_SUB+= NLS="@comment "
CONFIGURE_ARGS+= --disable-nls
@@ -61,4 +58,7 @@ post-patch:
@${REINPLACE_CMD} -e '/^LIBS/ s/$$/ -lintl/' ${WRKSRC}/Makefile.in
.endif
+pre-configure:
+ @(cd ${WRKSRC} && ${AUTORECONF})
+
.include <bsd.port.post.mk>
diff --git a/www/sarg/files/patch-configure.in b/www/sarg/files/patch-configure.in
new file mode 100644
index 000000000000..f99ea80e1f47
--- /dev/null
+++ b/www/sarg/files/patch-configure.in
@@ -0,0 +1,12 @@
+--- configure.in.orig 2012-01-23 11:17:59.000000000 -0200
++++ configure.in 2012-01-23 11:18:08.000000000 -0200
+@@ -17,9 +17,6 @@
+ dnl * ) AC_PROG_CXX ;;
+ esac
+
+-if test "${CC}" = "cc" ; then
+- CFLAGS="${CFLAGS} -g -O2 -Aa"
+-fi
+ CFLAGS="${CFLAGS} -Wall -Wno-sign-compare"
+
+ dnl Check for supported compiler options