aboutsummaryrefslogtreecommitdiff
path: root/www/sarg
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2012-02-18 13:11:17 +0000
committerRenato Botelho <garga@FreeBSD.org>2012-02-18 13:11:17 +0000
commit85a72c9f821b0557cb5eb95f7075972d9b5e608d (patch)
tree713e2acabd249d307966adfca681e601255c651c /www/sarg
parent38e8a1e8579d3d031999a3a6a24bff68a7a806e1 (diff)
downloadports-85a72c9f821b0557cb5eb95f7075972d9b5e608d.tar.gz
ports-85a72c9f821b0557cb5eb95f7075972d9b5e608d.zip
Notes
Diffstat (limited to 'www/sarg')
-rw-r--r--www/sarg/Makefile19
-rw-r--r--www/sarg/files/patch-Makefile.in26
-rw-r--r--www/sarg/pkg-plist56
3 files changed, 60 insertions, 41 deletions
diff --git a/www/sarg/Makefile b/www/sarg/Makefile
index 34131d795a59..1ef9bb7151bf 100644
--- a/www/sarg/Makefile
+++ b/www/sarg/Makefile
@@ -17,17 +17,17 @@ COMMENT= Squid log analyzer and HTML report generator
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-OPTIONS= GD "Enable GD support" on
+OPTIONS= GD "Enable GD support" on\
+ PHP "Install PHP for reporting generating" on
USE_AUTOTOOLS= autoconf aclocal
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --sysconfdir="${PREFIX}/etc/${PORTNAME}" \
- --enable-sargphp="${PREFIX}/etc/${PORTNAME}" \
- --enable-fontdir="${PREFIX}/etc/${PORTNAME}/fonts" \
- --enable-imagedir="${PREFIX}/etc/${PORTNAME}/images"
+CONFIGURE_ARGS= --sysconfdir="${ETCDIR}" \
+ --enable-fontdir="${ETCDIR}/fonts" \
+ --enable-imagedir="${ETCDIR}/images"
MAN1= sarg.1
@@ -46,8 +46,13 @@ USE_ICONV= yes
LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
.endif
-pre-install:
- ${STRIP_CMD} ${WRKSRC}/sarg
+.if !defined(WITHOUT_PHP)
+CONFIGURE_ARGS+= --enable-sargphp="${ETCDIR}"
+PLIST_SUB+= PHP=""
+.else
+CONFIGURE_ARGS+= --disable-sargphp
+PLIST_SUB+= PHP="@comment "
+.endif
post-extract:
@${FIND} ${WRKSRC} -type d -exec ${CHMOD} 0755 {} \;
diff --git a/www/sarg/files/patch-Makefile.in b/www/sarg/files/patch-Makefile.in
index bead9c38c6c2..8708d5c1347b 100644
--- a/www/sarg/files/patch-Makefile.in
+++ b/www/sarg/files/patch-Makefile.in
@@ -1,11 +1,25 @@
---- Makefile.in.orig 2011-06-19 16:12:39.000000000 -0300
-+++ Makefile.in 2011-12-28 10:50:42.000000000 -0200
-@@ -93,12 +93,11 @@
+--- Makefile.in.orig 2011-06-20 04:12:39.000000000 +0900
++++ Makefile.in 2012-02-02 18:04:28.000000000 +0900
+@@ -27,9 +27,9 @@
+ LIBS = @LIBS@ -lm
+ SRCDIR = .
+ VPATH = .
+-INSTALL = cp
++INSTALL = @INSTALL@ -m 644 -S
+
+-INSTALL_PROGRAM = $(INSTALL)
++INSTALL_PROGRAM = @INSTALL@ -m 755 -S -s
+
+ SRCS = util.c log.c report.c topuser.c email.c sort.c html.c \
+ index.c getconf.c usage.c decomp.c ip2name.c \
+@@ -91,14 +91,11 @@
+ mkdir -p $(DESTDIR)$(IMAGEDIR); \
+ fi
$(INSTALL_PROGRAM) sarg $(DESTDIR)$(bindir)/sarg
- chmod 755 $(DESTDIR)$(bindir)/sarg
- $(INSTALL_PROGRAM) sarg.1 $(DESTDIR)$(man1dir)/sarg.1
+- chmod 755 $(DESTDIR)$(bindir)/sarg
+- $(INSTALL_PROGRAM) sarg.1 $(DESTDIR)$(man1dir)/sarg.1
- chmod 755 $(DESTDIR)$(man1dir)/sarg.1
-+ chmod 644 $(DESTDIR)$(man1dir)/sarg.1
++ $(INSTALL) sarg.1 $(DESTDIR)$(man1dir)/sarg.1
+ cp sarg.conf $(DESTDIR)$(sysconfdir)/sarg.conf.default
@if test ! -f $(DESTDIR)$(sysconfdir)/sarg.conf; then \
echo "cp $(DESTDIR)$(sysconfdir)/sarg.conf"; \
diff --git a/www/sarg/pkg-plist b/www/sarg/pkg-plist
index a698b8a364d4..bdcceb56e582 100644
--- a/www/sarg/pkg-plist
+++ b/www/sarg/pkg-plist
@@ -12,24 +12,24 @@ etc/sarg/images/datetime.png
etc/sarg/images/graph.png
etc/sarg/images/sarg-squidguard-block.png
etc/sarg/images/sarg.png
-etc/sarg/sarg-php/COPYING
-etc/sarg/sarg-php/INSTALL
-etc/sarg/sarg-php/LANGUAGES
-etc/sarg/sarg-php/language.php
-etc/sarg/sarg-php/locale/en_EN/LC_MESSAGES/messages.mo
-etc/sarg/sarg-php/locale/en_EN/LC_MESSAGES/messages.po
-etc/sarg/sarg-php/locale/fr/LC_MESSAGES/messages.mo
-etc/sarg/sarg-php/locale/fr/LC_MESSAGES/messages.po
-etc/sarg/sarg-php/locale/pt_BR/LC_MESSAGES/messages.mo
-etc/sarg/sarg-php/locale/pt_BR/LC_MESSAGES/messages.po
-etc/sarg/sarg-php/locale/ru/LC_MESSAGES/messages.mo
-etc/sarg/sarg-php/locale/ru/LC_MESSAGES/messages.po
-etc/sarg/sarg-php/sarg-block-it.php
-etc/sarg/sarg-php/sarg-realtime.php
-etc/sarg/sarg-php/sarg-squidguard-block.php
-etc/sarg/sarg-php/sarg-squidguard-block2.php
-etc/sarg/sarg-php/style.php
-etc/sarg/sarg-php/translate.this
+%%PHP%%etc/sarg/sarg-php/COPYING
+%%PHP%%etc/sarg/sarg-php/INSTALL
+%%PHP%%etc/sarg/sarg-php/LANGUAGES
+%%PHP%%etc/sarg/sarg-php/language.php
+%%PHP%%etc/sarg/sarg-php/locale/en_EN/LC_MESSAGES/messages.mo
+%%PHP%%etc/sarg/sarg-php/locale/en_EN/LC_MESSAGES/messages.po
+%%PHP%%etc/sarg/sarg-php/locale/fr/LC_MESSAGES/messages.mo
+%%PHP%%etc/sarg/sarg-php/locale/fr/LC_MESSAGES/messages.po
+%%PHP%%etc/sarg/sarg-php/locale/pt_BR/LC_MESSAGES/messages.mo
+%%PHP%%etc/sarg/sarg-php/locale/pt_BR/LC_MESSAGES/messages.po
+%%PHP%%etc/sarg/sarg-php/locale/ru/LC_MESSAGES/messages.mo
+%%PHP%%etc/sarg/sarg-php/locale/ru/LC_MESSAGES/messages.po
+%%PHP%%etc/sarg/sarg-php/sarg-block-it.php
+%%PHP%%etc/sarg/sarg-php/sarg-realtime.php
+%%PHP%%etc/sarg/sarg-php/sarg-squidguard-block.php
+%%PHP%%etc/sarg/sarg-php/sarg-squidguard-block2.php
+%%PHP%%etc/sarg/sarg-php/style.php
+%%PHP%%etc/sarg/sarg-php/translate.this
etc/sarg/user_limit_block
%%NLS%%share/locale/bg/LC_MESSAGES/sarg.mo
%%NLS%%share/locale/ca/LC_MESSAGES/sarg.mo
@@ -55,16 +55,16 @@ etc/sarg/user_limit_block
%%NLS%%share/locale/tr/LC_MESSAGES/sarg.mo
%%NLS%%share/locale/uk/LC_MESSAGES/sarg.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/sarg.mo
-@dirrm etc/sarg/sarg-php/locale/ru/LC_MESSAGES
-@dirrm etc/sarg/sarg-php/locale/ru
-@dirrm etc/sarg/sarg-php/locale/pt_BR/LC_MESSAGES
-@dirrm etc/sarg/sarg-php/locale/pt_BR
-@dirrm etc/sarg/sarg-php/locale/fr/LC_MESSAGES
-@dirrm etc/sarg/sarg-php/locale/fr
-@dirrm etc/sarg/sarg-php/locale/en_EN/LC_MESSAGES
-@dirrm etc/sarg/sarg-php/locale/en_EN
-@dirrm etc/sarg/sarg-php/locale
-@dirrm etc/sarg/sarg-php
+%%PHP%%@dirrm etc/sarg/sarg-php/locale/ru/LC_MESSAGES
+%%PHP%%@dirrm etc/sarg/sarg-php/locale/ru
+%%PHP%%@dirrm etc/sarg/sarg-php/locale/pt_BR/LC_MESSAGES
+%%PHP%%@dirrm etc/sarg/sarg-php/locale/pt_BR
+%%PHP%%@dirrm etc/sarg/sarg-php/locale/fr/LC_MESSAGES
+%%PHP%%@dirrm etc/sarg/sarg-php/locale/fr
+%%PHP%%@dirrm etc/sarg/sarg-php/locale/en_EN/LC_MESSAGES
+%%PHP%%@dirrm etc/sarg/sarg-php/locale/en_EN
+%%PHP%%@dirrm etc/sarg/sarg-php/locale
+%%PHP%%@dirrm etc/sarg/sarg-php
@dirrm etc/sarg/images
@dirrm etc/sarg/fonts
@dirrmtry etc/sarg