aboutsummaryrefslogtreecommitdiff
path: root/www/sarg
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2013-05-31 13:17:41 +0000
committerRenato Botelho <garga@FreeBSD.org>2013-05-31 13:17:41 +0000
commit68c9ac4435ec110d934751c071773da2006e168a (patch)
treef1856af47cc313b057c4a8c7c989975fc33a849e /www/sarg
parent34074ecb783f8159c0bc6afbc06576ad6b50cc7c (diff)
downloadports-68c9ac4435ec110d934751c071773da2006e168a.tar.gz
ports-68c9ac4435ec110d934751c071773da2006e168a.zip
Notes
Diffstat (limited to 'www/sarg')
-rw-r--r--www/sarg/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/www/sarg/Makefile b/www/sarg/Makefile
index 12a7012daa02..92dbada83b14 100644
--- a/www/sarg/Makefile
+++ b/www/sarg/Makefile
@@ -3,6 +3,7 @@
PORTNAME= sarg
PORTVERSION= 2.3.6
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -34,6 +35,7 @@ MAN1= sarg.1
.if ${PORT_OPTIONS:MNLS}
PLIST_SUB+= NLS=""
USES+= gettext
+EXTRA_LDFLAGS= -lintl
.else
PLIST_SUB+= NLS="@comment "
CONFIGURE_ARGS+=--disable-nls
@@ -71,6 +73,7 @@ CONFIGURE_ARGS+=--without-ldap
.if ${PORT_OPTIONS:MICONV}
CONFIGURE_ARGS+=--with-iconv
USES+= iconv
+EXTRA_LDFLAGS+= -liconv
.else
CONFIGURE_ARGS+=--without-iconv
.endif
@@ -80,8 +83,11 @@ post-extract:
@${CHMOD} 0755 ${WRKSRC}/configure
post-patch:
-.if ${PORT_OPTIONS:MNLS}
- @${REINPLACE_CMD} -e '/^LIBS/ s/$$/ -lintl/' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/test .*==/ s/==/=/' \
+ ${WRKSRC}/configure.in
+.if ${PORT_OPTIONS:MNLS} || ${PORT_OPTIONS:MICONV}
+ @${REINPLACE_CMD} -e '/^LIBS/ s/$$/ ${EXTRA_LDFLAGS}/' \
+ ${WRKSRC}/Makefile.in
.endif
pre-configure: