aboutsummaryrefslogtreecommitdiff
path: root/www/screem
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
commit7887c684adab042fed1bfcba2e91589ecd17c4a8 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /www/screem
parent85544f2c01be814e0af1ebee1076012e7ed60bb0 (diff)
downloadports-7887c684adab042fed1bfcba2e91589ecd17c4a8.tar.gz
ports-7887c684adab042fed1bfcba2e91589ecd17c4a8.zip
Notes
Diffstat (limited to 'www/screem')
-rw-r--r--www/screem/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/www/screem/Makefile b/www/screem/Makefile
index 14365a87c4ec..979ecc3afcb9 100644
--- a/www/screem/Makefile
+++ b/www/screem/Makefile
@@ -49,5 +49,30 @@ post-patch:
s|-DGTK_DISABLE_DEPRECATED||g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|\&\& make|\&\& $$(MAKE)|g' \
${WRKSRC}/tests/Makefile.in
+ @${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
+ ${WRKSRC}/include/screem-markup.h \
+ ${WRKSRC}/include/screem-mdi.h \
+ ${WRKSRC}/include/screem-tagtree.h \
+ ${WRKSRC}/libegg/util/egg-macros.h \
+ ${WRKSRC}/src/screem-cvs.c \
+ ${WRKSRC}/src/screem-dtd-db.c \
+ ${WRKSRC}/src/screem-file-browser.c \
+ ${WRKSRC}/src/screem-markup.c \
+ ${WRKSRC}/src/screem-site-parse.c
+ @${REINPLACE_CMD} -e 's|glib/glist.h>|glib.h>|g' \
+ -e 's|glib/gconvert.h>|glib.h>|g' \
+ -e 's|glib/gunicode.h>|glib.h>|g' \
+ -e 's|glib/gstrfuncs.h>|glib.h>|g' \
+ -e 's|glib/gfileutils.h>|glib.h>|g' \
+ -e 's|glib/ghash.h>|glib.h>|g' \
+ ${WRKSRC}/plugins/entityWizard/entityWizard.c \
+ ${WRKSRC}/src/screem-mdi.c \
+ ${WRKSRC}/src/screem-page.c \
+ ${WRKSRC}/src/screem-search.c \
+ ${WRKSRC}/src/screem-site-ui.c \
+ ${WRKSRC}/src/screem-site.c \
+ ${WRKSRC}/src/screem-window-menus.c \
+ ${WRKSRC}/src/fileops.c \
+ ${WRKSRC}/src/support.c
.include <bsd.port.mk>