aboutsummaryrefslogtreecommitdiff
path: root/www/script4rss
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-08-02 08:54:56 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-08-02 08:54:56 +0000
commitc284e57ef969ff109c7da224427fc3507b5654b5 (patch)
treed6b5f8913cbbcec9fa642b9fa25fb50146acfb9d /www/script4rss
parent63581d92870752626e3a5e6ecbe4d69ee4b0c9f3 (diff)
downloadports-c284e57ef969ff109c7da224427fc3507b5654b5.tar.gz
ports-c284e57ef969ff109c7da224427fc3507b5654b5.zip
add script4rss 0.4b
Easily create scripts to convert HTML pages to RSS feeds
Notes
Notes: svn path=/head/; revision=115246
Diffstat (limited to 'www/script4rss')
-rw-r--r--www/script4rss/Makefile33
-rw-r--r--www/script4rss/distinfo2
-rw-r--r--www/script4rss/pkg-descr15
-rw-r--r--www/script4rss/pkg-plist4
4 files changed, 54 insertions, 0 deletions
diff --git a/www/script4rss/Makefile b/www/script4rss/Makefile
new file mode 100644
index 000000000000..22173819c69b
--- /dev/null
+++ b/www/script4rss/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: script4rss
+# Date created: Aug 2, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= script4rss
+PORTVERSION= 0.4b
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Easily create scripts to convert HTML pages to RSS feeds
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,#!/usr/bin/perl,#!${SETENV} perl," ${WRKSRC}/script4rss.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/script4rss.pl ${PREFIX}/bin/script4rss
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/script4rss/distinfo b/www/script4rss/distinfo
new file mode 100644
index 000000000000..e16515cae0b9
--- /dev/null
+++ b/www/script4rss/distinfo
@@ -0,0 +1,2 @@
+MD5 (script4rss-0.4b.tar.bz2) = 2a3dd02ad606b27ef0d0767562973ae8
+SIZE (script4rss-0.4b.tar.bz2) = 7201
diff --git a/www/script4rss/pkg-descr b/www/script4rss/pkg-descr
new file mode 100644
index 000000000000..fdd21ca00db6
--- /dev/null
+++ b/www/script4rss/pkg-descr
@@ -0,0 +1,15 @@
+Script4rss takes a plain text file which holds a description for how the
+particular site should be converted and creates a perl script which is able to
+do that in the most fast and efficient way (well, someday). Users don't have to
+know how to program but they need to know regular expressions (although there
+probably aren't a lot of these people).
+
+At the moment, script4rss is in its early development, which translates to "it
+can be used but you have to figure out how yourself" and "if you screw up, the
+script does so as well". Options include:
+ * Detect multiple catagories within an HTML page.
+ * Extract information over multiple lines.
+ * Pre-and append text in output.
+ * Attempt to circumvent "variable" HTML.
+
+WWW: http://script4rss.sourceforge.net/
diff --git a/www/script4rss/pkg-plist b/www/script4rss/pkg-plist
new file mode 100644
index 000000000000..3ab8343e1d60
--- /dev/null
+++ b/www/script4rss/pkg-plist
@@ -0,0 +1,4 @@
+bin/script4rss
+%%PORTDOCS%%%%EXAMPLESDIR%%/plosbiology2rss.s4r
+%%PORTDOCS%%%%EXAMPLESDIR%%/sciencenow2rss.s4r
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%