aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey-i18n
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2011-08-01 23:43:20 +0000
committerFlorian Smeets <flo@FreeBSD.org>2011-08-01 23:43:20 +0000
commiteb7994bdff58220d8bdd2021a5f9e0c0091e99e2 (patch)
tree88c5ab768693b877b9e22837633458714cd6d48b /www/seamonkey-i18n
parent4dcfa6ec1615880d56b20037cc5ab3f257e5dd89 (diff)
downloadports-eb7994bdff58220d8bdd2021a5f9e0c0091e99e2.tar.gz
ports-eb7994bdff58220d8bdd2021a5f9e0c0091e99e2.zip
Notes
Diffstat (limited to 'www/seamonkey-i18n')
-rw-r--r--www/seamonkey-i18n/Makefile86
-rw-r--r--www/seamonkey-i18n/Makefile.lang82
-rw-r--r--www/seamonkey-i18n/Makefile.option29
-rw-r--r--www/seamonkey-i18n/distinfo44
-rw-r--r--www/seamonkey-i18n/pkg-descr3
5 files changed, 244 insertions, 0 deletions
diff --git a/www/seamonkey-i18n/Makefile b/www/seamonkey-i18n/Makefile
new file mode 100644
index 000000000000..7f94848e92b2
--- /dev/null
+++ b/www/seamonkey-i18n/Makefile
@@ -0,0 +1,86 @@
+# New ports collection makefile for: firefox3-i18n
+# Date created: 28 May 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= seamonkey-i18n
+PORTVERSION= 2.2
+CATEGORIES= www
+MASTER_SITE_SUBDIR= seamonkey/releases/${PORTVERSION}/langpack
+PKGNAMEPREFIX=
+DISTFILES= ${SEAMONKEY_I18N_:S/$/.langpack.xpi/:S/^/seamonkey-${PORTVERSION}./}
+DIST_SUBDIR= xpi/${DISTNAME}
+
+MAINTAINER= gecko@FreeBSD.org
+COMMENT= Localized interface for SeaMonkey 2.2
+
+EXTRACT_DEPENDS= zip:${PORTSDIR}/archivers/zip
+
+USE_SEAMONKEY= yes
+USE_XPI= *seamonkey
+
+USE_SUBMAKE= yes
+
+WDIR= langpack-*@seamonkey.mozilla.org
+
+XPI_DISTNAMES= ${SEAMONKEY_I18N_}
+
+.ifndef WITHOUT_SWITCHER
+RUN_DEPENDS+= xpi-quick-locale-switcher>=0:${PORTSDIR}/www/xpi-quick-locale-switcher
+.endif
+
+.include "${.CURDIR}/Makefile.option"
+.include <bsd.port.options.mk>
+.include "${.CURDIR}/Makefile.lang"
+
+SEAMONKEY_I18N_?= ${SEAMONKEY_I18N}
+
+.for dist in ${XPI_DISTNAMES}
+XPI_ID_${dist}= langpack-${dist}@seamonkey.mozilla.org
+XPI_FILES_${dist}= chrome.manifest install.rdf chrome/${dist}.jar
+XPI_DIRS_${dist}= chrome
+.endfor
+
+pre-everything::
+ @${ECHO_CMD}
+ @${ECHO_CMD} "Please define SEAMONKEY_I18N_ALL to install all languages."
+ @${ECHO_CMD}
+ @${MKDIR} ${WRKSRC}
+
+do-extract:
+ @for lang in ${SEAMONKEY_I18N_}; do \
+ if ! (${EXTRACT_CMD} ${_DISTDIR}/seamonkey-${PORTVERSION}.$$lang.langpack.xpi -d ${WRKSRC}/langpack-$$lang@seamonkey.mozilla.org);\
+ then \
+ exit 1; \
+ fi; \
+ cd ${WRKSRC}/langpack-$$lang@seamonkey.mozilla.org/chrome; \
+ ${LOCALBASE}/bin/zip -r $$lang.jar $$lang; \
+ done
+
+do-install:
+ @${INSTALL} -d ${XPI_LIBDIR} ${XPI_SLDIRS_ALL}
+ @${CP} -R ${WRKSRC}/ ${XPI_LIBDIR}/
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${XPI_LIBDIR}/${WDIR}/
+ @${CHMOD} -R a+rX,go-w ${XPI_LIBDIR}/${WDIR}/
+ @for _dir in ${XPI_LINKFARMS} ; { ${LN} -sf ${XPI_LIBDIR}/${WDIR} $$_dir/ ${_Q} ; }
+ @${ECHO_CMD} '@exec ${INSTALL} -d ${XPI_SLDIRS_ALL:S,^${PREFIX},%D,}' ${_A}
+ @${ECHO_CMD} '@exec for _dir in ${XPI_LINKFARMS} ; { \
+ ${LN} -sf ${XPI_LIBDIR}/${WDIR} $$_dir/ ${_Q}; }' ${_A}
+ @${ECHO_CMD} '@unexec for _dir in ${XPI_LINKFARMS} ${XPI_LIBDIR}; { ${RM} -fR $$_dir/${WDIR} ; }' ${_A}
+
+ @${ECHO_CMD} '@unexec ${RMDIR} ${XPI_DIRS_TRY:S,^,%D/,} ${_Q}' ${_A}
+
+post-patch:
+ ${FIND} ${WRKSRC} -name install.rdf -print0 | \
+ ${XARGS} -0L1 ${REINPLACE_CMD} -i '' -e '/<?xml/,$$!d'
+
+List-Langs:
+ @fetch -o- "http://releases.mozilla.org/pub/mozilla.org/seamonkey/releases/${PORTVERSION}/langpack"|\
+ ${PERL} -ne 'if(/.*href="seamonkey-${PORTVERSION}.([a-zA-Z-]+).langpack.xpi"/){print "$$1\n"}' |\
+ ${AWK} 'BEGIN{ORS=" "}{print $1}END{printf "\nNumber of languages: %d\n",NR}'
+
+.include "${.CURDIR}/../xpi-adblock/Makefile.xpi"
+
+.include <bsd.port.mk>
diff --git a/www/seamonkey-i18n/Makefile.lang b/www/seamonkey-i18n/Makefile.lang
new file mode 100644
index 000000000000..84220225cc94
--- /dev/null
+++ b/www/seamonkey-i18n/Makefile.lang
@@ -0,0 +1,82 @@
+# New ports collection makefile.lang for: firefox3-i18n
+# Date created: 30 Nov 2008
+# Whom: Koji Yokota <yokota@res.otaru-uc.ac.jp>
+#
+# $FreeBSD$
+#
+# Currently, the following 22 languages are supported.
+#
+SEAMONKEY_I18N_ALL_= ca cs de en-GB en-US es-AR es-ES \
+ fi fr hu it ja-JP-mac ja lt nb-NO nl pl \
+ pt-PT ru sk sv-SE tr
+
+.if defined(SEAMONKEY_I18N_ALL) || (defined(PACKAGE_BUILDING) && !exists(${OPTIONSFILE})) || make(makesum)
+SEAMONKEY_I18N= ${SEAMONKEY_I18N_ALL_}
+.else
+.ifndef WITHOUT_LANG_CA
+SEAMONKEY_I18N+= ca
+.endif
+.ifndef WITHOUT_LANG_CS
+SEAMONKEY_I18N+= cs
+.endif
+.ifndef WITHOUT_LANG_DE
+SEAMONKEY_I18N+= de
+.endif
+.ifndef WITHOUT_LANG_GB
+SEAMONKEY_I18N+= en-GB
+.endif
+.ifndef WITHOUT_LANG_US
+SEAMONKEY_I18N+= en-US
+.endif
+.ifndef WITHOUT_LANG_SA
+SEAMONKEY_I18N+= es-AR
+.endif
+.ifndef WITHOUT_LANG_ES
+SEAMONKEY_I18N+= es-ES
+.endif
+.ifndef WITHOUT_LANG_FI
+SEAMONKEY_I18N+= fi
+.endif
+.ifndef WITHOUT_LANG_FR
+SEAMONKEY_I18N+= fr
+.endif
+.ifndef WITHOUT_LANG_HU
+SEAMONKEY_I18N+= hu
+.endif
+.ifndef WITHOUT_LANG_IT
+SEAMONKEY_I18N+= it
+.endif
+.ifndef WITHOUT_LANG_JP
+SEAMONKEY_I18N+= ja-JP-mac
+.endif
+.ifndef WITHOUT_LANG_JA
+SEAMONKEY_I18N+= ja
+.endif
+.ifndef WITHOUT_LANG_LT
+SEAMONKEY_I18N+= lt
+.endif
+.ifndef WITHOUT_LANG_NB
+SEAMONKEY_I18N+= nb-NO
+.endif
+.ifndef WITHOUT_LANG_NL
+SEAMONKEY_I18N+= nl
+.endif
+.ifndef WITHOUT_LANG_PL
+SEAMONKEY_I18N+= pl
+.endif
+.ifndef WITHOUT_LANG_PT
+SEAMONKEY_I18N+= pt-PT
+.endif
+.ifndef WITHOUT_LANG_RU
+SEAMONKEY_I18N+= ru
+.endif
+.ifndef WITHOUT_LANG_SK
+SEAMONKEY_I18N+= sk
+.endif
+.ifndef WITHOUT_LANG_SE
+SEAMONKEY_I18N+= sv-SE
+.endif
+.ifndef WITHOUT_LANG_TR
+SEAMONKEY_I18N+= tr
+.endif
+.endif
diff --git a/www/seamonkey-i18n/Makefile.option b/www/seamonkey-i18n/Makefile.option
new file mode 100644
index 000000000000..ba50a7757952
--- /dev/null
+++ b/www/seamonkey-i18n/Makefile.option
@@ -0,0 +1,29 @@
+# New ports collection makefile.option for: firefox3-i18n
+# Date created: 30 Nov 2008
+# Whom: Koji Yokota <yokota@res.otaru-uc.ac.jp>
+#
+# $FreeBSD$
+#
+
+OPTIONS= LANG_CA "Catalan" off \
+ LANG_CS "Czech" off \
+ LANG_NL "Dutch" off \
+ LANG_DE "German" on \
+ LANG_GB "English GB" off \
+ LANG_US "English US" off \
+ LANG_FI "Finnish" off \
+ LANG_FR "French" on \
+ LANG_HU "Hungarian" on \
+ LANG_IT "Italian" on \
+ LANG_JA "Japanese" off \
+ LANG_JP "Japanese (ja-JP-mac)" off \
+ LANG_LT "Lithuanian" off \
+ LANG_NB "Norwegian" off \
+ LANG_PL "Polish" off \
+ LANG_PT "Portuguese" off \
+ LANG_RU "Russian" on \
+ LANG_ES "Spanish" on \
+ LANG_SA "Spanish (Argentina)" off \
+ LANG_SE "Swedish" off \
+ LANG_SK "Slovak" off \
+ LANG_TR "Turkish" off
diff --git a/www/seamonkey-i18n/distinfo b/www/seamonkey-i18n/distinfo
new file mode 100644
index 000000000000..f6486ffafa4e
--- /dev/null
+++ b/www/seamonkey-i18n/distinfo
@@ -0,0 +1,44 @@
+SHA256 (xpi/seamonkey-i18n-2.2/seamonkey-2.2.ca.langpack.xpi) = 433a6e1dea81a1dbe9fc5f0e360845affb71dec9e3c5a669cc355281f17d70d9
+SIZE (xpi/seamonkey-i18n-2.2/seamonkey-2.2.ca.langpack.xpi) = 811514
+SHA256 (xpi/seamonkey-i18n-2.2/seamonkey-2.2.cs.langpack.xpi) = 666d504cf2d216a7a8de8a13898719da89a42166e4ee1d4c2d2bfcb4c9e39b6e
+SIZE (xpi/seamonkey-i18n-2.2/seamonkey-2.2.cs.langpack.xpi) = 814944
+SHA256 (xpi/seamonkey-i18n-2.2/seamonkey-2.2.de.langpack.xpi) = 13c3f08bcda947e5c20111a73bee995d5ac8bd97defd8ad235530b61d75de72a
+SIZE (xpi/seamonkey-i18n-2.2/seamonkey-2.2.de.langpack.xpi) = 857283
+SHA256 (xpi/seamonkey-i18n-2.2/seamonkey-2.2.en-GB.langpack.xpi) = 8133dc83554f01712330682c2b269ccb2917ee3064ef7394ef9f82db26845932
+SIZE (xpi/seamonkey-i18n-2.2/seamonkey-2.2.en-GB.langpack.xpi) = 787529
+SHA256 (xpi/seamonkey-i18n-2.2/seamonkey-2.2.en-US.langpack.xpi) = 8ac1ce65dc5044deabd9e1b49234f448cff3435b0660e42e091ddb611d219cda
+SIZE (xpi/seamonkey-i18n-2.2/seamonkey-2.2.en-US.langpack.xpi) = 786992
+SHA256 (xpi/seamonkey-i18n-2.2/seamonkey-2.2.es-AR.langpack.xpi) = 4db1673c306b821dca7de124415b4b92c339a076bc7cd38892ae06927659c982
+SIZE (xpi/seamonkey-i18n-2.2/seamonkey-2.2.es-AR.langpack.xpi) = 813118
+SHA256 (xpi/seamonkey-i18n-2.2/seamonkey-2.2.es-ES.langpack.xpi) = 08158721a1122ad6a74f688792e5f7e6e33ce078e1118dd8f13386da6eda6bd9
+SIZE (xpi/seamonkey-i18n-2.2/seamonkey-2.2.es-ES.langpack.xpi) = 785711
+SHA256 (xpi/seamonkey-i18n-2.2/seamonkey-2.2.fi.langpack.xpi) = a1350aa978c30a71f5ea2a7983bf2bb3f27ad46ad2572d355b565664ebe66804
+SIZE (xpi/seamonkey-i18n-2.2/seamonkey-2.2.fi.langpack.xpi) = 807217
+SHA256 (xpi/seamonkey-i18n-2.2/seamonkey-2.2.fr.langpack.xpi) = fcac0a2c51cf193fa2c712670a6c73e94ed58588ddd8dc0ad3e708b777f81842
+SIZE (xpi/seamonkey-i18n-2.2/seamonkey-2.2.fr.langpack.xpi) = 896104
+SHA256 (xpi/seamonkey-i18n-2.2/seamonkey-2.2.hu.langpack.xpi) = 95a1e3f685b74a8d655bdeec7bdb7a8ce88699dff9432483b5cadab3bbe10982
+SIZE (xpi/seamonkey-i18n-2.2/seamonkey-2.2.hu.langpack.xpi) = 827308
+SHA256 (xpi/seamonkey-i18n-2.2/seamonkey-2.2.it.langpack.xpi) = 28e7b90ff8d7596d7fca6c253d8fd2b1fc9464217cb7fe1a86a4ae9b832a1f8c
+SIZE (xpi/seamonkey-i18n-2.2/seamonkey-2.2.it.langpack.xpi) = 739672
+SHA256 (xpi/seamonkey-i18n-2.2/seamonkey-2.2.ja-JP-mac.langpack.xpi) = a83857fdebb8df144e725ccbc399e68447dc887d3539c27be4c2e5dd8ed43796
+SIZE (xpi/seamonkey-i18n-2.2/seamonkey-2.2.ja-JP-mac.langpack.xpi) = 885812
+SHA256 (xpi/seamonkey-i18n-2.2/seamonkey-2.2.ja.langpack.xpi) = ad3d03f42747427c3c862a6a30cb4b513a66fb21a8fee778cc56f3f3a013761e
+SIZE (xpi/seamonkey-i18n-2.2/seamonkey-2.2.ja.langpack.xpi) = 861377
+SHA256 (xpi/seamonkey-i18n-2.2/seamonkey-2.2.lt.langpack.xpi) = d129bc0278ca8637df4fe377c29ffcc687d2d20b4de35b7144d83508bfeb6713
+SIZE (xpi/seamonkey-i18n-2.2/seamonkey-2.2.lt.langpack.xpi) = 959540
+SHA256 (xpi/seamonkey-i18n-2.2/seamonkey-2.2.nb-NO.langpack.xpi) = 15818961fa34bc4610fcce26f8bd8885495f030d2ddf5d3f05fa0ee69aafbf96
+SIZE (xpi/seamonkey-i18n-2.2/seamonkey-2.2.nb-NO.langpack.xpi) = 805675
+SHA256 (xpi/seamonkey-i18n-2.2/seamonkey-2.2.nl.langpack.xpi) = 34385a5ae09d976b7124366cea2304ce6b4489119c337b175fb9340529324a76
+SIZE (xpi/seamonkey-i18n-2.2/seamonkey-2.2.nl.langpack.xpi) = 804311
+SHA256 (xpi/seamonkey-i18n-2.2/seamonkey-2.2.pl.langpack.xpi) = 44e0e2883601f7a71c64e8fad1e5653904dab5f25834cc96b479f7d3efa73f01
+SIZE (xpi/seamonkey-i18n-2.2/seamonkey-2.2.pl.langpack.xpi) = 825438
+SHA256 (xpi/seamonkey-i18n-2.2/seamonkey-2.2.pt-PT.langpack.xpi) = d733234dc5b11ea32b611d54efefea31eea331d21555db91712f9810d1f2493c
+SIZE (xpi/seamonkey-i18n-2.2/seamonkey-2.2.pt-PT.langpack.xpi) = 842511
+SHA256 (xpi/seamonkey-i18n-2.2/seamonkey-2.2.ru.langpack.xpi) = 15700e56b4ead24fb08c8a65b615343a56f364dee311dc5e808f1055c9277c5a
+SIZE (xpi/seamonkey-i18n-2.2/seamonkey-2.2.ru.langpack.xpi) = 889516
+SHA256 (xpi/seamonkey-i18n-2.2/seamonkey-2.2.sk.langpack.xpi) = a25e78e2c9e682910bd6fcdc7639ac7902d07f99ac9ccb85e567bb28606dcfcd
+SIZE (xpi/seamonkey-i18n-2.2/seamonkey-2.2.sk.langpack.xpi) = 840212
+SHA256 (xpi/seamonkey-i18n-2.2/seamonkey-2.2.sv-SE.langpack.xpi) = 83b5e7572ed550e299b2813a0826d3760e18fd49b56a3e852f3be32cd133a1fc
+SIZE (xpi/seamonkey-i18n-2.2/seamonkey-2.2.sv-SE.langpack.xpi) = 869508
+SHA256 (xpi/seamonkey-i18n-2.2/seamonkey-2.2.tr.langpack.xpi) = 0bb342f7845493c35f743b3f8589e9fa0d7ed1c283f400eeb929617c13f26f56
+SIZE (xpi/seamonkey-i18n-2.2/seamonkey-2.2.tr.langpack.xpi) = 805151
diff --git a/www/seamonkey-i18n/pkg-descr b/www/seamonkey-i18n/pkg-descr
new file mode 100644
index 000000000000..15681029c3b6
--- /dev/null
+++ b/www/seamonkey-i18n/pkg-descr
@@ -0,0 +1,3 @@
+Language packs for SeaMonkey 2.1
+
+WWW: http://www.seamonkey-project.org/releases/#langpacks