aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-05-18 22:09:26 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-05-18 22:09:26 +0000
commitf74495e675a49a541f2297c5d349b773692fd581 (patch)
tree0b6881b4f7295b182500d4755968b2711f67b9e3 /www/seamonkey/Makefile
parent15a2396d5047b6e8be9934e20bdf5168e598ed2d (diff)
downloadports-f74495e675a49a541f2297c5d349b773692fd581.tar.gz
ports-f74495e675a49a541f2297c5d349b773692fd581.zip
Notes
Diffstat (limited to 'www/seamonkey/Makefile')
-rw-r--r--www/seamonkey/Makefile23
1 files changed, 20 insertions, 3 deletions
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 003497d49bba..b714615e4128 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -7,8 +7,8 @@
PORTNAME= mozilla
PORTVERSION= 1.0.rc2
-PORTEPOCH= 1
PORTREVISION= 1
+PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
http://people.FreeBSD.org/~marcus/:local
@@ -49,8 +49,6 @@ CONFIGURE_ARGS= \
--enable-double-buffer \
--enable-dtd-debug \
--enable-jsd \
- --enable-ldap \
- --enable-mailnews \
--enable-mathml \
--disable-md \
--disable-optimize \
@@ -66,6 +64,25 @@ CONFIGURE_ARGS= \
--with-system-mng=${LOCALBASE} \
--with-system-png=${LOCALBASE} \
--with-pthreads
+
+# LDAP is only used by mail and news so disable both together
+.if defined(WITHOUT_MAILNEWS)
+CONFIGURE_ARGS+= --disable-ldap --disable-mailnews
+PLIST_SUB+= MOZILLAMAILNEWS="@comment "
+PLIST_SUB+= MOZILLALDAP="@comment "
+.else
+# mail and news desired, but not LDAP
+.if defined(WITHOUT_LDAP)
+CONFIGURE_ARGS+= --disable-ldap --enable-mailnews
+PLIST_SUB+= MOZILLAMAILNEWS=""
+PLIST_SUB+= MOZILLALDAP="@comment "
+.else
+CONFIGURE_ARGS+= --enable-ldap --enable-mailnews
+PLIST_SUB+= MOZILLAMAILNEWS=""
+PLIST_SUB+= MOZILLALDAP=""
+.endif
+.endif
+
.if !defined(WITHOUT_CHATZILLA)
CONFIGURE_ARGS+= --enable-extensions=default,irc,xmlterm
PLIST_SUB+= CHATZILLA=""