aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey2-i18n
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2009-12-14 12:31:01 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2009-12-14 12:31:01 +0000
commit22252655e9b554f9da4939275c33161e6f849257 (patch)
tree038acbcd1d9d7eb61a5f9363f0f133338f5ff0ac /www/seamonkey2-i18n
parentd24089b404cf98763039cdda65e788d0a3fa2480 (diff)
Notes
Diffstat (limited to 'www/seamonkey2-i18n')
-rw-r--r--www/seamonkey2-i18n/Makefile87
-rw-r--r--www/seamonkey2-i18n/Makefile.lang69
-rw-r--r--www/seamonkey2-i18n/Makefile.option25
-rw-r--r--www/seamonkey2-i18n/distinfo57
-rw-r--r--www/seamonkey2-i18n/pkg-descr3
5 files changed, 241 insertions, 0 deletions
diff --git a/www/seamonkey2-i18n/Makefile b/www/seamonkey2-i18n/Makefile
new file mode 100644
index 000000000000..4d71e0247bba
--- /dev/null
+++ b/www/seamonkey2-i18n/Makefile
@@ -0,0 +1,87 @@
+# New ports collection makefile for: firefox3-i18n
+# Date created: 28 May 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= seamonkey2-i18n
+PORTVERSION= 2.0
+CATEGORIES= www
+MASTER_SITE_SUBDIR= seamonkey/releases/${PORTVERSION}/langpack
+PKGNAMEPREFIX=
+DISTFILES= ${SEAMONKEY_I18N_:S/$/.langpack.xpi/:S/^/seamonkey-${PORTVERSION}./}
+DIST_SUBDIR= xpi/${DISTNAME}
+
+MAINTAINER= gecko@FreeBSD.org
+COMMENT= Localized interface for SeaMonkey 2
+
+USE_XPI= *seamonkey
+
+USE_SUBMAKE= yes
+
+WDIR= langpack-*@seamonkey.mozilla.org
+
+XPI_DISTNAMES= ${SEAMONKEY_I18N_}
+
+.include "${.CURDIR}/Makefile.option"
+.include <bsd.port.pre.mk>
+
+.ifndef WITHOUT_SWITCHER
+RUN_DEPENDS+= xpi-quick-locale-switcher>=0:${PORTSDIR}/www/xpi-quick-locale-switcher
+.endif
+
+.include "${.CURDIR}/Makefile.lang"
+
+SEAMONKEY_I18N_?= ${SEAMONKEY_I18N}
+
+.for dist in ${XPI_DISTNAMES}
+XPI_ID_${dist}= langpack-${dist}@seamonkey.mozilla.org
+XPI_FILES_${dist}= chrome.manifest install.rdf chrome/${dist}.jar
+XPI_DIRS_${dist}= chrome
+.endfor
+
+pre-everything::
+ @${ECHO_CMD}
+ @${ECHO_CMD} "Please define SEAMONKEY_I18N_ALL to install all languages."
+ @${ECHO_CMD}
+ @${MKDIR} ${WRKSRC}
+
+do-extract:
+ @for lang in ${SEAMONKEY_I18N_}; do \
+ if ! (${EXTRACT_CMD} ${_DISTDIR}/seamonkey-${PORTVERSION}.$$lang.langpack.xpi -d ${WRKSRC}/langpack-$$lang@seamonkey.mozilla.org);\
+ then \
+ exit 1; \
+ fi \
+ done
+
+.if !exists(${OPTIONSFILE}) && !defined(PACKAGE_BUILDING)
+pre-configure: config
+.endif
+
+do-install:
+ @${INSTALL} -d ${XPI_LIBDIR} ${XPI_SLDIRS_ALL}
+ @${CP} -R ${WRKSRC}/ ${XPI_LIBDIR}/
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${XPI_LIBDIR}/${WDIR}/
+ @${CHMOD} -R a+rX,go-w ${XPI_LIBDIR}/${WDIR}/
+ @for _dir in ${XPI_LINKFARMS} ; { ${LN} -sf ${XPI_LIBDIR}/${WDIR} $$_dir/ ${_Q} ; }
+ @${ECHO_CMD} '@exec ${INSTALL} -d ${XPI_SLDIRS_ALL:S,^${PREFIX},%D,}' ${_A}
+ @${ECHO_CMD} '@exec for _dir in ${XPI_LINKFARMS} ; { \
+ ${LN} -sf ${XPI_LIBDIR}/${WDIR} $$_dir/ ${_Q}; }' ${_A}
+ @${ECHO_CMD} '@unexec for _dir in ${XPI_LINKFARMS} ${XPI_LIBDIR}; { ${RM} -fR $$_dir/${WDIR} ; }' ${_A}
+
+ @${ECHO_CMD} '@unexec ${RMDIR} ${XPI_DIRS_TRY:S,^,%D/,} ${_Q}' ${_A}
+
+post-patch:
+ ${FIND} ${WRKSRC} -name install.rdf -print0 | \
+ ${XARGS} -0L1 ${REINPLACE_CMD} -i '' -e '/<?xml/,$$!d' \
+ -e 's/\(langpack\)/\13/'
+
+List-Langs:
+ @fetch -o- "http://releases.mozilla.org/pub/mozilla.org/seamonkey/releases/${PORTVERSION}/langpack"|\
+ ${PERL} -ne 'if(/.*href="seamonkey-2.0.([a-zA-Z-]+).langpack.xpi"/){print "$$1\n"}' |\
+ ${AWK} 'BEGIN{ORS=" "}{print $1}END{printf "\nNumber of languages: %d\n",NR}'
+
+.include "${.CURDIR}/../xpi-adblock/Makefile.xpi"
+
+.include <bsd.port.post.mk>
diff --git a/www/seamonkey2-i18n/Makefile.lang b/www/seamonkey2-i18n/Makefile.lang
new file mode 100644
index 000000000000..57ea6fc13cfb
--- /dev/null
+++ b/www/seamonkey2-i18n/Makefile.lang
@@ -0,0 +1,69 @@
+# New ports collection makefile.lang for: firefox3-i18n
+# Date created: 30 Nov 2008
+# Whom: Koji Yokota <yokota@res.otaru-uc.ac.jp>
+#
+# $FreeBSD$
+#
+# Currently, the following 17 languages are supported.
+#
+SEAMONKEY_I18N_ALL_= be ca cs de es-AR es-ES fr gl hu \
+ ka lt nb-NO nl pl pt-PT ru sk tr
+
+.if defined(SEAMONKEY_I18N_ALL) || defined(PACKAGE_BUILDING) || target(package)
+SEAMONKEY_I18N= ${SEAMONKEY_I18N_ALL_}
+.else
+.ifndef WITHOUT_LANG_BE
+SEAMONKEY_I18N+= be
+.endif
+.ifndef WITHOUT_LANG_CA
+SEAMONKEY_I18N+= ca
+.endif
+.ifndef WITHOUT_LANG_CS
+SEAMONKEY_I18N+= cs
+.endif
+.ifndef WITHOUT_LANG_DE
+SEAMONKEY_I18N+= de
+.endif
+.ifndef WITHOUT_LANG_SA
+SEAMONKEY_I18N+= es-AR
+.endif
+.ifndef WITHOUT_LANG_ES
+SEAMONKEY_I18N+= es-ES
+.endif
+.ifndef WITHOUT_LANG_FR
+SEAMONKEY_I18N+= fr
+.endif
+.ifndef WITHOUT_LANG_GL
+SEAMONKEY_I18N+= gl
+.endif
+.ifndef WITHOUT_LANG_HU
+SEAMONKEY_I18N+= hu
+.endif
+.ifndef WITHOUT_LANG_KA
+SEAMONKEY_I18N+= ka
+.endif
+.ifndef WITHOUT_LANG_LT
+SEAMONKEY_I18N+= lt
+.endif
+.ifndef WITHOUT_LANG_NB
+SEAMONKEY_I18N+= nb-NO
+.endif
+.ifndef WITHOUT_LANG_NL
+SEAMONKEY_I18N+= nl
+.endif
+.ifndef WITHOUT_LANG_PL
+SEAMONKEY_I18N+= pl
+.endif
+.ifndef WITHOUT_LANG_PT
+SEAMONKEY_I18N+= pt-PT
+.endif
+.ifndef WITHOUT_LANG_RU
+SEAMONKEY_I18N+= ru
+.endif
+.ifndef WITHOUT_LANG_SK
+SEAMONKEY_I18N+= sk
+.endif
+.ifndef WITHOUT_LANG_TR
+SEAMONKEY_I18N+= tr
+.endif
+.endif
diff --git a/www/seamonkey2-i18n/Makefile.option b/www/seamonkey2-i18n/Makefile.option
new file mode 100644
index 000000000000..ff62ab3e4ba7
--- /dev/null
+++ b/www/seamonkey2-i18n/Makefile.option
@@ -0,0 +1,25 @@
+# New ports collection makefile.option for: firefox3-i18n
+# Date created: 30 Nov 2008
+# Whom: Koji Yokota <yokota@res.otaru-uc.ac.jp>
+#
+# $FreeBSD$
+#
+
+OPTIONS= LANG_BE "Byelorussian" off \
+ LANG_CA "Catalan" off \
+ LANG_CS "Czech" off \
+ LANG_NL "Dutch" off \
+ LANG_GL "Galician" off \
+ LANG_KA "Georgian" off \
+ LANG_DE "German" on \
+ LANG_FR "French" on \
+ LANG_HU "Hungarian" off \
+ LANG_LT "Lithuanian" off \
+ LANG_NB "Norwegian" off \
+ LANG_PL "Polish" off \
+ LANG_PT "Portuguese" off \
+ LANG_RU "Russian" on \
+ LANG_ES "Spanish" on \
+ LANG_SA "Spanish (Argentina)" off \
+ LANG_SK "Slovak" off \
+ LANG_TR "Turkish" off
diff --git a/www/seamonkey2-i18n/distinfo b/www/seamonkey2-i18n/distinfo
new file mode 100644
index 000000000000..f3e7c7c2d973
--- /dev/null
+++ b/www/seamonkey2-i18n/distinfo
@@ -0,0 +1,57 @@
+MD5 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.be.langpack.xpi) = 586b28db226ded72211353e5d98903c9
+SHA256 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.be.langpack.xpi) = bfd965678c472d93d947a230cd6d6f9366e3547590d28bf0b7ae64730af8b924
+SIZE (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.be.langpack.xpi) = 493089
+MD5 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.ca.langpack.xpi) = 8c69da31324c509bbaf2a15096f09592
+SHA256 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.ca.langpack.xpi) = 5efe47942881127a6f17bd7d243748541f7ccf413a1fc03cc0a81d9fd2a1c2ea
+SIZE (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.ca.langpack.xpi) = 498856
+MD5 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.cs.langpack.xpi) = 087aad967a11450f9504458caf2cc7cd
+SHA256 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.cs.langpack.xpi) = b992c6a2039e4f09a056f8295728dcbab20ae941571224d3c08b7ef34f0bc6f5
+SIZE (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.cs.langpack.xpi) = 533787
+MD5 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.de.langpack.xpi) = 2866729ac991218f456968634be5c340
+SHA256 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.de.langpack.xpi) = ead560daf84a5d54c7e29fbb4732783f39cb77eed7275b247d2a49d01841711e
+SIZE (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.de.langpack.xpi) = 548440
+MD5 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.es-AR.langpack.xpi) = bf4715556958592f82b4b64c343c1b40
+SHA256 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.es-AR.langpack.xpi) = 512979f23f32ccdf8e3a83f7347992ff8324dc29dc28839334ec8ef9914402f9
+SIZE (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.es-AR.langpack.xpi) = 500162
+MD5 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.es-ES.langpack.xpi) = b589ed1dd5ae34cc66824c49eb278163
+SHA256 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.es-ES.langpack.xpi) = 78047822155ac06e58689e9bb2a56c78d0c126dfc2cd4d2612315325cc0264c9
+SIZE (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.es-ES.langpack.xpi) = 519758
+MD5 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.fr.langpack.xpi) = 1e3605894f1a13870505ea3995c53cbe
+SHA256 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.fr.langpack.xpi) = 5820f519fbafe4c4922e7520b1037d655140735dd0139effe1966f3e4cfa54e7
+SIZE (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.fr.langpack.xpi) = 857289
+MD5 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.gl.langpack.xpi) = c8a090764d8a7f3e4e5c0de428b0b702
+SHA256 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.gl.langpack.xpi) = 487899b352be95f4db1ab1902fd626ea42d60009c701be21f70b3852728d8c4c
+SIZE (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.gl.langpack.xpi) = 506673
+MD5 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.hu.langpack.xpi) = fceb11ae5e3f7208ee7f54dfd36c0424
+SHA256 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.hu.langpack.xpi) = 92315f0a8dbc2b670d6790190e6d77cd56070bf5cc4bbbc4c360de7342ac3b75
+SIZE (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.hu.langpack.xpi) = 1264809
+MD5 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.ka.langpack.xpi) = cd51bed1e2bedad34919259338846e5b
+SHA256 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.ka.langpack.xpi) = 47d16e52c9a6949cb0439f061ac3a75b6b50db745c2cfe7456de6e84c4137274
+SIZE (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.ka.langpack.xpi) = 769068
+MD5 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.lt.langpack.xpi) = f9855edc07e120a924f0e40ffed714da
+SHA256 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.lt.langpack.xpi) = 967e4833f6db52522bd620a5b62475875f9fff74b6cf395b401e2b76f3fd8349
+SIZE (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.lt.langpack.xpi) = 892103
+MD5 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.nb-NO.langpack.xpi) = 80abe566b750a394aedf306377258ff5
+SHA256 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.nb-NO.langpack.xpi) = 9f4ca6bcdd5b291de7a432b07a1ea727a2d3d99b2a5be6c242b3059816427027
+SIZE (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.nb-NO.langpack.xpi) = 501910
+MD5 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.nl.langpack.xpi) = 9172c38b5b9e6d8845f1d8f9423e81bf
+SHA256 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.nl.langpack.xpi) = 1d0b6d1348cff9fd5c44dc5570917e26747635dd42a13bb9506b75394631da6e
+SIZE (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.nl.langpack.xpi) = 1521294
+MD5 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.pl.langpack.xpi) = 88e34b989c125b489e9dc048a8c87827
+SHA256 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.pl.langpack.xpi) = d545f6392477727416dd995a995b92a359ab677dac779380cb6d2851e542e772
+SIZE (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.pl.langpack.xpi) = 1603813
+MD5 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.pt-PT.langpack.xpi) = 8f70f3ac772739d3a9e1736fb328feff
+SHA256 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.pt-PT.langpack.xpi) = 66e4073f251d270ad8e24ea5d20b0d8ac6a7f99cd49498ad09fb80c87b813e04
+SIZE (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.pt-PT.langpack.xpi) = 714698
+MD5 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.ru.langpack.xpi) = 171320d0a32a2992737996891f6b1b09
+SHA256 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.ru.langpack.xpi) = f028ac5f91801062675d0301e7976b0f3e2632b9907c20efa4b4374f5569bdc7
+SIZE (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.ru.langpack.xpi) = 1091988
+MD5 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.sk.langpack.xpi) = e4f4bc8bfb3cb07a5057feb5025f655f
+SHA256 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.sk.langpack.xpi) = 1f34238d43c0f35fa37c788353b064fa096f1b7cc93acfbde024907e673c9612
+SIZE (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.sk.langpack.xpi) = 1131920
+MD5 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.sv-SE.langpack.xpi) = 18ad749f00cfc2b775e79ee64fb5d749
+SHA256 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.sv-SE.langpack.xpi) = 6d9b1eb3e60827a84b2e30d04b451d63946a4c1efff5d7ac1cfcb2a38ef73314
+SIZE (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.sv-SE.langpack.xpi) = 841590
+MD5 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.tr.langpack.xpi) = eb794af47e466b5fd537de5429115132
+SHA256 (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.tr.langpack.xpi) = 5d0f37494131320263cf0b3084b87469411641061269b251475925fecfa7e2ab
+SIZE (xpi/seamonkey2-i18n-2.0/seamonkey-2.0.tr.langpack.xpi) = 504536
diff --git a/www/seamonkey2-i18n/pkg-descr b/www/seamonkey2-i18n/pkg-descr
new file mode 100644
index 000000000000..42e32d638856
--- /dev/null
+++ b/www/seamonkey2-i18n/pkg-descr
@@ -0,0 +1,3 @@
+Language packs for SeaMonkey 2
+
+WWW: http://www.seamonkey-project.org/releases/#langpacks