aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey2/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-10-22 03:42:24 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-10-22 03:42:24 +0000
commitceab29fa677934f9a8541ad0dc57738aecc8f7f3 (patch)
tree65ac614b19e089b6f45532f0fe3255a3262985f4 /www/seamonkey2/Makefile
parent75b211265108e6b65aec4f7537bc85ce3a70cbd9 (diff)
downloadports-ceab29fa677934f9a8541ad0dc57738aecc8f7f3.tar.gz
ports-ceab29fa677934f9a8541ad0dc57738aecc8f7f3.zip
Notes
Diffstat (limited to 'www/seamonkey2/Makefile')
-rw-r--r--www/seamonkey2/Makefile60
1 files changed, 41 insertions, 19 deletions
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index a4a02764eabb..555e38d6a59e 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= mozilla
-PORTVERSION= 1.2a
+PORTVERSION= 1.2b
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
- http://people.FreeBSD.org/~sobomax/:local
+ http://people.FreeBSD.org/~marcus/:local
MASTER_SITE_SUBDIR= mozilla/releases/${PORTNAME}${PORTVERSION:S/.rc/rc/}/src \
marcus/:local
DISTFILES= ${PORTNAME}-source-${PORTVERSION:S/.rc/rc/}${EXTRACT_SUFX} \
@@ -18,8 +18,6 @@ DISTFILES= ${PORTNAME}-source-${PORTVERSION:S/.rc/rc/}${EXTRACT_SUFX} \
MAINTAINER= gnome@FreeBSD.org
-NO_LATEST_LINK= yes
-
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
freetype-config:${PORTSDIR}/print/freetype2
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
@@ -31,13 +29,19 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
WITHOUT_CHATZILLA= "Contains a buffer overflow reported at http://online.securityfocus.com/archive/1/270249"
-EXTRACT_AFTER_ARGS= | tar -xf - -X ${FILESDIR}/tar-exclude
-USE_BZIP2= yes
+LATEST_LINK= mozilla-devel
+EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude */CVS/* \
+ --exclude */macbuild/*\
+ --exclude */package/* \
+ --exclude .cvsignore \
+ --exclude makefile.win \
+ --exclude MANIFEST
USE_X_PREFIX= yes
USE_PERL5= yes
USE_GMAKE= yes
USE_GNOMENG= yes
USE_GNOME= orbit gtk12
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= \
--disable-auto-deps \
@@ -60,36 +64,29 @@ CONFIGURE_ARGS= \
--disable-tests \
--disable-xterm-updates \
--enable-xinerama \
- --enable-xft \
+ --enable-xft \
--with-system-jpeg=${LOCALBASE} \
--with-system-mng=${LOCALBASE} \
--with-system-png=${LOCALBASE} \
--with-pthreads
+PLIST= ${WRKDIR}/pkg-plist
# LDAP is only used by mail and news so disable both together
.if defined(WITHOUT_MAILNEWS)
CONFIGURE_ARGS+= --disable-ldap --disable-mailnews
-PLIST_SUB+= MOZILLAMAILNEWS="@comment "
-PLIST_SUB+= MOZILLALDAP="@comment "
.else
# mail and news desired, but not LDAP
.if defined(WITHOUT_LDAP)
CONFIGURE_ARGS+= --disable-ldap --enable-mailnews
-PLIST_SUB+= MOZILLAMAILNEWS=""
-PLIST_SUB+= MOZILLALDAP="@comment "
.else
CONFIGURE_ARGS+= --enable-ldap --enable-mailnews
-PLIST_SUB+= MOZILLAMAILNEWS=""
-PLIST_SUB+= MOZILLALDAP=""
-.endif
+.endif
.endif
.if !defined(WITHOUT_CHATZILLA)
CONFIGURE_ARGS+= --enable-extensions=default,irc,xmlterm
-PLIST_SUB+= CHATZILLA=""
.else
CONFIGURE_ARGS+= --enable-extensions=default,xmlterm
-PLIST_SUB+= CHATZILLA="@comment "
.endif
CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1
@@ -111,9 +108,13 @@ BROKEN= "core dumps on alpha during post-build"
BROKEN="You must upgrade your freetype port to 1.3.1_2 or higher before installing Mozilla. If you have 1.3.1_2 installed, please remove ${LOCALBASE}/include/freetype, then build Mozilla"
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/build/unix/run-mozilla.sh
+
post-build:
${SED} -e "s;@PREFIX@;${PREFIX};g" \
- ${FILESDIR}/mozilla.sh >${WRKSRC}/mozilla
+ ${FILESDIR}/mozilla.sh >${WRKSRC}/mozilla-devel
(cd ${WRKSRC}/dist/bin; \
${SETENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ./regxpcom; \
${SETENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ./regchrome; \
@@ -121,13 +122,34 @@ post-build:
${FIND} ${WRKSRC}/dist/bin -type d | /usr/bin/sort -r | \
${XARGS} ${RMDIR} 2> /dev/null || ${TRUE}
+pre-install:
+ ${TOUCH} -f ${PLIST}
+ ${TEST} ! -x ${PREFIX}/bin/mozilla && ${TEST} ! -L ${PREFIX}/bin/mozilla && \
+ ${ECHO_CMD} bin/mozilla >> ${PLIST}
+ ${ECHO_CMD} bin/mozilla-devel >> ${PLIST}
+ ${TEST} ! -L ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so && \
+ ${ECHO_CMD} lib/browser_plugins/libjavaplugin_oji.so >> ${PLIST}
+ cd ${WRKSRC}/dist/bin && ${FIND} -s * -type f -o -type l | \
+ ${SED} -e 's:^:lib/mozilla-devel/:' >> ${PLIST} \
+ && ${FIND} -d * -type d | \
+ ${SED} -e 's:^:@dirrm lib/mozilla-devel/:' >> ${PLIST}
+ ${ECHO_CMD} @dirrm lib/mozilla-devel >> ${PLIST}
+
do-install:
${MKDIR} ${PREFIX}/lib/mozilla-devel
${CHMOD} 755 ${PREFIX}/lib/mozilla-devel
cd ${WRKSRC}/dist/bin && ${FIND} . | \
cpio -pdm -L -R ${LIBOWN}:${LIBGRP} ${PREFIX}/lib/mozilla-devel
- ${INSTALL_SCRIPT} ${WRKSRC}/mozilla ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/mozilla-devel ${PREFIX}/bin
+ ${TEST} ! -x ${PREFIX}/bin/mozilla && ${TEST} ! -L ${PREFIX}/bin/mozilla && \
+ ${LN} -sf ${PREFIX}/bin/mozilla-devel ${PREFIX}/bin/mozilla
+ ${TEST} ! -d ${PREFIX}/lib/browser_plugins && \
+ ${MKDIR} ${PREFIX}/lib/browser_plugins
+ ${TEST} ! -L ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so && \
${LN} -sf ${LOCALBASE}/jdk1.3.1/jre/plugin/i386/ns600/libjavaplugin_oji.so \
- ${PREFIX}/lib/mozilla-devel/plugins/libjavaplugin_oji.so
+ ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>