aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey2/files
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-06-11 20:34:59 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-06-11 20:34:59 +0000
commitcfe0d5ef4500ca9928d83c64e467fd5c6c345055 (patch)
tree06d7bb516bebbe05a2b01712d9eb8860f38c69d7 /www/seamonkey2/files
parentd3f5608178a765e12aab07066f67875dd7d3f7fd (diff)
downloadports-cfe0d5ef4500ca9928d83c64e467fd5c6c345055.tar.gz
ports-cfe0d5ef4500ca9928d83c64e467fd5c6c345055.zip
Notes
Diffstat (limited to 'www/seamonkey2/files')
-rw-r--r--www/seamonkey2/files/patch-ap38
-rw-r--r--www/seamonkey2/files/patch-security::manager::Makefile.in11
-rw-r--r--www/seamonkey2/files/patch-widget::src::gtksuperwin::gtkmozarea.c66
-rw-r--r--www/seamonkey2/files/patch-widget::src::gtksuperwin::gtkmozarea.h17
4 files changed, 0 insertions, 132 deletions
diff --git a/www/seamonkey2/files/patch-ap b/www/seamonkey2/files/patch-ap
deleted file mode 100644
index 2db3c4707256..000000000000
--- a/www/seamonkey2/files/patch-ap
+++ /dev/null
@@ -1,38 +0,0 @@
---- security/coreconf/config.mk.orig Tue Mar 13 21:00:48 2001
-+++ security/coreconf/config.mk Mon May 14 18:13:01 2001
-@@ -56,7 +56,7 @@
- # each OS release. #
- #######################################################################
-
--ifeq (,$(filter-out BSD_OS NetBSD OS2,$(OS_TARGET)))
-+ifeq (,$(filter-out BSD_OS NetBSD OS2 FreeBSD,$(OS_TARGET)))
- include $(CORE_DEPTH)/coreconf/$(OS_TARGET).mk
- else
- include $(CORE_DEPTH)/coreconf/$(OS_CONFIG).mk
---- security/psm/server/Makefile.orig Fri Mar 30 21:46:06 2001
-+++ security/psm/server/Makefile Mon May 14 18:03:23 2001
-@@ -67,11 +67,11 @@
- endif
- endif
-
--ifeq ($(OS_ARCH), Linux)
-+ifeq ($(OS_ARCH), FreeBSD)
- ifdef USE_PTHREADS
- # Replace OS_LIBS, because the order of libpthread, libdl, and libc are
- # very important. Otherwise you get horrible crashes.
--OS_LIBS = -lpthread -ldl -lc
-+OS_LIBS = -pthread
- endif
- endif
-
-@@ -165,8 +165,8 @@
- XPCOM_LINK_LIBS = -lxpcom
- XPCOM_LIBS += $(DIST)/lib/libz.$(DLL_SUFFIX)
- else
--NSPR_LINK_LIBS = $(NSPR_LIBS)
--XPCOM_LINK_LIBS = $(XPCOM_LIBS)
-+NSPR_LINK_LIBS = -L$(DIST)/lib -lnspr4 -lplc4 -lplds4
-+XPCOM_LINK_LIBS = -lxpcom
- endif
-
- ifndef MOZ_DIST
diff --git a/www/seamonkey2/files/patch-security::manager::Makefile.in b/www/seamonkey2/files/patch-security::manager::Makefile.in
deleted file mode 100644
index 0ddf7c6a12ae..000000000000
--- a/www/seamonkey2/files/patch-security::manager::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- security/manager/Makefile.in.orig Mon Apr 16 00:50:16 2001
-+++ security/manager/Makefile.in Tue May 22 10:10:27 2001
-@@ -44,7 +44,7 @@
- include $(CORE_DEPTH)/coreconf/$(OS_CONFIG).mk
- endif
- include $(CORE_DEPTH)/coreconf/prefix.mk
--CPU_TAG := _$(CPU_ARCH)
-+#CPU_TAG := _$(CPU_ARCH)
- LOADABLE_ROOT_MODULE := $(DLL_PREFIX)nssckbi.$(DLL_SUFFIX)
- CORECONF_OBJDIR:=$(OBJDIR_NAME)
-
diff --git a/www/seamonkey2/files/patch-widget::src::gtksuperwin::gtkmozarea.c b/www/seamonkey2/files/patch-widget::src::gtksuperwin::gtkmozarea.c
deleted file mode 100644
index 25b708dd0495..000000000000
--- a/www/seamonkey2/files/patch-widget::src::gtksuperwin::gtkmozarea.c
+++ /dev/null
@@ -1,66 +0,0 @@
-Patch that fixes a bug with Galeon. Should go after 0.9. Obtained from
-http://bugzilla.mozilla.org/show_bug.cgi?id=79022.
-
-$FreeBSD$
-
---- widget/src/gtksuperwin/gtkmozarea.c.orig Thu May 3 07:11:01 2001
-+++ widget/src/gtksuperwin/gtkmozarea.c Tue May 22 13:46:58 2001
-@@ -25,6 +25,7 @@
- static void gtk_mozarea_unrealize (GtkWidget *widget);
- static void gtk_mozarea_size_allocate (GtkWidget *widget,
- GtkAllocation *allocation);
-+static void gtk_mozarea_destroy (GtkObject *object);
-
- static void
- attach_toplevel_listener(GtkMozArea *mozarea);
-@@ -85,6 +86,8 @@
- widget_class->unrealize = gtk_mozarea_unrealize;
- widget_class->size_allocate = gtk_mozarea_size_allocate;
-
-+ object_class->destroy = gtk_mozarea_destroy;
-+
- parent_class = gtk_type_class(gtk_widget_get_type());
-
- /* set up our signals */
-@@ -112,6 +115,7 @@
- {
- mozarea->superwin = NULL;
- mozarea->toplevel_focus = FALSE;
-+ mozarea->toplevel_window = NULL;
- }
-
- static void
-@@ -179,6 +183,22 @@
- }
- }
-
-+static void
-+gtk_mozarea_destroy(GtkObject *object)
-+{
-+ GtkMozArea *mozarea;
-+
-+ g_return_if_fail(GTK_IS_MOZAREA(object));
-+
-+ mozarea = GTK_MOZAREA(object);
-+
-+ /* remove the filter on the toplevel window */
-+ gdk_window_remove_filter(mozarea->toplevel_window, toplevel_window_filter,
-+ mozarea);
-+
-+ GTK_OBJECT_CLASS(parent_class)->destroy(object);
-+}
-+
- GtkWidget*
- gtk_mozarea_new (GdkWindow *parent_window)
- {
-@@ -220,6 +240,10 @@
- automatically be removed. */
-
- gdk_window_add_filter(gdk_window, toplevel_window_filter, mozarea);
-+
-+ /* save it so that we can remove the filter later */
-+
-+ mozarea->toplevel_window = gdk_window;
- }
-
- /* this function will try to find the real toplevel for a gdk window. */
diff --git a/www/seamonkey2/files/patch-widget::src::gtksuperwin::gtkmozarea.h b/www/seamonkey2/files/patch-widget::src::gtksuperwin::gtkmozarea.h
deleted file mode 100644
index e96a7ea10608..000000000000
--- a/www/seamonkey2/files/patch-widget::src::gtksuperwin::gtkmozarea.h
+++ /dev/null
@@ -1,17 +0,0 @@
-Patch that fixes a bug with Galeon. Should go after 0.9. Obtained from
-http://bugzilla.mozilla.org/show_bug.cgi?id=79022.
-
-$FreeBSD$
-
---- widget/src/gtksuperwin/gtkmozarea.h.orig Thu May 3 07:11:02 2001
-+++ widget/src/gtksuperwin/gtkmozarea.h Tue May 22 17:18:26 2001
-@@ -39,6 +39,9 @@
- GtkWidget widget;
- GdkSuperWin *superwin;
- gboolean toplevel_focus;
-+
-+ /* store away the toplevel window */
-+ GdkWindow *toplevel_window;
- };
-
- struct _GtkMozAreaClass