aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey2
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2010-10-26 19:18:53 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2010-10-26 19:18:53 +0000
commit280f42698d4da61ac26a204cd6d4406d79519969 (patch)
treec9e19cc058186ba14f09a6cb10447bdde0c84539 /www/seamonkey2
parent6f05697fa11f81c9faf3b6c1ce67eeef6c299773 (diff)
Notes
Diffstat (limited to 'www/seamonkey2')
-rw-r--r--www/seamonkey2/Makefile1
-rw-r--r--www/seamonkey2/files/patch-mozilla-media-libsydneyaudio-src-sydney_audio_oss.c33
2 files changed, 34 insertions, 0 deletions
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index 338f06f08fd3..f7678e633733 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= seamonkey
DISTVERSION= 2.0.9
+PORTREVISION= 1
CATEGORIES?= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
MASTER_SITE_SUBDIR= seamonkey/releases/${DISTVERSION}/source
diff --git a/www/seamonkey2/files/patch-mozilla-media-libsydneyaudio-src-sydney_audio_oss.c b/www/seamonkey2/files/patch-mozilla-media-libsydneyaudio-src-sydney_audio_oss.c
new file mode 100644
index 000000000000..e096cc70c2e8
--- /dev/null
+++ b/www/seamonkey2/files/patch-mozilla-media-libsydneyaudio-src-sydney_audio_oss.c
@@ -0,0 +1,33 @@
+--- mozilla/media/libsydneyaudio/src/sydney_audio_oss.c.orig 2010-10-12 21:45:53.000000000 +0400
++++ mozilla/media/libsydneyaudio/src/sydney_audio_oss.c 2010-10-25 23:33:08.919096567 +0400
+@@ -258,6 +258,7 @@
+ int
+ sa_stream_destroy(sa_stream_t *s) {
+ int result = SA_SUCCESS;
++ pthread_t thread_id;
+
+ if (s == NULL) {
+ return SA_SUCCESS;
+@@ -265,8 +266,10 @@
+
+ pthread_mutex_lock(&s->mutex);
+
++ thread_id = s->thread_id;
++
+ /*
+- * This causes the thread sending data to ALSA to stop
++ * This causes the thread sending data to OSS to stop
+ */
+ s->thread_id = 0;
+
+@@ -281,6 +284,8 @@
+
+ pthread_mutex_unlock(&s->mutex);
+
++ pthread_join(thread_id, NULL);
++
+ /*
+ * Release resources.
+ */
+
+