aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey2
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2005-01-21 09:11:38 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2005-01-21 09:11:38 +0000
commite44e1d3968d62d3f93afaf0a370e3550a7fa7514 (patch)
treec802d9d074e2c98675267effe66cdaa42103befa /www/seamonkey2
parent0be1727ef2837484d1ee99018ab79dc525efb5e7 (diff)
downloadports-e44e1d3968d62d3f93afaf0a370e3550a7fa7514.tar.gz
ports-e44e1d3968d62d3f93afaf0a370e3550a7fa7514.zip
Notes
Diffstat (limited to 'www/seamonkey2')
-rw-r--r--www/seamonkey2/Makefile4
-rw-r--r--www/seamonkey2/files/extra-patch-nsSVGLibartGlyphMetricsFT.cpp42
2 files changed, 0 insertions, 46 deletions
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index 9d54be6e95ee..038fafdd3269 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -199,10 +199,6 @@ FAKEDIR= ${WRKDIR}/fake
CONFIGURE_ARGS+= --enable-reorder
.endif
-.if ${OSVERSION} < 500035 && !defined(WITH_CAIRO_RENDER)
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-nsSVGLibartGlyphMetricsFT.cpp
-.endif
-
.if defined(WITH_SMB)
USE_GNOME+= gnomevfs2
.else
diff --git a/www/seamonkey2/files/extra-patch-nsSVGLibartGlyphMetricsFT.cpp b/www/seamonkey2/files/extra-patch-nsSVGLibartGlyphMetricsFT.cpp
deleted file mode 100644
index a1c0265f14b6..000000000000
--- a/www/seamonkey2/files/extra-patch-nsSVGLibartGlyphMetricsFT.cpp
+++ /dev/null
@@ -1,42 +0,0 @@
---- layout/svg/renderer/src/libart/nsSVGLibartGlyphMetricsFT.cpp.orig Sat Jul 24 23:59:16 2004
-+++ layout/svg/renderer/src/libart/nsSVGLibartGlyphMetricsFT.cpp Sun Jul 25 00:04:20 2004
-@@ -56,6 +56,12 @@
- #include "nsArray.h"
- #include "nsDataHashtable.h"
-
-+#ifdef HAVE_CPP_2BYTE_WCHAR_T
-+ typedef nsDependentString nsLiteralString;
-+#else
-+ typedef NS_ConvertASCIItoUTF16 nsLiteralString;
-+#endif
-+
- /**
- * \addtogroup libart_renderer Libart Rendering Engine
- * @{
-@@ -112,7 +118,7 @@
- nsCOMPtr<nsISVGGlyphMetricsSource> mSource;
-
- public:
-- static nsDataHashtable<nsStringHashKey,const nsDependentString*> sFontAliases;
-+ static nsDataHashtable<nsStringHashKey,const nsLiteralString*> sFontAliases;
- };
-
- /** @} */
-@@ -120,7 +126,7 @@
- //----------------------------------------------------------------------
- // nsSVGLibartGlyphMetricsFT implementation:
-
--nsDataHashtable<nsStringHashKey,const nsDependentString*>
-+nsDataHashtable<nsStringHashKey,const nsLiteralString*>
- nsSVGLibartGlyphMetricsFT::sFontAliases;
-
-
-@@ -406,7 +412,7 @@
- }
- else {
- // try alias if there is one:
-- const nsDependentString *alias = nsnull;
-+ const nsLiteralString *alias = nsnull;
- nsSVGLibartGlyphMetricsFT::sFontAliases.Get(NS_ConvertUTF8toUCS2(family_name),
- &alias);
- if (alias) {